Jump to content

Recommended Posts

  • maxmp pinned this topic

A few issues I've noticed (Samsung Galaxy A70, Android 10):

  • I have my 'Volume Levels' set at¬†50 steps, but when I use the volume +/- buttons on the phone it has gone back to the default 16 step adjustment. The actual audible gain¬†jumps all over the place when I adjust it up or down, sometimes going down a bit when I press up for example, even¬†though the on-screen indicator has gone up by one step. Same¬†with Bluetooth output volume - although I usually just leave that at maximum on the phone anyway, and use the BT device's volume controls.
  • You mention that there should now be a 150-step fine volume level option on Samsung devices, but I only see Default/30/50/76/100 on mine. (By the way, why 76 rather than 75 -¬†just seems like a strange number?)
  • Inserting a wired headset now causes PA to commence playback, even when Settings > Headset/Bluetooth >¬†Resume on Wired Headset¬†is turned off. Bluetooth connections behave¬†correctly as per the BT setting.
  • I also see the same alignment issue with Bass wording in the EQ panel in the default skins. It's OK in third-party skins.
    image.png

And not a bug, but I'm sure someone will ask before long: I assume the new Compressor/AGC feature from the stand-alone EQ app will be ported over to the main Poweramp EQ in a future update?

Andre

Link to post
Share on other sites

@Someguyonlinethe Bass wording alignment issue is not present on the $YAPS$ skin for example. However @flyingdutchmanwon't have updated his skin for the new colourful control knobs yet, so that may be linked?

I do love those new colour changing control knobs and sliders by the way, really nice job with those Max! 

Andre

Link to post
Share on other sites

@andrewilley before the nice gradient effect can be shown in a skin I suspect a new api github release is required. I have upgraded to the latest Poweramp version but the new feature does not show. On the alignment, I think that the space required for the new feature has pushed the text field to the left, hence the overlap

ps yes, the overlap also occurs in $YAPS$. I suspect I need to reduce the button sizes

Link to post
Share on other sites

also

these styles are not available whilst compiling. I believe these control the text top left of the buttons

		<item name="com.maxmpz.audioplayer:EqToneRoundKnobLabel">
			@style/EqToneRoundKnobLabel
		</item>

		<item name="com.maxmpz.audioplayer:EqToneRoundKnobValueLabel">
			@style/EqToneRoundKnobValueLabel
		</item>

    <style name="EqToneRoundKnob" parent="com.maxmpz.audioplayer:EqToneRoundKnob">
        <item name="android:layout_gravity">left</item>
        <item name="android:layout_marginRight">10dp</item><!-- NOTE: slightly offset tone round knob within its layout for better horizontal distribution -->
        <item name="android:layout_width">@dimen/EqToneRoundKnob_size</item>
        <item name="android:layout_height">@dimen/EqToneRoundKnob_size</item>
    </style>

 

Link to post
Share on other sites
On 11/19/2020 at 1:08 AM, andrewilley said:

A few issues I've noticed (Samsung Galaxy A70, Android 10):

  • I have my 'Volume Levels' set at¬†50 steps, but when I use the volume +/- buttons on the phone it has gone back to the default 16 step adjustment. The actual audible gain¬†jumps all over the place when I adjust it up or down, sometimes going down a bit when I press up for example, even¬†though the on-screen indicator has gone up by one step. Same¬†with Bluetooth output volume - although I usually just leave that at maximum on the phone anyway, and use the BT device's volume controls.

I have the same issue with the volume levels on an LG G7 running Android 9.

Link to post
Share on other sites

@maxmp see post above, I may be wrong but the styles dealing with these text fields, are in styles_eq.xml. I listed them in my earlier post

EqToneRoundKnobLabel
EqToneRoundKnobValueLabel
EqToneRoundKnob

I found that there appear to be a number of other knob styles not exposed. There are probably others

<item name="com.maxmpz.audioplayer:EqBigRoundKnob">@style/EqBigRoundKnob</item>
<item name="com.maxmpz.audioplayer:EqToneRoundKnob">@style/EqToneRoundKnobt</item>
<item name="com.maxmpz.audioplayer:EqRoundKnob">@style/EqRoundKnob</item>

the error for all of these for example : 

styles.xml:26:2-1229:10: AAPT: error: style attribute 'com.maxmpz.audioplayer:attr/EqRoundKnob' not found, 

The ultimate aim is to be able to set the size of these buttons

 

Also, Am I correct in stating another github api release is required to show the new gradient volume and sliders?

Link to post
Share on other sites

Did something change in the settings with the new EQ app and this Poweramp Player update?   I notice that when i turn the volume up or down on my phone the bluetooth devices volume also changes.   it wasn't like that before.    I did reset my phone recently and restored Poweramp settings from backup.   GS9+

Link to post
Share on other sites

Thanks for the update love the new EQ features ūüôŹ

I think there is a problem in Eq layout Bass is overlapping with tone & limit. This is not only present in the built-in skin I've same problem with luminous white skin as well

Device rdmi note 4

 

Edited by Prosenjit
Link to post
Share on other sites

I have also interesting bug when I try to adjust volume it jumps to 66% (I have 0-100 levels enabled) and it stays there and doesn't move (up, down nothing) I am using Galaxy Note 9 lastest update on OneUI 2.5 and last build 888

Link to post
Share on other sites

Quite a while since I've last been on the forums, but damm I had to come back for this one: the new customizable equalizer is amazing! The equalizer from Poweramp always was unmatched for me, but this got it to another level, allowing to yet deeper fine tuning, which I do really love, thanks a lot, Max.

I am still with the LG G7 and haven't noticed problems all this while, this includes the volume thing: the volume steps on Poweramp settings is settled to "System default (16)", but on the LG G7 the default volume steps is 75 (when Quad DAC is enabled). It works flawlessly in and out of the app, and the system volume bar always show when I press the volume buttons. It uses the 75 steps from the system with no problem at all even tho the setting on Poweramp says 16. Haven't tried setting it manually to a different amount tho.

Just one thing I have noticed: i have been using TAK files again and they still have a somewhat erratic behavior. They work fine if you click on play an leave it alone, but at higher resolutions if you try to skip to a certain point with the seek bar, it hangs for a quick moment, skip to the place you clicked and then shows a weird elapsed time, there is a screenshot showing it. You can still go to various moments of the song clicking on the seek bar, but the elapsed time will still be strange. This seems to happen on any TAK file with 176.4kHz or more and a few particularly heavy 96kHz ones as well. The files in question are from various sources but they are all at -p4m compression.

Screenshot_20201122-233040.png

Link to post
Share on other sites

as has been pointed out, the latest release has moved the labels to the left but I found this occurs only for devices with a width smaller than 400dp.

I also think there needs to be another github api update as the necessary components to show the equaliser knob highlichts are not available in the current release

image.png.074be582c5a8c6ad97447a3ed00eac44.png

 

poweramp_eq.png

 

Link to post
Share on other sites
2 hours ago, I.am.Ivan said:

Am I the only one whose Poweramp player keeps resuming right after I plug a jack, even though the "Resume on wired connections" option is still disabled?? Happened after the recent update.

Same here, thought I changed something but didn't see anything in the options.

BTW this should not be in the V2 thread. @andrewilley I think this needs to move to the V3 bug thread.

Edited by MotleyG
Link to post
Share on other sites
  • maxmp changed the title to Poweramp build 888-889

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...