Jump to content

Playlist issue


bard1964
 Share

Recommended Posts

Hello,

My first post here. Just to say, Poweramp is by far the best music app I've ever used. However, a few days ago, SD card playlists ceased to function correctly on the app, and I have absolutely no idea why (some won't play, new copies have appeared, and the count of tracks in many playlists has spontaneously decreased).  I have a Galaxy S9 running Android 10.  I have re-scanned both the Android media library and Poweramp's - the re-scan of Poweramp yielded some very minor improvement, but the playlists are far from intact. I will try my best to answer any questions asked of me, and would greatly appreciate any assistance - this is both frustrating and quite random.

Many thanks!

Link to comment
Share on other sites

Poweramp does not use the Android library, it maintains its own database of songs and playlists.

For a song to be played back in a Playlist, that audio file needs to have been found on your storage scanned into PA's library. Try a FULL Rescan in Poweramp Settings > Library, and then check that the songs that are referenced in your Playlists are present in the library Folders category (and inside the same folder names that are referred to in the Playlist). 

Andre

Link to comment
Share on other sites

Do the tracks / albums these missing tracks come from have diacritic characters in their titles? Are the playlists ASCII? If these are both true you should go into the Scanner settings and shut off "Always use UTF-8..." or make sure your playlists are in UTF-8 format.

Link to comment
Share on other sites

I doubt this is an extended ASCII issue in this case as apparently they all worked before, but you never know. If there are any international characters (outside ASCII 32-127) in your Playlists it might be worth changing them to .M3U8 format to enforce the use of the UTF-8 Unicode character set.

Andre 

Link to comment
Share on other sites

  • 4 months later...

Hi!

previously I have playlist on my Poweramp and then when I update the new version. It always keep rescan...and not responding and the I decided to uninstall and reinstall. My issue was solved but my playlist has gone...Can you tell me how can I get my Playlist back?
The reason why I install and reinstall my app because after I downloaded the new updade build 899 version 3 it keeps scanning and promp not responding...now its no longer scanning after I reinstall it, all the playlist has gone...i tried import playlist but the Playlist is 0. Can anyone help me please. I have 500- in my playlist now its gone...
 
Thank You,
 
Paul

Screenshot_20210314-094534_Poweramp.jpg

Link to comment
Share on other sites

7 hours ago, Bulletcross said:

My issue was solved but my playlist has gone...Can you tell me how can I get my Playlist back?

Unfortunately, unless you backed up your playlists to physical storage before you uninstalled Poweramp, they will have been cleared along with anything else that has been added over time to Poweramp's internal database (library contents, ratings, play counts, etc).

While it won't help for now, in future you can backup any internally created playlists by going into the Library Playlists category, tapping the menu icon (three-dots) and selecting Export. That will create permanent .M3U8 playlist files on your device's storage (which include song ratings by the way) so you can either use them again on your existing setup or copy them elsewhere for new installations/etc.

Andre

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...