Jump to content

Simultaneous output to speaker and bluetooth


Recommended Posts

MiMax 3, Stock MIUI 11.0.4

Poweramp Build 882

Issue: Sound output on internal speaker and bluetooth at the same time. Not sure if it's Poweramp or phone causing this.

Frequency: Rare, can't be replicated on demand.

Fix: Reboot phone.

Attempted fixes:

- Hardkill Poweramp

 - Reset Poweramp sound settings

 - Switching from high to normal resolution

 - Reboot of BT headset, disable/enable BT...

Other things to attempt:

 - Check some other app (I think I have done it, but I'm not 100% sure)

 - Plugin wired headset

 - Any other ideas?

What makes this even more interesting is that the internal speaker is using OpenSL and the BT headset uses Hi-Res.

Anyone else seeing something similar?

Link to post
Share on other sites

I'm not expecting any miracles on this issue as it's so infrequent and I have no way so far to replicate it. I raised it as a bug with a log file directly to Max a month ago when the problem occurred the last time, only reason for raising it in the forum is to get some ideas what can be attempted to resolve or to see if I have some soulmate out there.

I went back and checked the mail sent and there I had tested TuneIn which routed the sound properly and therefore I made the conclusion that this might be an PA "feature". But I wouldn't at all be surprised if it's Xiomi related.

This time I did switch output from Hi-Res to OpenSL and did a reset of the audio options when the issue occurred and this didn't resolve the issue. I will add the enable/disable DVC to the list of things to test next time I run into this.

Link to post
Share on other sites

I where hit by this feature again yesterday, this was actually the first time that it has happened while listening to music, it where most likely triggered by a whatsapp notification, after the duck I got audio from both internal speaker and BT speaker.

I did fiddle back and forth with the output selections, switching back and forth between Hi-Res and OpenSL, resetting audio settings, enabling and disabling DVC, disabling speaker, switching speaker to AudioTrack output... basically everything I could come up with to no avail.

Next I pulled out my wired headset, plugged it in and I got sound from the speaker and wired headset. Did the same settings toggle exercise and still dual output. Unplugged the headset and back to BT+speaker.

I did the toggle all the settings once more and something finally muted the speaker.

The funny thing is that PA claimed all the time that BT is the active output.

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...