Jump to content
Sign in to follow this  
Sara003

Can't un-pause with bluetooth headphones when screen is locked

Recommended Posts

Posted (edited)

EDIT: Problem solved 🙌 (check out answer below)

 

I got bluetooth headphones almost two years ago and Poweramp eight years ago, and have had no problem with using the headphones with the app before.

But a couple of weeks (maybe a month) ago, it started to not work properly. The sound and everything else works great, but if I pause Poweramp using the play/pause button on the headphones, I can’t start it up again with the button. Poweramp now also disappears from the lock screen when I pause, so I then have to unlock the screen, and open up Poweramp to start again where I paused.

I can pause and un-pause using the headphone button when I use my podcast app, so the problem doesn’t seem to be universal for the headphones.

If I un-pause right after having paused, there’s no problem and the music starts right back up again. But even a 10 second pause is enough for me to not be able to un-pause. There is no problem if the screen is unlocked, I’ve tried pausing and waiting a full five minutes before I un-pause, and it starts right back up.

I’ve tried “forgetting” the headphones and re-pairing them to the phone, I’ve tried rebooting the phone, I’ve tried un-checking the “react to buttons” headphone setting in Poweramp and re-checking it (after a reboot), but none of it has made any difference.

The problem might have started when I updated the Android version on my phone, but I’m not sure. It’s the only change I have made to headphones, phone or app in a while, but it might be a coincidence since I’m not definitely sure if the problems started right when I updated

 

Poweramp build number -- v3-build-882-arm64-play [882004-437be2ab]

Device model -- OnePlus 6T

Android version -- 10.3.5

Edited by Sara003
Problem solved

Share this post


Link to post
Share on other sites

It sounds like your device is in some way unloading Poweramp when it considers it is inactive, or setting some other service for receiving BT commands by default. Do you have any Battery optimisations active? Also check that Settings > Misc > "Use Wakelock" and "Keep Service" are enabled. I assume no commands are getting through to PA? You can check with Settings > Headset/Bluetooth > Last Processed Commands.

Andre

Share this post


Link to post
Share on other sites

@andrewilley  Thank you, thank you - it works now! 

It was the Wakelock/Keep service settings that did it. Don't know how/why it suddenly didn't work, but who cares, because it works now! 

Now I can go back to pausing and un-pausing to my heart's content 😄 

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

×
×
  • Create New...