Jump to content
MarkF

Can't fast forward in large mp3

Recommended Posts

Hi all,

Having a really strange issue. Been using Poweramp for years now with no issues whatsoever. 

I had recorded a live mix of the internet using audactiy and saved as mp3 extreme quality.

File is 44.1KHZ 256KBPS MP3 and it 2 hours 44 mins long.
FIle size is about 301MB.

When i try and fast forward the player just hangs for a few seconds then either starts from 0:00:00 again or skips to the next file. Really weird. The files work fine on my pc and can fast foward them.

Using a samsung S10 and have tried on internal storage and SD card. Both the same. 

I have tried using the latest beta and other versions.

Wondering if there is a limitation to how long an MP3 can be or something random.

Thanks for any help or suggestions,

Mark.

 

Share this post


Link to post
Share on other sites

Most likely your file does not contain any audio seek-point metadata - basically a lookup table which provides a quick way to seek within longer (and especially variable bit rate) files. I've had this problem with some longer podcasts where seek accuracy could drift by several minutes when you try to restore the playback position.

You could try running a backup copy of the file through a program like MP3 Diags to see if that helps? Not tried it myself, might be worth some further Googling though.

Andre

Share this post


Link to post
Share on other sites

Hi Andre,

That's very interesting. I've actually never heard of that!! I will definitely try your suggestion.

Do you think a constant rate MP3 would be better to use or would it still suffer from the same bug?

Thanks for the help. :)

Mark.

Share this post


Link to post
Share on other sites

Constant rate, and with nothing large in the header (large cover image etc) might help. But adding a seek table is most likely the best solution. 

Andre

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...