Jump to content
Jonny G

Scanning new files into library

Recommended Posts

Just installed latest Poweramp today (26/07/2020), unsure exactly what the build number is but in app changelog shows 875-879. However, this is an issue that has affected every version of Poweramp I have ever installed on my Android headunit. It's currently running version 9, on a custom rom from a guy named Hal9K available on the XDA forums. 

I've just added a few hundred meg of (correctly tagged) audio files onto my external SSD connected via USB to the headunit. Checked that the new folders are ticked and tried to rescan. Only a handful of the new files are added. Cleared cache, cleared storage, re-added the folders and tried to start a new library scan. Only a seemingly random amount of files are added to the library. The app has USB access, I have scanning set to manual only, I'm out of ideas. Could anyone with any thoughts please suggest something else I can try to get Poweramp to reliably scan new music? 

Share this post


Link to post
Share on other sites

Hi, I'm still experiencing the above problem, seemingly random folders are missing from my music library despite how many times I rescan. All my folders are correctly ticked. 

I've checked the FAQ for an answer, but unfortunately haven't found what I was looking for. 

If I've not submitted this bug report correctly, please could someone just give me a pointer on how I can improve my chances of getting some assistance?

Many thanks.

Share this post


Link to post
Share on other sites

It's a hard one to diagnose as you are using an unsupportable custom ROM on an unknown device, with an SSD drive connected to a USB port rather than device internal memory or normal Android SD Card access. There are so many possible variations there that it's hard to even work out where start. It sounds like file access is not occurring fast enough, but that's really more of a guess than anything. Are these regular MP3 files, or high bitrate/FLAC/etc? What happens if you try some tests using internal memory, or a more normal Android storage method?

You could try running a manual FULL Rescan and see how many songs are recognised compared the number that are present on your drive, and then immediately submit a log via Settings > Get Support > Send Log > email to gpmaxmpz @ gmail.com. Post a message here to say you have done it (or DM @maxmp so he knows to look for it).

Andre

Share this post


Link to post
Share on other sites

Hi, thanks for getting back to me.

I can say for a start that I also experience this problem when using a microsd card plugged directly into the unit. 

I take your point re: the custom rom but it would seem to me that if it's possible to find and scan one track into the library, it should be possible for it to do them all.

Case in point, tracks that were previously in my library are now omitted following the full rescan. None of the filenames or locations have changed.

I can access and play all the files using the headunit's file manager, it only seems to be Poweramp that has difficulty in reading them.

The last time this issue occurred (on an older version) the only way I could get Poweramp to fully scan all my media was to scan the folders in chunks, rather than all at once. so A to D, E to H, etc, etc. The folders do contain approx 150GB of media, could it just be too much for the scanner?

Share this post


Link to post
Share on other sites

The scanner can handle any amount of files, I still think the most likely cause is the speed at which your device/ROM/USB connection can read the file system. Sending a log file as I suggested might help.

Andre

Share this post


Link to post
Share on other sites
6 hours ago, andrewilley said:

The scanner can handle any amount of files, I still think the most likely cause is the speed at which your device/ROM/USB connection can read the file system. Sending a log file as I suggested might help.

Andre

I have 25k+ files that are aver 250GB on an external 400GB uSD card. All tracks scan as expected in PA. So the issue is not PA specific, but something that needs to be resolved with your device.

Share this post


Link to post
Share on other sites

There definitely IS an issue with the scanner related to Poweramp (I have a full stock Samsung).

For some time now, I sometimes notice that some albums disappear from the library. Turns out that the scanner randomly removes full folders (I have each album in its dedicates folder) from the library. I have to launch a manual rescan each time for them to reappear.

Also, when Poweramp is playing and you delete a completely unrelated folder from the SD card, Poweramp stops as if you deleted the currently playing song and it disappears from the library (even though it's not, at all, the file you deleted).

Share this post


Link to post
Share on other sites

Issue still present. I was listening to an album, paused and closed the app to do something else and when coming back to resume my playing, the time Poweramp rescanned the library, that album just disappeared from the library. I had to rescan the library once again for it to reappear.

Edit: just noticed that after that issue happened, those numbers in the parameters (attached image) are completely false. That not even half of what I have in my SD card (I have at least 20'000 tracks in 2600 folders). The scanner seems to skip entire folders because each time entire folders are concerned. 

Also, please note that issue is present only in Poweramp. Until this is resolved, I have to use another player (because it happens at least once a day which makes it totally unreliable and a hassle) and it doesn't happend in other players.

 

Screenshot_20200912-180019_Poweramp.jpg

Edited by hrolf1713

Share this post


Link to post
Share on other sites

For the record, it happened again today, in worse. After a rescan, everything goes to normal again. Still no issues with other music players. 

Screenshot_20200913-191257_Poweramp-01.jpeg

Share this post


Link to post
Share on other sites
35 minutes ago, hrolf1713 said:

For the record, it happened again today, in worse. After a rescan, everything goes to normal again. Still no issues with other music players. 

Screenshot_20200913-191257_Poweramp-01.jpeg

Is it possible one of your other players is updating the file when Poweramp is not active? Either changing the file name or rating perhaps? Seems something is causing PA to lose access to these files on your phone.

I have 25k+ songs organized by Artist/Album/Track#Name and have never had this issue. I'm on Android 10 currently with an LG G8 thinQ. So not that you are not having an issue, but just providing some reference.

Maybe try turning off the Auto-Scan feature in the Library/Scanner options so it only refreshes when you force it?

Share this post


Link to post
Share on other sites

When this issue occurs next, as soon as the scan has finished please can you send a log via Settings > Get Support > Send Log, and also post a comment to let @maxmp know what you've sent. It does sound like a file system issue though. Just in case it makes a difference (as you don't mention what device or Android version you have) it might be worth trying to enable Settings > Misc > File Access Legacy Mode.

Andre

Share this post


Link to post
Share on other sites

It can be also the issue with Android sending scan request when storage (sd card) is not yet available. Log will definitely help. Thanks!

Share this post


Link to post
Share on other sites
On 9/13/2020 at 7:58 PM, MotleyG said:

Is it possible one of your other players is updating the file when Poweramp is not active? Either changing the file name or rating perhaps?

That's very unlikely as I reinstalled another player because of this problem (I use Poweramp for almost as long as it exists, I really don't want to use another player in the long term, but I had to find a temporary solution as especially at work I close/open the player several times a day, so it happens often and is a bit of a hassle), so it happened before that.

I have a Samsung Galaxy S9 in Android 10. And my usage is relatively "sober" so it never changes much (no phone updates, no new apps since then), I just keep my apps updated and reboot my phone every now and then. I can't think of any issue that can be caused by other apps as nothing changed between before and after the issues began.

On 9/13/2020 at 7:58 PM, MotleyG said:

Maybe try turning off the Auto-Scan feature in the Library/Scanner options so it only refreshes when you force it?

That would be an acceptable resolution if it works. I'll try that, thanks.

On 9/14/2020 at 12:57 AM, andrewilley said:

When this issue occurs next, as soon as the scan has finished please can you send a log via Settings > Get Support > Send Log, and also post a comment to let @maxmp know what you've sent. It does sound like a file system issue though. Just in case it makes a difference (as you don't mention what device or Android version you have) it might be worth trying to enable Settings > Misc > File Access Legacy Mode.

Andre

I'll try the option you mentioned. Will definitely send logs the next time ! Thanks.

On 9/14/2020 at 5:43 PM, maxmp said:

It can be also the issue with Android sending scan request when storage (sd card) is not yet available. Log will definitely help. Thanks!

I will try to send logs ! Thanks.

Share this post


Link to post
Share on other sites

@maxmp, I just send you logs. It happened just after I launched a manual scan (so @MotleyG, disabling auto scan is unfortunately not a solution 😞 ), not so long after I put a new folder into my SD card. I copied the folder from a local network drive to my SD card so I haven't disconnected my SD card and I was without any issue accessing my SD card through my phone file manager just before that. It stopped what I was listening to. Also, as I have a lot of songs, each time it takes 4-5 minutes for PA to "rebuilt" the library so I have to wait that time before I can listen to anything.

Edited by hrolf1713

Share this post


Link to post
Share on other sites
2 hours ago, andrewilley said:

Can you PM Max with the email address you sent the log from, makes it easier to find specific reports.

Andre

Sure !

Share this post


Link to post
Share on other sites

Thanks for the logs, nothing relevant (except it takes 12 sec. for 18k songs, though full rescan will be much slower), no complains in the log. If you notice something disappears when it shouldn't, please share that particular folder/album (may be just a few songs from a folder + CUE if it's there) - I'll test it's related to the particular files/CUE.

Also please note that Poweramp scanner (at least in "fast" modes, that are all rescan modes except the Full Rescan) is very date/time dependent (for both files/folder timestamp and the device time) and may react inadequately if date/time has been recently changed on the device AND some file activity happened (thus folder last modified timestamps jumped). Poweramp compares recorded modification time vs filesystem timestamp (which is device time dependent) and scans or skips scanning in fast mode, causing some folders which jumped time being removed from database. Full Rescan fixes that. Time zone changes don't affect scanning.
 

On 8/31/2020 at 10:47 PM, hrolf1713 said:

Also, when Poweramp is playing and you delete a completely unrelated folder from the SD card, Poweramp stops as if you deleted the currently playing song and it disappears from the library (even though it's not, at all, the file you deleted).

This may happen in some modes when the currently played list is changed so we can't continue (e.g. all songs, or shuffle all or other shuffle mode, which includes tracks from the removed folders). But generally Poweramp should continue, so if it happens while isolated list is played, I would be grateful for the details (what category, what format played, what repeat/shuffle mode was used, etc.). If it's a consistent behavior (happens every time) short captured video will help a lot.

Thanks!

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...