Jump to content

ReplayGain / R128Gain problems


null
 Share

Recommended Posts

  • 1 year later...
  • Replies 28
  • Created
  • Last Reply

Top Posters In This Topic

Top Posters In This Topic

Hi, I'm experiencing this same problem with the volume of Opus files being extraordinarily low with ReplayGain turned on. I read through this thread and I already manually cleared the Opus Header Gain tags in foobar2000. I scanned ReplayGain tags in foobar (scanned as albums, with a 4x oversample True Peak enabled.) I checked the tags and the header gain tags were indeed removed. When I play opus files in Poweramp with track ReplayGain turned on (I always listen to music in shuffle mode,) the volume is very low. When I listen to the same exact files using other Android music players like GoneMAD or Pulsar, it's the correct volume and much louder. In my estimation, around 10dB louder. I made sure the RG preamp settings are the same for each app (set to 0.) I also followed the directions in the above linked thread, and set the Opus header gain tags in foobar's advanced settings to "Null". 

I have attached a sample Opus file for reference.

ID3 tags for the file:

image.png.5002c85340c00be9b9a73e6de8b0f5ad.png

 

Opus file: https://drive.google.com/file/d/1iOg_yaSVzPuikvEcy0G-QG454KuxAG7t/view?usp=sharing

 

Link to comment
Share on other sites

2 hours ago, dankim said:

Hi, I'm experiencing this same problem with the volume of Opus files being extraordinarily low with ReplayGain turned on. I read through this thread and I already manually cleared the Opus Header Gain tags in foobar2000. I scanned ReplayGain tags in foobar (scanned as albums, with a 4x oversample True Peak enabled.) I checked the tags and the header gain tags were indeed removed. When I play opus files in Poweramp with track ReplayGain turned on (I always listen to music in shuffle mode,) the volume is very low. When I listen to the same exact files using other Android music players like GoneMAD or Pulsar, it's the correct volume and much louder. In my estimation, around 10dB louder. I made sure the RG preamp settings are the same for each app (set to 0.) I also followed the directions in the above linked thread, and set the Opus header gain tags in foobar's advanced settings to "Null". 

 

Going off my last message...I was digging into Poweramp's audio settings and I see that under "Direct Volume Control", the 'No DVC Headroom Gain' default setting is -6.0dB. That seems to account for the volume difference between Poweramp and other apps like GoneMAD and Pulsar. Setting it to 0 seems to balance out the volume I'm hearing between apps. Is it recommended to keep 'No DVC Headroom Gain' at -6.0db? Will it diminish the audio quality in any way to set it to 0? I see that the description for this setting is linked to equalization, but I personally never use any sort of equalization when listening to music.

Link to comment
Share on other sites

The "No DVC Headroom Gain" setting is only used if you do not have DVC enabled for your current listening method. If DVC is turned on, it is inactive. The setting is used to allow some breathing space in case of EQ adjustments on recordings that are already at 100% digital maximum volume, which otherwise DVC would handle.

ReplayGain is much the same, it is mean to set all songs so their peak levels are the same between tracks. The default in the spec is to set that target level at 14dB below 100% digital maximum, although I don't think PA goes quite that far. You can adjust that target point within PA's settings though, if you want to make your music louder but do not intend to use any EQ boosting.

I seem to recall a thread a few years back about ReplayGain not playing nicely with OPUS files, but I assumed that had been resolved. [Edit: Ah, it was this thread we are already commenting in. :) ]

Andre

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...