Jump to content

Can't seem to install on Android 5.1.1


Recommended Posts



Recently I bought this app as it seemed to be well recommended for using in car head units. On my device in the 'about' part I have:

Processor type: QuadCore-R16 1.6G

Android version: 5.1.1

And in the appstore it says "Required android: 5.0 and up". This lead me to believe that it would be ok to use. 

However, I get the "cannot be installed on your device" message when trying to install directly on the device with the appstore. I am not super well versed on android quirks so I am not sure how to go about debugging this. Is there a separate version which can be downloaded and manually installed after purchase to get around this issue, or some other steps I can try to debug it?

Appreciate your help and have an awesome day, 



Link to comment
Share on other sites

  • 1 month later...

hello @flyingdutchman, sorry I have not been able to look into this for a while -- life. 

Anyway I was not sure about your reply. I assume that you mean that I should try to sideload it from that download link. I can't seem to get that to work well. Please see the following photos regarding the issue:






Do you have any suggestion about how I may install the software in this case?

Thank you, I appreciate the support!


Link to comment
Share on other sites

The latest available website download is at: 


Just copy that APK file onto your device's internal memory and launch it from a file explorer app (not browser) and it should normally be able to install on an Android 5.1 device. Do you still see the same error message? What memory size is your device?


Link to comment
Share on other sites

@andrewilley @UK_SPAWN , 

I installed ES file explorer and RS file explorer and tried to install the 8.8.0 new version with both. I got the 'error parsing' message in both cases. 

I went to the developer options and unchecked the "allow apps to be installed from other location" and tried and checked it again and tried. Still parse error in both cases. The developer menu also has it's own button to install APK but this also fails with the parse error. 

For the memory I am not sure where to find this information -- it was not obvious. Do you know how to check?


Thanks for reading!

Link to comment
Share on other sites

All i can suggest is:

1) Update your android version if possible
2) Try an older or different version of the App
3) Enable permission to install unknown apps
4) Try downloading again using a different browser
5) Try With USB debugging on
6) Disable Security/antivirus and things like that and try to install again.

if none works then the app is probably not compatable or there is something wrong with the android install on the device.


Link to comment
Share on other sites

@sona1111 I don't think your device is using Android 5.1.1 in the first place. Looks like your device is running Android 4.4, and relabeled as android 5.1.1 (yes this is fake Android Lollipop lol). Try to install v2 (or alpha v3 build) instead

Why don't you try to tap the Android version 4 times and see what comes out?

Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

  • Create New...