Jump to content

Enabling No Duck/disabling Short Focus Audio doesn't work


Recommended Posts

Phone: Realme C2

ROM: Color OS 6 @ Anrdroid 9

Poweramp version : build 871

 

I have a problem when I try to turn off Short Audio Focus when using whether MTK Hi-Res / OpenSL Hi-Res output (from previous build). The audio will sound like in telephone/voice chat mode (mono and quite sound) when the notifications come in.

Same goes to No Duck Option. When I turn on Short Audio Focus and No Duck options, notifications keep interrupting audio instead of ducking it.

Link to post
Share on other sites

Some devices can't handle multiple audio streams with Hi-Res + DVC enabled. Poweramp automatically has proper default settings to avoid any artifacts. As you tweaked those, you may try also tweak e.g. Audio / Advanced Tweaks / Emulate Media Stream or/and DVC options. Thanks!

Link to post
Share on other sites
On 5/21/2020 at 3:25 PM, andrewilley said:

Does happen in regular OpenSL (non high-res) output too?

No. It only affects the Hi-Res output

16 hours ago, maxmp said:

Some devices can't handle multiple audio streams with Hi-Res + DVC enabled. Poweramp automatically has proper default settings to avoid any artifacts. As you tweaked those, you may try also tweak e.g. Audio / Advanced Tweaks / Emulate Media Stream or/and DVC options. Thanks!

I will try it tomorrow after my sister wakes up. thanks.

Link to post
Share on other sites
  • 3 months later...

sorry for very, very late report. I completely forgot this problem since i always turned off my notification while playing music to avoid distraction while listening music 😂🙏

in this current build (882), the problem is even worse. The sound is completely interrupted (silent) in short time during notification alert popped out, even though i disabled the short audio focus in settings.

i tested it using MTK hi-res output. Could you fix this bug please?

Link to post
Share on other sites

It may just be an issue with your device's internal audio feature not being fully compatible with running a high-res audio output at the same time.  I assume you've tried Max's advice and checked to see if disabling DVC helps, and also tried Restore Defaults in Settings > Audio > Output. There are a couple of options in Settings > Audio > Advanced Tweaks you could try too (Force Audio On Audio Focus Change. and Emulate Media Stream and both worth trying).

Andre

Link to post
Share on other sites

Try disabling high-res and use Open-SL ES output. It sounds like this might be issue with your phone not playing nicely between its own (regular) audio needs and apps running high-res at the same time. There are several places where you can try to disable DVC by the way - both in the main DVC settings and the individual Output pages - I assume you've tried them all?

Andre

Link to post
Share on other sites

But I need Hi-res output tho. The sound is very clean than using regular output.

Is there any way to use OpenSL ES hi-res instead? Because i think it has no problem in short audio focus now instead of using MTK hi-fi output.

Edited by M Akmal
Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...