Jump to content
Sign in to follow this  
Wolfpig

Hires Output broken?

Recommended Posts

Hi.

As i got yesterday a new phone i wanted to test Poweramp with it and had to notice that the hires playback is not working (Bluetooth headphones).

As i saw the thread of the other guy, i first tried to disable dac & also shut off the max volume option in the dev options off the phone to see if it might work...but it does not. If i try to play a file trough HR output it seems that the file is not played at all (keeps at the same position where it starts, the visual slider moves a bit and jumps to start position).

Playback with the non hires options works fine.

As i dont know if it is caused by Poweramp, the rom of the device (cant roll back to an earlier version as this is the shipping one) or something else.

 

Share this post


Link to post
Share on other sites

Please give more details, starting from your Poweramp build, Android device/version and why do you think it doesn't work and how exactly it doesn't work (no hi-res output available, silence, something else).

Thanks!

Share this post


Link to post
Share on other sites

Weird, put the logfile yesterday in the post but seems it vanished (or someone deleted it).

When i try to play Audio trough the Hires Output to my Bluetooth Headphones (Sony WH 1000xm3...hires capable) the Audio does not play at all/stops at start position (that it tries to downsample it to 24bit/48hz might be another issue or tied to it....no idea)

Another BT Device (bt dongle in my car, not hires capable) shows the same issue.

If as Output the OpenSL/Java is used files get played 

Tried it with dvc on/off but happens regardless of that.

Used Device:

Xiaomi Mi 10 Pro (global)

Andrioid 10/Miui11.0.7.0

Poweramp log from yesterday

https://pastebin.com/PkQ3RS84

One i created right now

https://pastebin.com/tRrgdGAh

Video of the issue

 

Share this post


Link to post
Share on other sites

@Wolfpig Thanks for the video and details. Behavior like this means Android doesn't accept audio at this moment. Phone reboot should resolve this (provided everything else is OK, like BT connection, etc.) If you recently ROM I would suggest re-pairing the BT device. Also, please try AudioTrack output (it's also capable of 96kHz LDAC output). 

Share this post


Link to post
Share on other sites

Thanks.

The Audio Track Output seems to work with at least 24/48.

But for some reason Poweramp is downsampling from 96khz to 48 while the device (according to the info at the options in the dev options) is sending 96khz.

 

A "problem" from the app or have i set something wrong?

 

info.jpg

Screenshot_2020-04-23-15-50-37-811_com.android.settings.jpg

Share this post


Link to post
Share on other sites
1 hour ago, Wolfpig said:

But for some reason Poweramp is downsampling from 96khz to 48 while the device (according to the info at the options in the dev options) is sending 96khz

What are the value set in Settings > Audio > Output > (device) for your desired output method?  

Andre

Share this post


Link to post
Share on other sites

In the Audio Track output i cant change the values (defaulted there to 24/48)

In the not working Hires Output (where the same happens according to the audio info screen) i had it set to 24/96.

Share this post


Link to post
Share on other sites

@Wolfpig At this moment, hi-res output on Mi 10 is not supported - Poweramp will fail to load hi-res on Snapdragon 865. As soon as my test Mi 10 allows me to debug apps on it, that will be fixed. Thanks!

PS Support added (build 869 - soon to be released).

Share this post


Link to post
Share on other sites

Thanks for the info.

Just asked it as i was not sure if it was a Poweramp problem or a bug in the MI OS.

 

 

Share this post


Link to post
Share on other sites

@Wolfpig For the 865 it seems MIUI lags a bit too as no DVC + Hi-Res is possible on USB-3.5 dongle (11.0.9). Though it works OK for Bluetooth LDAC or LHDC.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

×
×
  • Create New...