Jump to content
Poweramp
maxmp

PowerAMP v2.0 (Release)

Recommended Posts

maxmp,

how to enable the auto advance feature , what i want is , after the last song played , the Poweramp can move to music folder following with , it worked fine when with 1.4

Look here. I had the same question. ;)

Share this post


Link to post
Share on other sites

Hey. Thanx for the release but there seem to be some huge bugs for Samsung Galaxy. I Have S2.

- First of all, the worst: it doesn't seem to find any embedded album arts on my m4a files. 1.4 did this with no problems and i had to revert back to it.

- Second, it seems to do a full library scan every time the phone is restarted, which basically means i have to wait a huge time before getting to listen to music. On top of that, Samsung has its on media scan that it does on all restarts and it used to be simultaneous with 1.4 but with 2.0 Samsung first does the scan, and after that, Poweramp starts its scan from scratch.

- Third, I have music on my phone's internal memory and on my sd card. When the program starts for the first time, it doesn't seem to search my internal memory, and this is a problem because I have some playlists with music from internal memory and therefore those playlists are missing those tracks and the only option then is to add them manually (which is a huge pain because there are so many)

- I actually didn't check if this was a problem but if in 1.4 you saved some EQ presets for some songs, are those same presets saved to 2.0? Even if the presets are your own made?

Basically, I would really appreciate it if you could tell me are you going to consider these Samsung issues on future fixes? Because right now I'm unfortunately stuck with 1.4 even though it's great, 2.0 has a lot of qualities I would have found extremely useful.

Share this post


Link to post
Share on other sites

Love the new release. Really good to have ratings and persistent shuffle. Apart from the "Top Rated" list, is there any way to use the ratings? On my iPod, I could create a custom playlist that was (e.g.) all songs rated 4 stars or higher. This would be really useful in Poweramp.

Share this post


Link to post
Share on other sites

Hi maxmp,

Thank you for the new release!

I have been following the beta threads but I never tried any of the beta releases, only the full release from the market. Anyways, I have seen somebody report that Replay Gain from ID3 tags are not applied and I see the same thing in the full release. When playing a track with RG info created in FooBar2000 the "RG preamp" setting has no effect whereas the "Preamp for songs without RG" does have effect.

I have also seen that you have requested an mp3 file that shows this behavior before. Have you already received one from the previous person that reported this? Otherwise I could send you one.

Cheers

Share this post


Link to post
Share on other sites

defecz

Please send (one) m4a file with missing in PowerAMP album art to poweramp.maxmpz gmail.com.

yhrn

Sorry, I can't reproduce that, all my Foobar2000 created rg info is read ok from mp3 files. Please send your failing song to poweramp.maxmpz gmail.com for testing.

Note that PowerAMP understands RG info only if it's written in tag format native to file, i.e. ID3V2 tag for mp3 (APE RG tag won't be processed for mp3), etc.

Thanks!

Share this post


Link to post
Share on other sites

hi, i just updated the app, and i have only one problem, but very big. music stops playing after about 1 minute and 10 seconds. i tried with several tracks, and i tried with the phone locked and unlocked, and the behaviour is always the same.

pd: music doesnt pause, it stops completely.

pd2: now its even worse. now music stops, and the screen goes to desktop, at about 35 seconds, but it seems that the process is not killed, since the Poweramp notification is still on the notifications bar.

Share this post


Link to post
Share on other sites

Max,

Why havn't you answerdd my simple question on the Backup PA's Settings to SD feature. You stated long before first v2.0 release builds that this feature would make it's way into v2.0. Have you run into any sudden limitations on the feature or something.

If Poweramp had the ability to backup settings to a cloud then surely the same thing for users to their SD cards too. Thank you.

Share this post


Link to post
Share on other sites

yhrn

Sorry, I can't reproduce that, all my Foobar2000 created rg info is read ok from mp3 files. Please send your failing song to Poweramp.maxmpz gmail.com for testing.

Note that Poweramp understands RG info only if it's written in tag format native to file, i.e. ID3V2 tag for mp3 (APE RG tag won't be processed for mp3), etc.

I have sent you a file now. Hope you can make something out of it. Please get back to me if the email doesn't arrive.

Thank you

Share this post


Link to post
Share on other sites

I just downloaded the 2.0 (update of the 1.4) and it runs well.

I'm pretty happy with the grid view but I would like to know if it is possible to reduce the size of the album cover ?

Currently, on my SG2, I only see 4 full covers and 2 half cover. I would like to see more than 4 and 2 half.

Also, can I remove the album's name and artist ?

I have the cover so I do not need them and with the "gained surface", more covers can be displayed.

By the way, 2.0 doesn't handdle pictures as the previous version. I have rename all the picture to "cover.jpg" in order to make it work.

Also, some pictures are not handled because they are too big. I do not know if they are too big in KB or in "pixel". I donwsized them by 50% and they are now handled correctly.

Share this post


Link to post
Share on other sites

Great interface and lots of improvements. However, now PA handles it's own library, podcasts in folders that were previously excluded from stock player library, now appear in PA. This is a real pain when the 'Shuffle all' function is on, as it will now include podcasts. You really need to put in an 'ignore folder on shuffle' function when selecting media folders to scan in PA.

Hope you sort something out, as this has already become a pain, as I have many podcasts and will now have to exclude podcasts from PA entirely and use stock player or another alternative.

NOTE: I have previously posted this here:

Share this post


Link to post
Share on other sites

Ok, I have a question - isn't Poweramp supposed to support CUE sheets? When I play one of my flac albums it just plays it as one file and there isn't any track separation. When I play the same album in neutron player, for instance, all the songs are separated as in a normal album.

Share this post


Link to post
Share on other sites

Ok, I have a question - isn't Poweramp supposed to support CUE sheets? When I play one of my flac albums it just plays it as one file and there isn't any track separation. When I play the same album in neutron player, for instance, all the songs are separated as in a normal album.

Didn't have any issues with my CUE sheets during the month of beta testing. I'd suggest pasting yours here or emailing it to support.

Share this post


Link to post
Share on other sites

vincientjames

Please check your sd card for errors, obviously some broken file stops the scanning.

sirv3rt1go

richard127

http://forum.poweram...ndpost__p__7079

apertotes

http://forum.poweram...ndpost__p__6252

how to enable the auto advance feature , what i want is , after the last song played , the powerAmp can move to music folder following with , it worked fine when with 1.4

Keep pressing Repeat icon until Advance list mode.

patokadonald

CUE sheets (when recognized) are represented as virtual folders (marked with .cue icon in Folders view) and as separate tracks in library

Re: SGS2 non stock ROMs - looks like these has modified filesystem for internal flash, which doesn't support last modified stamp, which is absolutely required for incremental scan (on reboots). There are no any issues as highlighted in this topic on stock SGS2 roms (this is my everyday phone, btw). Non stock ROMs are generally not supported by PowerAMP - it's not possible to support like at least 10 roms per each phone out there and workaround their bugs, sorry. Still, I will probably add option to disable automatic scan completely - this can be useful for stock ROMs as well.

anton79ru

You may get better results for some buggy ROMs by disabling Direct Volume Control in PowerAMP Audio Engine Advanced settings.

Haddy

Settings, including eq/tone presets is planned feature for PowerAMP v2.1. It was deferred for 2.0 as it could move the release date by week.

yhrn

Thanks for the file. I was able to identify the issue which is related to ffmpeg + utf-16 encoded tags (it works for ansi and utf-8 encoded). Will be fixed in PowerAMP 2.0.

CptDobey

You can get 4 per row in horizontal view. I will think about configurable # of colums. Thanks for the request.

PowerAMP 2.0 have additional album art options, for example, it can prioritize cover.jpeg or not for lists/main player.

Also, PowerAMP 2.0 doesn't use android system library and thus it doesn't use android resolved system library album art.

Thanks!

Share this post


Link to post
Share on other sites

yhrn

Thanks for the file. I was able to identify the issue which is related to ffmpeg + utf-16 encoded tags (it works for ansi and utf-8 encoded). Will be fixed in Poweramp 2.0.

Happy times! Thank you for a great app and great support!

Share this post


Link to post
Share on other sites

Still, I will probably add option to disable automatic scan completely - this can be useful for stock ROMs as well.

When you do this, please could you also add a quick third option to force a rescan whenever launching the main PowerAmp program? That'd help folks like me who have podcast folders which update regularly.

So the new 'Automatic Rescans' option would be something like:

  • Auto
  • Startup
  • Never

Andre

Share this post


Link to post
Share on other sites

vincientjames

Please check your sd card for errors, obviously some broken file stops the scanning.

Thanks for responding, however I had 0 issues with these same files, and 0 issues with the android music player or mobo player. Upon further inspection I noticed that the files are being added but the ID3 tags are being read wrong. All my music shows up under "songs" but none under artist, album, or genre. And yes I have made sure that my IDv3 tags are correct with my music. I've used MP3 Tagger Pro to fix any tag issues I've had in the past. As I said, I've had Poweramp on my device since the first day I got it and had 0 issues with the library, all I did was simply install the update; none of the folders or files changed, I didn't do anything with the SD. And all of my music plays just fine If I dig for it through the "folders" view.

Share this post


Link to post
Share on other sites

How do I see what songs are in a playlist? The only way I could find was by queueing them up which leads me to my second question, how do I clear the cue list?

Also, as has already been asked in this thread, how do I keep music and non-music files separate?

Thanks.

Share this post


Link to post
Share on other sites

The library problem I've mentioned in this post still hasn't been addressed.

Fig. 1 - compilation albums aren't marked as such (the "True Blood" soundtracks).

shot000001k.png

Fig. 2 - Multivalue genres aren't split, for some obscure reason the semicolons are displayed as colons.

shot000004o.png

The files have standard ID3v2.3 tags created in foobar2000 (ie. "VA" as album artist and the semicolon splitter in multivalue genre field).

I didn't check whether multiple artist albums that aren't compilations per se are displayed correctly, but I guess a similar problem applies.

Share this post


Link to post
Share on other sites

Any hint on when v2.1 will be out? I'm hanging for the embedded star ratings. I understand you don't want to give dates because people will be bugging you if the development doesn't go to schedule. But is it likely to be a week, weeks or months?

Poweramp has well and truly been worth its money. I bought it with the functions it had about 1 year ago so anything since has been a bonus if you ask me..... But it doesn't stop me wanting more :)

Share this post


Link to post
Share on other sites

I am having problems with Flac embedded art. The art shows up fine in the Library. If i turn on the "Show CUE disc image files" option in the library a nine song file will show up as 10 songs (the tenth being the entire flac file). Then if i play the album (in the player view) tracks 1-8 will display album art and track nine will show the Poweramp logo and the tenth track (the single track of the entire flac file) will display the embedded art also. This does the same behavior regardless of the number of tracks, the last track before the single flac track does not display album art.

If i turn "Show CUE disc image files" off, which is what i want to do, the album art thumbnails display correctly in the library but nothing but the Poweramp logo displays in the player. I checked my flac file and the art displays correctly in foobar2000, squeezebox server, amarok, banshee and songbird, as well as in the library view of Poweramp.

If i miss configured something let me know, otherwise I can do anything to test further. I chose Poweramp because all my CD's i have encoded in flac with embedded art and it is nice to have an android player that works correctly with embedded tags (the tags work great.

Thanks

sean

Share this post


Link to post
Share on other sites

Look here. I had the same question. ;)

I still dont get it, after the last song played in the folder, screen pop up 'list finished' and stay , not advance to next folder .

g

Share this post


Link to post
Share on other sites

Trying to figure out a few things on this new release.

How do I disable the track counter on the widget?

The volume of my preset equalizer gets screwed up sometimes when I adjust it with the phone's buttons, switching off and back. Not sure what causes this.

Why is shuffle/repeat switches forced with the rating switches on lockscreen? I'd prefer not to have that on the screen.

Why does it need to rescan randomly when I boot? I noticed a few others have mentioned this, I have a G2X with the Weapon G2X rom.

Whenever I click on the widget on my homescreen, it doesn't always take me to the Player screen even though I have the Startup Screen set to the player. It seems that if I don't hit home while on the player, it doesn't take me there when I press on the widget and it just takes me to the Library. Any way to correct this?

Any plans for different lockscreens? I liked the old one very much where everything was on the bottom of the screen with my clock alone on the top of the screen.

Also, I downloaded the widget pack, but none of the widgets seemed different from the regular included ones at all, options and look. What's that about? Very happy about finding the older theme on the market, didn't like any of the new ones at all.

Share this post


Link to post
Share on other sites

Impressions of 2.0:

  • GOOD: Much less cluttered "home" view - less chance of hitting the wrong button when trying to do something (e.g. hit shuffle instead of advance)
  • GOOD: Persistent shuffle session - that was the most frustrating thing about the previous version IMHO
  • GOOD: Sound appears to be much crisper
  • Not-so-good: the progress bar is way too thin (in the default skin anyway) so can't drag back to point 0:00 in a track (with my biggish fingers anyway)
  • BUG: on upgrade my Folder playlists from the previous version were emptied (note, NOT deleted, but emptied). All folders were registered with PA in the previous version and stayed registered in this version.
  • BUG: seems every track has at least one hiccup in playback now (Samsung Galaxy S, Gingerbread) - playback was as close to flawless as possible in the previous version.

General impression - pretty good - looking forward top minor issue fixes.

Share this post


Link to post
Share on other sites

×
×
  • Create New...