Jump to content
Sign in to follow this  
Lowlow

Track skipping after car bluetooth connection

Recommended Posts

Hi,

I had Poweramp running fine with my previous car but since I got a new one..when it connects/autoplay (whether by starting the engine, being paused because of external interruptions, etc) the track that was paused is just skipped.

Must say that this is quite boresom as I got a lot of tracks of 120+ minutes ;)

It seems that this issue exist since a while
https://forum.powerampapp.com/topic/5052-often-skips-to-next-track-after-car-stereo-returns-to-bluetooth-music-playback/

But anyway, maybe since then a fix has been found.

Cheers!

Share this post


Link to post
Share on other sites

First, did know that for longer tracks, PA can permanently remember your last played position, even if you return to the track after listening to lots of other stuff in the meantime? Settings > Library > "Store/Restore Per-Track Progress", and you can also adjust how long any track needs to be before that feature triggers.

For the Bluetooth issue, after this incident happens please could you check Settings > Headset/Bluetooth > Last Processed Commands to see a list of what actions have been requested by the BT device.

Andre

Share this post


Link to post
Share on other sites

I did know about saved positions but not really interested by that.

There you go, your last processed commands.

 

Cheers,

Laurent

Screenshot_20200304-151200_Poweramp.png

Share this post


Link to post
Share on other sites

So something is sending a NEXT command via PSMediaButtonReceiver, which Poweramp is responding to correctly. The question is why though? @maxmp , any ideas?

Andre

Share this post


Link to post
Share on other sites

Besides, by seeing this I thought it might be the car but..

With other players it doesn't happens (I use AP since a few years now, really don't want to change my habits ^^).

Share this post


Link to post
Share on other sites

Poweramp tends to interpret received commands rather more literally (i.e. correctly) than some apps.

For example, Poweramp treats the keycode events MEDIA_PLAY, MEDIA_PAUSE, and the toggle-version MEDIA_PLAY_PAUSE, each as separate commands - as it should. However there are some BT receivers/head-units that simply send MEDIA_PAUSE for everything, whether they wish to start or stop, which is wrong as the event should only ever trigger a PAUSE, never a resumption of playback (that's what MEDIA_PLAY_PAUSE is for). Or sometimes they forget to send a corresponding BUTTON_UP event after BUTTON_DOWN.

Andre

Share this post


Link to post
Share on other sites

Not sure that Audi would listen if I told them they messed up things ;)

Does that means that nothing can be done on your side ?

Share this post


Link to post
Share on other sites
4 hours ago, Lowlow said:

Does that means that nothing can be done on your side ?

We'll have to wait and see what @maxmp says, not sure exactly how that NEXT command is being generated.

Andre

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

×
×
  • Create New...