Jump to content
Wgesh

Song titles showing file extension

Recommended Posts

@maxmp Yes for sure.. i will sen you some files. I have switched units, but on both units (Ibasso dx160 and cayin n6ii) it looks like it shows the same situation when using v364.

I will send files from dx160, using v364..

Share this post


Link to post
Share on other sites

Latest Status:

1. I reinstalled 364 on cayin just now, and did a "Full Rescan". After that i found almost every Album showing the filename instead of title tag.

2. Next Step: i startet to do the first "Rescan". ( iwll have one question to that lateron for my understanding). After that 1st "Rescan" i found approximately only every 3rd Album showing the filename instead of title tag. rest was showing the title tag as expected.

@maxmp I have sent you 3 files. 1 showing the title tag correectly and 1 with filename instead of title tag incl. .mp3 extension and 1 with filename instead of title tag excl. .mp3 extension

3. Next Step: i startet to do  again a "Rescan". After that i found almost no Album which showing filename instead of title tag...

4. Next Step: I kept on Rescanning after Scanning Step 2 shows 0/0. It took me 9 times "Rescan"  and now, there is no Album showing Filename instead of title tag anymore...

As it seems PA doesnt put all scanned files Tags in the Database with 1 Rescan.. it takes more "Rescans" to get all data into Database.. How many may differ or depend on number of files?

Now my question to scanning: Scanning is running in 2 Steps as it looks..

1st Scanning the folders - (see picture 1)

2nd Scanning tags of unknown files and copy to Database - (see picture 2)

is that right?

InkedK1024_Picture2_LI.jpg

InkedK1024_Picture1_LI.jpg

Share this post


Link to post
Share on other sites

Thanks for the files. They are OK.

It seems the issue on your device is scanning while files are being uploaded. This explains Full Rescan occasionally fixing the issue.

I would recommend disabling Settings / Library / Scanner / Auto-scan and using manual rescan (via e.g. Library / Folders header / Rescan menu) to avoid such mid-upload auto scans. On standard Android system manages to issue file changed event after file upload is complete and Poweramp additionally waits for the possible next file upload, but those timings are tuned for average Android device with the standard MTP upload code. If this code is customized in the ROM or otherwise changed, scan may happen during upload, thus no valid tags will be read and no proper title appears until the next manual Full Rescan.

Please note that usual Rescan won't touch files previously scanned and won't fix the filename/title issue.

Share this post


Link to post
Share on other sites
Posted (edited)
1 hour ago, maxmp said:

I would recommend disabling Settings / Library / Scanner / Auto-scan and using manual rescan (via e.g. Library / Folders header / Rescan menu) to avoid such mid-upload auto scans.

Hello,

Thanks for your reply.. This might be an explanation, but this option is disabled from the beginning, as i experienced problems earlier having Auto-scan "on". So this is always "off" on my devices..

Must be another problem..

Please let me know if i can support with further infos. I can repeat the problem as often as you want by just do again a "Full Rescan".. After a "Full Rescan" all Titles in Albums are again shown as Filename with .mp3 extension and not as Title Tag. Only multiple "Rescans" is solving the issue as explained in above post.

1 hour ago, maxmp said:

Please note that usual Rescan won't touch files previously scanned and won't fix the filename/title issue.

As it looks to me, i believe PA is not scanning properly in the first run.. Only multiple "Rescans" makes sure ALL Tracktitles are shown as Titel Tag..

Normally i switch off the device, takeout SD Card, put files on it via Windows, then put back in device and switch device back on..

Edited by Andro

Share this post


Link to post
Share on other sites

Please try turning off ALL the scanning options, perhaps PA is still doing a scan on powerup and possibly the card mounting with the new files has not completed? It's hard for Max to say much more if he scan't replicate the issue. Could you maybe send a log from just after a  Full Rescan has completed in case that shows anything?

Andre

Share this post


Link to post
Share on other sites

Hello Andrew, 

For sure, I will send a log file after the next Full Rescan, which will happen in the next few days. 

I also just can guess, maybe it something to do with the amount of files? If there are more then x files, it takes several Rescans to get all tag data into the database? I also don't think too many people will have that number of files on their SD card. I have another issue with Playlist, which I will report separately late where I also think it comes from the amount of files.. 

I just want to say: Poweramp is the ONLY Player (and I have tried many of them, icl. UAPP,  NEUTRON, Hiby Music or whatsoever) which is able to handle my big library, with highspeed scanning and library functions so thanks for your good work and your awesome piece of software 🙂

But back to topic:

In on first Rescan after a Full Rescan looking at scanning Step 2 - Library (remember I have in total 87935 Files) it shows about 72000 Songs. On second Rescan, looking at Step 2 there you can see only about 55000 Songs to be updated. This continues until 6 to 9th Rescan where you can see at Step 2 written: 

On Step 1: Scanning Folders... Folders: 12156, Files:89275 (don't know where the difference to the final 87935 comes from) 

On Step 2: Scanning library... Songs:0/0, Playlist:0

Results in: Folders: 7296, Playlists:3, Songs: 87935

Only after that I have all Files Tag Infos in the database, which shows the desired result when using Library functions. 

What also need to be said: It's not a big issue anymore for me, as I can solve my Problem of having shown filenames as Titel Infos by Rescanning often enough after Full Rescan. And there is still the possibility this comes from a Problem with my unit or my files.. 

Anyway, I will send a Logfiles after next Full Rescan. 

Edited by Andro
Forgot infos

Share this post


Link to post
Share on other sites
2 hours ago, Andro said:

Anyway, I will send a Logfiles after next Full Rescan. 

When you do, can you PM Max to let him know you're sent a log relating to this specific issue. 

Andre

Share this post


Link to post
Share on other sites

Latest Status: I did a "Full Rescan" (Logfile is sent). After that i had to "Rescan" again multiple times. As i was interested, i just did this Process 3 times.. What i found is the following:

At the "Full Rescan" PA recognizes 89307 Files at the first Step, but adds 87967 Songs at the 2nd Step (ignore Shorttracks is set to "don't ignore - include all"). After that i start "Rescan" to get all Title tags.

1st "Rescan": 1st Step: 89307 Files, 2nd Step: 87967 Songs added
2nd "Rescan": 1st Step: 89307 Files, 2nd Step: 71965 Songs added (= 16002 Songs less then before)
3rd "Rescan": 1st Step: 89307 Files, 2nd Step: 55963 Songs added (= 16002 Songs less then before)
4th "Rescan": 1st Step: 89307 Files, 2nd Step: 39961 Songs added (= 16002 Songs less then before)
5th "Rescan": 1st Step: 89307 Files, 2nd Step: 23756 Songs added (= 16205 Songs less then before)
6th "Rescan": 1st Step: 89307 Files, 2nd Step: 9428 Songs added (= 14328 Songs less then before)
7th "Rescan": 1st Step: 89307 Files, 2nd Step: 0 Songs added (= Rest of the Songs)

Whenever i do a "Full Rescan", this pattern repeats  with exactly the same figures. I just did it 3 times.. 

Maybe this Pattern gives any idea or can help?

Share this post


Link to post
Share on other sites

@Andro Thanks for the log / details. Please PM me your email you send log from so I can find it.

PS Found your log. I guess I found the issue with your collection and next beta will have appropriate fix. Thanks again!

 

Share this post


Link to post
Share on other sites
On 3/25/2020 at 9:46 PM, maxmp said:

PS Found your log. I guess I found the issue with your collection and next beta will have appropriate fix. Thanks again!


thanks for that. im glad if i can help to improve this great Player..

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...