Jump to content
Wgesh

Song titles showing file extension

Recommended Posts

Recently I did a full rescan and changed my device name on my phone and now the titles for my songs have ".mp3" showing up at the end (songs with numbers in their filename don't have the ".mp3" in the title for some reason). Before doing the full rescan and device name change I never had this issue before. Is there any way to fix this?

 

Build: v3-build-860-arm64-play
Device: samsung SM-G973W (Samsung S10)
Android: 10

Edited by Wgesh
Added build, device and android ver. details

Share this post


Link to post
Share on other sites

You may have accidentally enabled the option to display filenames instead of title tags, in Settings > Library > Lists > Filename as Title. But otherwise, the song title lines should be derived from the tag info rather than from filenames. If the tags info has not been scanned correctly into the database (which can sometimes happen when a complete filesystem change has occurred, and would normally result in lots of Unknown Artist and Unknown Album instances) try doing another FULL Rescan.

Andre

Share this post


Link to post
Share on other sites
10 hours ago, Wgesh said:

@andrewilley Thanks for the reply. What if I wanted to use the "filename as title" option, is it supposed to grab the entire filename including the extension?

Correct, you will see the whole filename (but not the full path) wherever you would otherwise see the 'Title' tag shown. That is what the option is designed to do.

Andre

Share this post


Link to post
Share on other sites

@andrewilley Got it, thanks.


Do you a have possible explanation for this though? I'm sure I didn't have the "filename as title" option turned on at the time and Poweramp would show titles from my filenames without the extension.

On 2/23/2020 at 11:31 PM, Wgesh said:

Before doing the full rescan and device name change I never had this issue before.

 

Share this post


Link to post
Share on other sites
31 minutes ago, Wgesh said:

I'm sure I didn't have the "filename as title" option turned on at the time and Poweramp would show titles from my filenames without the extension.

If you have music files without any Title tags, then PA will show the filename instead. Including the extension as that is considered to be part of the filename. 

Andre 

Share this post


Link to post
Share on other sites

Just had this same issue. After a full Rescan all of my 4,000 songs now don't show my selected custom artwork and for some reason this does not apply to songs with numbers in their filename. Do i have to do a batch rename of all my album artwork to include ".mp3" at the end? then manually go through and delete it for those songs with numbers in them?

The old way was great where you could set it to display the filename, but ".mp3" was not shown in the lists or PA main screen song title.

Share this post


Link to post
Share on other sites

@JohnnySapphire

8 minutes ago, JohnnySapphire said:

The old way was great where you could set it to display the filename, but ".mp3" was not shown in the lists or PA main screen song title.

So I'm not crazy! This WAS a thing before. I have the exact same issue where all my album art is gone since the titles aren't exactly the same. I'm going to keep poking around for another fix but I might go and write a Python script that sets all the songs' title metadata to whatever the filename is, excluding the extension. I'll update back here once I find some solution.

Share this post


Link to post
Share on other sites
6 minutes ago, Wgesh said:

@JohnnySapphire

So I'm not crazy! This WAS a thing before. I have the exact same issue where all my album art is gone since the titles aren't exactly the same. I'm going to keep poking around for another fix but I might go and write a Python script that sets all the songs' title metadata to whatever the filename is, excluding the extension. I'll update back here once I find some solution.

Yeah, i only also noticed this when i re-copied songs to my phone. Only those in that copy had this issue. As soon as i did a "Full Rescan" as recommended in this thread, it created the problem for the rest of the 4,000 songs...

Share this post


Link to post
Share on other sites

I'm not sure when this behaviour changed, but logically I would have expected a filename to be shown including its extender. Otherwise it is not the correct filename, and it would not be possible to distinguish between different files like Africa.mp3, Africa.flac, Africa.m4a, etc.

When PA is trying to interpret the filename where the Title tag is missing (rather than being directly asked to show the full filename) then I seem to recall it might be possible for the extender to be omitted, and also for any leading digits (usually representing track numbers) to be dropped too. This could of course cause unexpected results with names such as "99 Red Balloons", "7 Years", etc.

@maxmp would be able to tell us if this behaviour has changed though.

Andre

Share this post


Link to post
Share on other sites
6 hours ago, andrewilley said:

When PA is trying to interpret the filename where the Title tag is missing (rather than being directly asked to show the full filename) then I seem to recall it might be possible for the extender to be omitted, and also for any leading digits (usually representing track numbers) to be dropped too.

Yea this is the function that I was looking to get back. 

 

 

6 hours ago, andrewilley said:

This could of course cause unexpected results with names such as "99 Red Balloons", "7 Years", etc.

This did happen to me but for those few songs I just manually entered a title then. 

Share this post


Link to post
Share on other sites

Of course a much better solution to avoid this sort of issue in the first place is to simply make sure your files are tagged properly in the first place. I use TagScanner, which makes it a doddle to batch edit music tags. It can even interpret title/album/artist/etc from your filenames (using user-definable pattern matching) and then you can just tweak any by hand which don't look right.

Andre

Share this post


Link to post
Share on other sites

@andrewilley TagScanner worked pretty well thank you. Since my song files were formatted differently for some I couldn't properly do the title and artist tag, instead I just copied the entire filename I had and pasted into the title tag. This also helped me with restoring all my album art easily since my titles then had the exact same formatting. @JohnnySapphire I think things went okay you might wanna give this program a shot. 

Edited by Wgesh

Share this post


Link to post
Share on other sites
Posted (edited)

Hello, 

My collection has 87000 files. All of them are properly tagged. 

For my instance renaming filenames is not an option.. 

I have the situation, that some album tracks are show the filename incl. Extension. mp3 , some show the title tag

On albums which show the full filename and not the title tag, tagging is done properly so there is definitely a title tag. I double checked this to be sure.. 

I cannot find a pattern why one is this way and one another.. 

Is there a way to force PA to use the title tag? And if there is not title tag, put it to unknown title? 

I don't want to have the filename shown. 

 

Edited by Andro

Share this post


Link to post
Share on other sites

Has PA picked up the tags correctly on the files which show the .mp3 extension? Do you see the album title, aritst name, etc under the song title line in the Player screen or Library view? If not, try a FULL Rescan.

Andre

Share this post


Link to post
Share on other sites
2 hours ago, andrewilley said:

Has PA picked up the tags correctly on the files which show the .mp3 extension? Do you see the album title, aritst name, etc under the song title line in the Player screen or Library view? If not, try a FULL Rescan.

Andre

Hello..

Yes, as long ias i can judge this yes.. Funny it is, i have 3 different cases.. and in all cases, i believe tags have been picked up properly.. Let me show

Case 1: Tags fine, trackname is shown as title tag.. 

Case 2: Tags fine, trackname shown as FIlename incl. .mp3 extension

Case 3: Tags fine, trackname shown as Filename without .mp3 extension

Last Picture my settings for Lists..

 

SettingsLists.JPG

CASE1a.JPG

CASE1b.JPG

CASE2a.JPG

CASE2b.JPG

CASE3a.JPG

CASE3b.JPG

Share this post


Link to post
Share on other sites
Posted (edited)
3 hours ago, andrewilley said:

And did anything change on doing a FULL Rescan?

Hello Andre,

 

I did a full rescan right now.. Yes there is a change: Cas1 looks now the same as Case 2. hmmmm strange.. Still, the Setting "Filename as Title"is switched off..

 

Actually im anyway doing "Rescan" and "Full Rescan" forth and back the last 5 days, as PA has also other issues like it doesnt recognise all Files at the beginning (They show up right as a number while scanning, but then some are missing ind library.. Only after few Scans, or days, or magnetic changes in the earth rotation ( idont know) they show up in the library.

THe biggest Problem with showing Filename instead of Title tag is, that the numbering is taken from the filename and the sorting is wrong.. It goes: 1, 10, 11, 12, 2, 3, 4 - It seems it ignores the numbering in the id3 Tags.

 

Actually i dont want PA to recognise the FIlename at all.. i have properly tagged all my Albums and so i want to force PA to only use the ID3 Tags..

And the Question is how to do that?

K1024_IMG_20200319_160939.JPG

Edited by Andro

Share this post


Link to post
Share on other sites

PA should only revert to using filenames if it has not read the tags correctly during the scanning process (which is not the same as showing Info/Tags by the way, that reads the file directly rather than getting the info from the scanned database).

Andre

Share this post


Link to post
Share on other sites

@andrewilley Not exactly. If no title tag is detected, title based on filename is used, but such title won't have extension (or starting track number). 01-Track.mp3 will have title "Track".

Share this post


Link to post
Share on other sites

@andrewilley Not exactly. If no title tag is detected, title based on filename is used, but such title won't have extension (or starting track number). 01-Track.mp3 will have title "Track".

@Andro Filename As Title seems to be enabled (for your last screenshot). This one will show file extension.

Share this post


Link to post
Share on other sites
8 minutes ago, maxmp said:

Andro Filename As Title seems to be enabled (for your last screenshot). This one will show file extension.

Hello.. 

No, its 100% not. Filename as title is disabled as you can see at the screenshot in the prior post. As it seems, this is a problem with version 864.

I have 860 running on another unit which doesn't show this behaviour. 

I will revert back to 860 on this unit and see what will happen.. 

I will post the outcome tomorrow morning. 

 

Share this post


Link to post
Share on other sites

Hello, 

Yes, after going back to v860 everything works fine. I use the same settings as before and PA only shows the Title tags.. I couldn't find any album which shows the filename. 

@maxmpif I can help to find the problem with 864 please let me know what I can do.

Still possible, I did something wrong?

Share this post


Link to post
Share on other sites

@Andro Thanks for the details and testing. Would you please share couple of the tracks showing this behavior for tests, preferable via Poweramp itself: in list long press / Send / Gmail / gpmaxmpz @ gmail.com?

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...