Jump to content
Demelza

/storage/emulated/0/Download missing or not readable

Recommended Posts

Hello,


I Have a question hope you can help me.

For some reason new songs are not added to the app anymore and now everytime I open the app it's says /storage/emulated/0/Download is missing.

I dont know what happend but I cany use the app anymore.

You see my playlist everything but cant play anything

What can I do know to fix it.


 

Share this post


Link to post
Share on other sites

/storage/emulated/0/ is just Android's way of referring to the main internal memory of your device, so Poweramp has been told to look for (or had previously found music in) the Download folder in your device's internal memory. Try disabling (unticking) that folder in PA Settings > Library > Music Folders, as that ought to just be a temporary/transient folder for file downloads until you decide where to put them, not a music repository.

Andre

Share this post


Link to post
Share on other sites

That doesn't look like a Poweramp display to me. Are you sure you went into Poweramp's Settings menu screen, and then selected Library and then Music Folders ?

Andre

Share this post


Link to post
Share on other sites

Even without any music files on your device, you should be able to go into Settings (from your screenshot), and then choose Library and then Music Folders. You should see something like this, which you can drill-down into to tick or untick folders to tell Poweramp where your music is stored:
Screenshot_20200211-234643_Poweramp.jpg

I have only one folder for my music, so mine looks like this:
Screenshot_20200211-234740_Poweramp.jpg  

Andre

Share this post


Link to post
Share on other sites

I see that i have to give Access to the sd kaart or the Galaxy  s9 i will try that know see what it does 

I did it and how i see everything is clicked on so i guess now i have to unclick them something like that🙈

Screenshot_20200212-012702_Poweramp.jpg

Edited by Demelza

Share this post


Link to post
Share on other sites

Ok disabled the whole galaxy s9 and know it put everything back and it works again no idea which folder but ok it works thank you for your help👍🏾

Share this post


Link to post
Share on other sites

The first screen you saw in PA was to enable access to storage, which used to be a simple prompt during first run of an app so I wasn't expecting you to suddenly see it during normal use. Has your phone recently updated itself to a newer version of Android, as those checks are a fairly recent change made by Google (mostly affecting Android 10 I though, which you did not mention).

But yes, now you have proper access to the storage on your device, just untick everything you don't need so just the top-level folder(s) that contain your music are ticked. Then do a Full Rescan to clear out any remaining issues from before.

Andre

Share this post


Link to post
Share on other sites
8 minutes ago, Demelza said:

Yes omg I totally forgot there was an update 🙈

Blame Google for that one I'm afraid, they are getting more and more Apple-like in the way they are taking control of how people use and access their own devices. Freedom to use my own property in exactly the way that I want to was one of my main reasons for me going down the Android route rather than getting an iPhone.

Anyway, all sorted now, you should be fine from here on.

Andre

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...