Jump to content

Failed to Play - Storage Unmounted


Recommended Posts

Strange one ...

Build 860

I had a 256 GB SD card in my Samsung A70 loaded with lossless m4a music all playing fine with Poweramp (and GoneMad to compare) ... its was running out of space so I swapped the SD card with a 512 GB card I had in my Samsung tablet with hardly anything on it (it was a freebie promo from Samsung with the tablet).

I copied all the music from the 256 to the 512 using Android File Transfer on my iMac and loaded the 512 into my phone.

I changed the library path in Poweramp and recanned ... all albums detected, album art downloaded, perfect!

But, now when I'm trying to play files, about half of them don't play and show the error "Failed to play storage unmounted"

The other half (ish) play fine.

Gonemad plays the files that Poweramp won't!

All files are lossless m4a.

I put the 256 card (with all the same filed still on it) in my tablet ... Poweramp (same build) plays all files OK!

Any ideas?

Really don't want to ditch Poweramp in favour of Gonemad.

Link to comment
Share on other sites

Ah, the clearly marked option to deal with exactly the scenario that I was facing that I didn't take the time to find???!!! 


Yip, that worked! 


Thanks for the quick reply... I can go load another couple of hundred GB in confidence! 


Link to comment
Share on other sites

1 hour ago, Mark_M said:

Ah, the clearly marked option to deal with exactly the scenario that I was facing

Yup, that'd probably be the one. :)

The reason is that Android will have given your new storage card a completely new name, and PA will have scanned in all the 'new' files it found - but without any way to know they were really duplicates of the 'old' songs which it for some reason could no longer read.

Back in Poweramp v2 the app would have immediately removed all of the old 'lost' entries for you just as soon as they disappeared from the storage system. However if that disappearance was only temporary (ejecting a card to copy new files to it for example) then wiping out the whole library - along with all the associated ratings, playlists, etc - could be somewhat annoying... ;)


Link to comment
Share on other sites

  • 9 months later...
  • 2 months later...

Same error. First thing to mention is that I don't have the SD card. All my music is on the internal hard drive.

Tried to re-scan, as suggested. As a result, my music folder and its subfolders are no longer seen by the app.

I go to Settings->Library->Music Folders and select internal storage. Re-scan doesn't find anything.

I go back and tap on + in the lower left corner of the Folder Selection dialog. In response the app tells me to add Storage/Provider Plugin. I have no idea what it means but tap on Continue anyway. On the next screen I see a bunch of folders, one of them is Music. I tap on it and I see all my subfolders. I tap on USE THIS FOLDER blue bar at the bottom and then allow Poweramp to access files in Music.

Now I click on Full Rescan and it finds nothing. Folders: 0, Playlists: 0, Songs: 0.

What am I doing wrong?

Link to comment
Share on other sites

16 hours ago, maxmp said:

@Sashka disable File Access Legacy Mode in Poweramp (if you're on Samsung+Android 11, it silently removes legacy permission to access files directly and there is no way to know that or re-request permission). Then choose folders in Music Folders.

And how do I do that?

Link to comment
Share on other sites

16 minutes ago, Sashka said:

And how do I do that?

Which bit?

1) PA Settings > Misc > File Access Legacy Mode (turn this off)

2) PA Settings > Library > Music Folders (choose the folder where your music is located and tick it; you may need to grant access to that folder first, see the FAQ at https://forum.powerampapp.com/kb/en_us/faq/music-folders-selection-doesnt-work-on-android-1011-and-other-file-access-issues-r36/)

(there is a search feature in Settings by the way, makes navigating your way back to these sort of options a bit easier)


Link to comment
Share on other sites

  • 7 months later...
6 hours ago, vinniesilvagio said:

File Access Legacy Mode in Poweramp is nowhere to be found.

It's in PA Settings > Misc. However if you reinstalled (or cleared app data which does mostly the same thing) the new default setup will have preset that mode correctly for Android 11 anyway.

By the way, there's a very handy Search tool in PA Settings (on the top line) that a lot of people miss. Typing "Legacy" into that would find the switch too.


Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Create New...