Jump to content

Android Auto bug - Playback resumes after plugging in, then pauses


duraz0rz
 Share

Recommended Posts

I don't know if it's Bluetooth related or this particular issue but, I had issues since I have upgraded my phone to Android 12 (Pixel 4a).

My car is a Versa 2007 so, I don't have a stock smart dashboard. So, I use a bluetooth adaptor. On top of taking a while to connect since the OS update every second attempts, the music just stop playing. So, while I'm driving, I just turn off and back on my bluetooth adaptor and it starts again.

Please note that the last time below, I *never* pressed the pause button. So, if it says that PA received a PAUSE command, that's not me.

If it's not that, it's a bluetooth issue.

Thank you. Cheers

Version: build-911-arm64-play [911004-cb218340]
Full Version
64-bit

Here's the log:

Quote

==================
16:18:49.078 PlayerService NEXT
from PSMediaButtonReceiver
==================
16:24:21.212 PSMediaButtonReceiver android.intent.action.MEDIA_BUTTON
KEYCODE_MEDIA_NEXT ACTION_DOWN name=Virtual source=0x0 sources=0x301 virt=true repeat=0 actionTime=53302765 sourcePak=com.android.bluetooth isAvrcp  flags=0x0 playerState=1
==================
16:24:21.222 PSMediaButtonReceiver android.intent.action.MEDIA_BUTTON
KEYCODE_MEDIA_NEXT ACTION_UP name=Virtual source=0x0 sources=0x301 virt=true repeat=0 actionTime=53302775 sourcePak=com.android.bluetooth isAvrcp  flags=0x0 playerState=1
==================
16:24:21.940 PlayerService NEXT
from PSMediaButtonReceiver
==================
16:34:17.711 HeadsetPlugReceiver headset event
disconnection BT=false am mode=0 no_keep_notif_on_dscn=false
==================
16:34:17.711 HeadsetPlugReceiver cmd_player_pause_playing
==================
16:34:17.859 BTReceiver headset event
disconnection BT=true am mode=0 TaoTronics TT-BR04 no_keep_notif_on_dscn=false
==================
16:34:19.860 PlayerService onRoutingChanged
newDevice=speaker oldDevice=bt
==================
16:34:19.861 PlayerService reloadPipeline
 allowPlaying=false forceResume=false state after reload=2
==================
16:34:20.898 BTReceiver headset event
connection BT=true am mode=0 TaoTronics TT-BR04
==================
16:34:20.898 BTReceiver RESUME
resume_on_bt delay=500
==================
16:34:20.999 PlayerService onRoutingChanged
newDevice=bt oldDevice=speaker
==================
16:34:20.999 PlayerService reloadPipeline
 allowPlaying=true forceResume=false state after reload=2
==================
16:34:21.506 PlayerService RESUME
from BTReceiver resumePlaying
==================
16:45:05.882 BTReceiver headset event
disconnection BT=true am mode=0 TaoTronics TT-BR04 no_keep_notif_on_dscn=false
==================
16:45:05.882 BTReceiver cmd_player_pause_playing
==================
16:45:06.104 HeadsetPlugReceiver headset event
disconnection BT=false am mode=0 no_keep_notif_on_dscn=false
==================
16:45:09.941 PlayerService onRoutingChanged
newDevice=speaker oldDevice=bt
==================
16:45:09.941 PlayerService reloadPipeline
 allowPlaying=false forceResume=false state after reload=2
==================
16:45:13.660 BTReceiver headset event
connection BT=true am mode=0 TaoTronics TT-BR04
==================
16:45:13.660 BTReceiver RESUME
resume_on_bt delay=500
==================
16:45:13.779 PlayerService onRoutingChanged
newDevice=bt oldDevice=speaker
==================
16:45:13.779 PlayerService reloadPipeline
 allowPlaying=true forceResume=false state after reload=2
==================
16:45:14.267 PlayerService RESUME
from BTReceiver resumePlaying
==================
16:53:28.591 PSMediaButtonReceiver android.intent.action.MEDIA_BUTTON
KEYCODE_MEDIA_NEXT ACTION_DOWN name=Virtual source=0x0 sources=0x301 virt=true repeat=0 actionTime=55050144 sourcePak=com.android.bluetooth isAvrcp  flags=0x0 playerState=1
==================
16:53:28.593 PSMediaButtonReceiver android.intent.action.MEDIA_BUTTON
KEYCODE_MEDIA_NEXT ACTION_UP name=Virtual source=0x0 sources=0x301 virt=true repeat=0 actionTime=55050146 sourcePak=com.android.bluetooth isAvrcp  flags=0x0 playerState=1
==================
16:53:29.283 PlayerService NEXT
from PSMediaButtonReceiver
==================
17:04:58.456 BTReceiver headset event
disconnection BT=true am mode=0 TaoTronics TT-BR04 no_keep_notif_on_dscn=false
==================
17:04:58.456 BTReceiver cmd_player_pause_playing
==================
17:04:58.742 HeadsetPlugReceiver headset event
disconnection BT=false am mode=0 no_keep_notif_on_dscn=false
==================
17:05:02.534 PlayerService onRoutingChanged
newDevice=speaker oldDevice=bt
==================
17:05:02.535 PlayerService reloadPipeline
 allowPlaying=false forceResume=false state after reload=2

 

Link to comment
Share on other sites

  • Replies 28
  • Created
  • Last Reply

Top Posters In This Topic

Top Posters In This Topic

So I noticed that when it keeps pausing and trying to play again, it seems to trying to use a different source?  Also kind of looks like that based on the logs I posted earlier (or that could be something else, I'm no expert).  One thing I tried doing was changing my BT AVRCP/MAP version to their defaults and so far things seem to be running better.  Not sure if that helps at all or not.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...