Jump to content
maxmp

Poweramp builds 856-860

Recommended Posts

1 hour ago, maxmp said:

@sztsam sorting by artists (+albums) both in playlist re-sort and for any track list is improved for the next beta, thanks for the feedback.

Hi Max, should include Year too. So Album Artist/Album/Year/Track#. This way when I go to All Album Artists Songs, they are properly sorted according to the year and not alphabetically. Thanks a bunch!

Share this post


Link to post
Share on other sites
22 hours ago, Pilou42 said:

Hello,

I've opted for beta to test the wonderful equalizer-by-BT-device feature. It works quiet well, but sometimes it won't work. Especially with the Bluetooth from my car.

When connecting to my car, the wrong equalizer preset is selected. I have to close Poweramp then remove it for recent tasks (sometimes I even have to force close it). When it restarts, it chooses the right preset. As long as I don't close Poweramp, if the wrong preset is used, even if I change preset manually, when the next song starts, the wrong preset will be selected again.

I have the problem when connecting to my BT car, and also for the device following my car audio, so I think it is linked to the BT of my car. I've triple checked settings, removed presets, recreated it, but it's the same.

I use Tasker for BT tasks and it manages to handle all BT devices well, so I think the problem is in Poweramp.

I have this issue too.  I have posted about this issue here and in the bug forum I believe but nobody responded.   I have that happen with the bt adapter for the car and my jlab headphones.   I have to turn the headphones back off and back on again to get it to load the right one.   I had to take the car one out of the setting because it wouldn't switch to it sometimes.   And once I had the bluetooth speaker in there twice for the eq setting.   And yes when manually changing to the proper one it always changes back to whatever wrong device it thinks it is.  

Edited by hypomaniac-eric

Share this post


Link to post
Share on other sites
9 hours ago, andrewilley said:

How did you get to that view, and is it repeatable?

Andre

Pressed 3 dots button on playlist header (cover). But after the restart of the app it's ok. I can't reproduce it now.

Share this post


Link to post
Share on other sites

I really like the added streaming feature! What is currently missing is resolving non browser encoded URL:s from playlists.

Right now I play music streaming FLAC from my home server using Total commanders media player as it's the only android app able to resolve m3u direct links for streaming over the internet.

For example this m3u entry works:

http%3A%2F%2Fhomeserver.mysite.net%3A11555%2FMusik%2F%5BAlbum%5D%5CBC%5CBryan+Adams+-+%28CA%29+%28HardRock%29%5C%5B1984%5D+Reckless+%28Dynamic+MFSL%29%5CBryan+Adams+-+Reckless+-+06+-+Summer+of+%2769.flac

This m3u entry doesn't work:

http://homeserver.mysite.net:11555/Musik/[Album]\BC\Bryan Adams - (CA) (HardRock)\[1984] Reckless (Dynamic MFSL)\Bryan Adams - Reckless - 06 - Summer of '69.flac

(Proper URL address has been scrambled)

Share this post


Link to post
Share on other sites

Cover - Android 10 Android Auto

I have problems with the display of covers on the monitor of the car radio. Under Android 10 everything still worked fine. Now under Android 10 the first cover is displayed - from the next track on not anymore. With AIMP it works wonderfully.

Share this post


Link to post
Share on other sites
On 2/20/2020 at 2:50 PM, Werner303 said:

 Now under Android 10 the first cover is displayed - from the next track on not anymore. With AIMP it works wonderfully.

You could try enabling Settings > Album Art > Always Send Album Art.

Andre

Share this post


Link to post
Share on other sites

Hey everyone.

I'll post in both English and Russian for simplicity.
The new EQ by BT device feature, is there a way to automatically engage the EQ when the device connects, and disengage when the device disconnects (or another one connects in place of the first one)? I played around with the settings and couldnt' achieve this.
In addition to that, somehow when I went to check if I can save the EQ again I found the UI displaying the same device twice, which is weird. I'll delete both settings and try to re-save it to see what's up.

----

Макс, приветствую. Моё почтение.
Новая фича, создание настроек эквалайзера по имени bluetooth-устройства - есть ли возможность автоматически включать эквалайзер и подключать сохранённые настройки при подключении устройства, и выключать при отключении устройства? Поковырял настройки, но пока не добился такого поведения.
Кроме того, я поймал странную ошибку - при отключении устройства и повторном подключении, и попытке сохранить настройки заново, плеер предложил сохранить их "в параллель" с существующими, хотя имя девайса одинаковое. Неинтуитивно. См. скриншот.

Pixel 4 XL, Android 10 (security patch Feb 5, 2020). Poweramp build v3-build860-arm64-play

Edit:
I was able to achieve SWITCHING between "device 1" EQ setting and "device 2" EQ setting when I would connect both devices, stop playback on one, resume on the other.
But this is not 100% what I was looking for. My idea was - disconnect "device 1" or disconnect bluetooth altogether, then EQ must be disengaged. It doesn't happen. When I disconnect bluetooth, EQ settings last applied stay in effect. In this case it means when I try to play music from the phone's speakers, it would still have "device 1" EQ settings active.

Not too frustrating anymore, since I mostly just switch between 3 devices, use flat Poweramp EQ for two of them (I use Sennheiser's EQ app for those) and only need Poweramp EQ for the 3rd one. But still, perhaps I'm just doing something wrong and there is a way to achieve the behavior I was expecting?
 

photo_2020-02-23_23-36-11.jpg

Share this post


Link to post
Share on other sites
12 hours ago, middleofnow said:

The new EQ by BT device feature, is there a way to automatically engage the EQ when the device connects, and disengage when the device disconnects (or another one connects in place of the first one)?

I haven't used this new option myself yet (I just leave settings flat most of the time) but I thought the whole point of this feature was to auto-switch to the specified saved EQ presets whenever that device became active. And once a BT device disconnects, I would expect PA to return to any saved preset for whatever output method replaces it (Speaker, headset, USB DAC, etc). Not sure of the expected behaviour if BT disconnects but there isn't a saved setting for the replacement though, I'm not sure if previous setting is remembered or if you need to have another specific preset saved. 

Andre

Share this post


Link to post
Share on other sites
On 22.2.2020 at 09:46, andrewilley said:

Sie können versuchen, Einstellungen> Albumcover> Albumcover immer senden zu aktivieren.

Andre

Many thanks for the quick answer. The changed setting has solved my problem.

Werner

Share this post


Link to post
Share on other sites

Yo, there's something happening on the last two updates that I didn't happened before concerning the album art.

The album art is not showing as the lockscreen background when the track changes automatically.

When I select the first track of an album, the background goes as it should. If I change the track manually by the mini player on the lock screen, it behaves as it should. But if I just let the music play, when it ends and changes to the next track, the background vanish, and even if I change manually after that, it won't come back.

I have been noticing this happening for a while, but I remember it didn't happened a few releases before. Using the "Always Send Album Art" option doesn't seem to do anything. 

The first screenshot I selected the first track of the album manually, so it's all as it should be. The second screenshot was from before when the album was playing already for a while.

Any clues?

LG G7, Android 9.0.0, Stock ROM (Forced update), no root, V3 b860

Screenshot_20200304-121823.png

Screenshot_20200304-121338.png

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...