Jump to content
maxmp

Poweramp builds 856-860

Recommended Posts

14 hours ago, andrewilley said:

The following is nit-picky I know, but to avoid extra confusion to users could the wording be updated to use v3 terminology (i.e. 'Category' rather than 'List')? It's the same as with those otherwise-trivial 'Repeat' icon wording changes - Play One|Category|All, Repeat One|Category|All - that I keep banging on about (sorry!), it just makes support explanations easier when the interface terminology is consistent. 

Updated in build 858 (English labels). "List" word is still used to specify these actual lists we are have inside categories (for example, current list, now playing list, list options, etc.). Category is now used for repeat/shuffle modes and related.

Share this post


Link to post
Share on other sites

Thanks for the keep aspect ratio option. Its not a big deal to have them cropped in other small areas like notification or widgets. The main UI is the important part.

Mine didn't get squashed in the library as well and it was looking fine. I did restart the app and do a rescan though.

Share this post


Link to post
Share on other sites

im having the same exact issue as @Keerah

pressing the streams icon does nothing except make the whole app unresponsive

 

Share this post


Link to post
Share on other sites
On 1/2/2020 at 4:06 AM, invaderzim said:

Noticed this as well on 2 different devices and android versions. I have cleared PA cache and selected again the "image/album art" from storage but it didn't take effect.

 

Screenshot_20200102-180303.jpg

Screenshot_20200102-180323.jpg

I noticed that too.   I thought it was because i cleared data and reimported settings.   So this is because of an update?

Share this post


Link to post
Share on other sites
1 hour ago, hypomaniac-eric said:

I noticed that too.   I thought it was because i cleared data and reimported settings.   So this is because of an update?

Build 856 had some minor artwork issues, are you using 856 or 857?

Andre

Share this post


Link to post
Share on other sites
Posted (edited)

There's a problem specifically in Stream category if I start playing Poweramp from home screen widget and change tracks (streaming URL/playlist) at some point the widget show wrong channel info , same thing happens with the main playing screen. Suppose currently I'm listening Dance wave retro but on the player screen it's showing I'm streaming an URL. This is only happening with steaming category if I play from Playlists category and change tracks hundreds of times this will not happen.

 

 

Edited by Prosenjit

Share this post


Link to post
Share on other sites
2 hours ago, hypomaniac-eric said:

I'm on the newest as of the other day. 857

Mine works fine now. Album Art appears as it should. Did nothing but update to 857.

Share this post


Link to post
Share on other sites

@Prosenjit thanks for the report. This is due to the sorting streams by field which changes when stream metadata updates, for example title. I will reduce number of possible stream sorting option to non-dynamic fields only. Playlist entries are not affected as their item ordering is fixed.

Share this post


Link to post
Share on other sites

Hi Max, an issue with the layout has appeared since 856/857. I am on Pie with a LG G8, and prefer to have the Android home touch buttons hidden when using PA. But with these recent updates, the bottom navigation buttons on startup are in the position as if the home touch buttons were present. But if I access any of the four, then they shift down to where they should be. On any app focus change, coming back to PA the buttons are back to the wrong place again until they are used.

See attached before and after screenshots. I used the built in dark skin for these, and have the same.problem on several other 3rd party skins. No issues like this prior to 856.

G

Screenshot_20200106-102054.png

Screenshot_20200106-102101.png

Share this post


Link to post
Share on other sites

@MotleyG Do you use Hide Home touch buttons per apps Setting or something else? I can't reproduce it with similar V30+ @ Pie with just this option enabled.

Share this post


Link to post
Share on other sites
Just now, maxmp said:

@MotleyG Do you use Hide Home touch buttons per apps Setting or something else? I can't reproduce it with similar V30+ @ Pie with just this option enabled.

Just using the hide button on the left side of the home buttons while using PA.

Share this post


Link to post
Share on other sites

Build 858:

  • new Show Track Number option
  • sorting By track # sorts also by disc number, if exists
  • fixed issue with Streams category and CUE images option
  • fixed issue with invalid stream info shown in UI due to the dynamic Streams sorting
  • new Check For Updates options
    Website version only

Download link (also in first post): https://forum.powerampapp.com/files/file/65-poweramp-v3-build-858-uniapk/

Share this post


Link to post
Share on other sites
4 hours ago, maxmp said:

Build 858:

  • new Show Track Number option
  • sorting By track # sorts also by disc number, if exists
  • fixed issue with Streams category and CUE images option
  • fixed issue with invalid stream info shown in UI due to the dynamic Streams sorting
  • new Check For Updates options
    Website version only

The Show track number option is very useful for me. :) Thank you.

Share this post


Link to post
Share on other sites
31 minutes ago, wormant1 said:

the current build is not compatible with my phone's hi-fi DAC when using Hi-Res Output

Vivo X21A

interesting, I got the DAC to work again after enabling "Emulate Media Stream"

Share this post


Link to post
Share on other sites
9 hours ago, maxmp said:
  • sorting By track # sorts also by disc number, if exists

Many thanks Max, it's lovely to see some old but relatively straight-forward feature requests and fixes getting addressed during these last few builds, creating lots of happy users I suspect.

Could I suggest that if a Disc# tag is not present, it should not be interpreted as the same as Disc 1 though? It could be handled either as Disc 0, so it gets sorted before any real Disc# tags that happen to be present, or some large value so it gets sorted after any real Disc numbers? Otherwise, tracks without Disc# tags get muddled up with valid Disc 1 tracks in the list.

Missing Disc# tags probably do not need to be shown at all in Info/Tags, the whole field could be simply hidden in the same way that the Track field is hidden when no Track# tag is present.

Oh, and I'm not sure that a disc number needs to be appended to the track number as well as being displayed in its own field? For example, this looks rather like "Track 5 out of a total of 2 tracks" (it took me a while to work out what it was really showing in fact):

image.png

 

Goodness, what a lot of stuff about a simple disc number! :)

Andre

Share this post


Link to post
Share on other sites
Posted (edited)

Thanks for the new features and updates! I really like the show track number option. I really don't like that it shows on the main screen while playing. If you can simply click on the cover and it takes you to the list with track number, that's more than adequate. I think you just want to see the artist, song and album title when playing a song. Track numbers in list view only. It's really odd and confusing when playling playlists with multiple albums. TBH I had to turn it off. IDK it just bothers me seeing that on the main screen. I'm not used to seeing that in any other media player.

Edited by Absinthequ

Share this post


Link to post
Share on other sites
9 hours ago, Absinthequ said:

Track numbers in list view only. It's really odd and confusing when playling playlists with multiple albums.

I tend to agree, having the number there on its own in the player screen without the context of being part of a list is a bit strange. It would definitely make more sense to make it optional, but Max was struggling with how that affects the animation effect when the Title field is switched between the List (with number) and the Player (without number) screens. Giving separate controls would require some more work and having separate bits of code for the Title line in each screen type, which maybe will come in time?

There could also perhaps be a Disc# / Track# display option added to the metadata line choices, that would be easy enough? It could also perhaps include Genre so it doesn't look too lonely. :)

Andre

Share this post


Link to post
Share on other sites
Posted (edited)
7 hours ago, maxmp said:

I don’t think I can reproduce issues like in that topic in current builds. Poweramp definitely uses in-folder images. And as this is just an Android device, it’s not related to Auto. Thanks!

My friend is also having exactly same problem with me in his android head unit. I really don't know why we are having this problem. Maybe because our head units using an old Android version.(6.0.1).

As I said in the topic linked, our music files don't have problems about tags. We can see cover art and other tags of all our music files by using mediaplayers and tag editors in our computer & in our head units. 

I don't know why but when we do a 'full scan' we can't see cover arts of some random songs.

I can record a long video of this issue in my car with all details if it help you to understand the problem.

We're having this problem only with Poweramp, but except this issue  we're so happy with Poweramp that we don't have a chance to use another media player : D . Poweramp doesn't have any competitor in android head units.

Thank you for regular updates! 👍

 

Edited by traxformania

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...