Jump to content
Andro

Library scan problem

Recommended Posts

Hello team, 

Im using ibasso dx160 with fidelizer Rom and lurker add on.. 

I have approx 89500 files in 320kbps mp3 with proper tagging.. 

I have at the initial scan 80178 files recognized. I added several folders later but on any kind of rescan (even full rescan) it does not recognize those files. The files are added as all the other files in the same folder system with similar subfolder system. 

I looked into library settings and all folders are ticked on. I also set the short tracks setting to 2sec.

When I scan my library with Neutron Player it recognizes correctly 80551 files. Poweramp only recognizes 80178 files. 

Newly added folders are not recognized.. Is there any idea what could cause the problem? 

Kind regards

Share this post


Link to post
Share on other sites

It's hard to know what the issue is without knowing what specific files it isn't scanning, but with 90,000 files that's not going to be easy to track down! Are you sure that every folder location that other apps are scanning is included in Poweramp's Music Folders list? Also change the short files limit to zero rather than 2 seconds.

What you could do if you've got a bit of time is to go into All Songs, select every song in the list (long-press on a song and then tap All) and then tap Add to Playlist. Create a new playlist called 'All', and then export that to an M3U8 file and you'll get a text file containing every song that Poweramp has in its library (with paths). Then get a similar list for your SD Card contents using a command-line prompt. I find that easier on a PC (get a recursive directory listing and send the results to a file, using something like dir /s /b > filelist.txt ). Then load both files into a decent text editor (Notepad++ on a PC is a good one), batch-remove any unnecessary prefix path info in both files (and change "/" to "\") and then sort them the same way (alpha) and then run a file-to-file compare.  A bit fiddly, but it would tell you what files are not being imported into PA and you might find a pattern.

Andre

Share this post


Link to post
Share on other sites
On 12/29/2019 at 10:34 AM, andrewilley said:

It's hard to know what the issue is without knowing what specific files it isn't scanning, but with 90,000 files that's not going to be easy to track down! Are you sure that every folder location that other apps are scanning is included in Poweramp's Music Folders list? Also change the short files limit to zero rather than 2 seconds.

What you could do if you've got a bit of time is to go into All Songs, select every song in the list (long-press on a song and then tap All) and then tap Add to Playlist. Create a new playlist called 'All', and then export that to an M3U8 file and you'll get a text file containing every song that Poweramp has in its library (with paths). Then get a similar list for your SD Card contents using a command-line prompt. I find that easier on a PC (get a recursive directory listing and send the results to a file, using something like dir /s /b > filelist.txt ). Then load both files into a decent text editor (Notepad++ on a PC is a good one), batch-remove any unnecessary prefix path info in both files (and change "/" to "\") and then sort them the same way (alpha) and then run a file-to-file compare.  A bit fiddly, but it would tell you what files are not being imported into PA and you might find a pattern.

Andre

Hello Andrew, 

First of all, sorry for the late reply and thanks for your quick answer.. 

I was playing around a little following your suggestions.. 

1. Yes you where right, I had other folder included in neutron so the count was different by my fault. 

2. I reduced the short file limit to 0

3. I knew already what was not scanned.  It was only new files for any reason. After some restarts and 2 days later (I did approx 15 times full scan without any success) it just started working and all files where shown in the list. Please -don't ask me why.. I really have no clue.. But since then, any new file has been added properly by simple reacan.. 

Long story short - it works again.. Don't know why. I have now 81415 files running properly. 

I assume the problem is sitting on front of the display 😂

Thanks again for your Contribution

Andy 

Share this post


Link to post
Share on other sites

@Andro rarely, some incorrect file may fail tag scanner and basically scan stops on such track. While Poweramp scanner already very robust and all-eating, there are always rare files in the wild which can break scanner like this. I have a collection of such files, previously breaking Poweramp, but now OK, ranging in their effect from just being not noticed by other players to crashing Android media scanner completely. If you feel this is the case, sharing that folder/album/track in question will help me fix it for the next builds. Thanks!

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...