Jump to content
Poweramp
maxmp

PowerAMP v2.0 beta 3

Recommended Posts

I'm using HTC Incredible S on Trinity SensationXL ROM (Android 2.3.5 + Sense 3.5). I mostly use Resume On Headset Connect to start playing. I wonder if it's the reason.

Max

Today I tested a bit more on the SRS issue and found that the problem seems to occur only if I plug/unplug my earphone when the screen is off. As you said, if I do it when the screen is on, SRS effect is retained.

Share this post


Link to post
Share on other sites

SGS2 has "issues" in OpenGL ES driver which can cause such effect (though, it can be just low res cover art).

I quoted it as "issues" as I personally think 3d quality was specifically reduced by Samsung on this phone to get more fps from benchmarks.

Share this post


Link to post
Share on other sites
How can this (correct) tagging behaviour be controlled in Foobar2000?

Preferences => Advanced => Tagging => Prefered tag writing scheme => ID3v2+ID3v1 or ID3v2

Sorry if I missed this question being answered... the suddenly empty playlist issue is an Android system bug, is that correct? That's nothing that can be deal with in PowerAmp?

This is not an issue for PowerAMP v2.0, as PowerAMP v2.0 doesn't use system library playlists anymore (the ones which like to disappear on reboot).

Share this post


Link to post
Share on other sites

Hello

I have a problem with Poweramp beta 3:

the Direct Volume Control option can't be checked (it says my firmware doesn't support that)

I have Samsung Galaxy Ace S5830, Gingerbread 2.3.5.

Share this post


Link to post
Share on other sites

SGS2 has "issues" in OpenGL ES driver which can cause such effect (though, it can be just low res cover art).

I quoted it as "issues" as I personally think 3d quality was specifically reduced by Samsung on this phone to get more fps from benchmarks.

All my cover art is 600x600 pixels, and, as I said earlier, I never noticed any such issues on version 1.4.

Share this post


Link to post
Share on other sites

Every time I try and do a search I get a message saying that Poweramp has unexpectantly stopped and I am thrown out. I am using a Toshiba thrive and my music is stored on the SD card whilst Poweramp is on the tablet memory.

Share this post


Link to post
Share on other sites

This is not an issue for Poweramp v2.0, as Poweramp v2.0 doesn't use system library playlists anymore (the ones which like to disappear on reboot).

That is awesome news. Thanks!

Share this post


Link to post
Share on other sites

So I just upgraded my phone last weekend. Went from the original droid to the Bionic. Poweramp 1.3 kept quitting outputting audio. I almost always just have it set to shuffle play my entire library. It would play fine, until I skipped. I guess a few people have this, because I found this thread on Beta 3, and I gotta say, it works perfectly for me! Love the new look and feel. Love the swipe to skip - so much better than trying to hit a little virtual button in a bouncy jeep. Sound quality seems a lot better, but I grant that may be party the phone circuitry, too. Anyhow, just wanted to say keep up the good work! My most used app just got a lot better!

Share this post


Link to post
Share on other sites

I can guess, than rescans on reboot is caused by faulty sd card which for some reason doesn't apply "last modified" properly to files, or there is time/date issues on the phone.

Poweramp scanning depends on phone date/time + files last modified date/time. Poweramp knowns if it should rescan the file if file "last modified" is changed. If "last modified" is borked on the device, there is no way of knowing file was changed or not.

Note that system media scanner always runs on boot, and it 10-100x slower than Poweramp's.

I already mentioned that in a previous post but apparently it went unnoticed.

I don't know for T3mp3 but in my case, it's not a SDCard but the internal storage of the SGS2. As of the system media scanner, I don't care about it because I asked, via Poweramp, to not scan my music dir using a .nomedia. It may be 10-100x slower than Poweramp but on my phone, it's lightning fast because it basically scans... nothing! Poweramp, although fast, scans my 1600 files collection on EVERY REBOOT which is more than annoying.

I'd really appreciate Poweramp to have a simple option switch to STOP automatic scanning at boot. There's already a manual scanner in prefs, that is already neat as far as I'm concerned!

Continue the good work, Poweramp is a masterpiece and once it gets the new suggestions made here by several users, it'll be very hard for competition to reach the level :)

Share this post


Link to post
Share on other sites

Preferences => Advanced => Tagging => Prefered tag writing scheme => ID3v2+ID3v1 or ID3v2

This is (as far as I know) the default mp3 tagging setting in Foobar2000, and PA still does not seem to recognize the RG-tags in my mp3-files. Anything else I can try?

Works great for FLAC-files though!

Share this post


Link to post
Share on other sites

FiberG

Please send such track (one is enough) to poweramp.maxmpz gmail.com for tests.

Thanks!

Share this post


Link to post
Share on other sites

I have gotten some problems.

1: It wouldn't update the tag of sound tracks after rescanning music folders.

2: It wouldn't delete the sound tracks in the list that were scanned after I deselected the folders which containing them.

3: The widgets which from those widget pack and app itself would not update sometimes. After some songs were played, the album art , sound track info, or even everything won't update and kept the previous song info.

This is the suggestions:

1: Could you add a controller of player in statues bar? Like a box having some buttons and album art.

Thank you. :)

Share this post


Link to post
Share on other sites

Yeah! That's a great idea! Like when you're calling someone and go back to the home screen, you can hang up in de notification thing!

Bug:

I was listening to music, but everytime I pressed a key, the volume turned up and when I release the key it goes back to normal. This is very annoying if I'm typing for a long time.

Samsung Glaxy S, Stock ROM, Rooted.

Share this post


Link to post
Share on other sites

Oh, and one silly little request: please could the 'zoom art' slider function work more logically? At the moment, to get square album art to completely fill the space allocated for it, I have to set the zoom to about x1.05, rather than the expected x1. I would suggest that a value x1 should always scale to fill the area as completely as possible (based on the image ratio being correct) and values of <1 should scale smaller and show the neat coloured border effect.

Andre

Share this post


Link to post
Share on other sites

Just installed the beta-3 on my Transformer. The scroll bug (mixed up album art after scrolling down and up again) is still present in folders/library view.

Share this post


Link to post
Share on other sites

edwardplus

1. File scanning depends on "last modified" timestamp set on files. If "last modified" is not updated (as on some buggy roms), there is no way of knowing the file was modified and requires rescan. Only "Clear and Rescan" will help.

2. File deletion is disabled in beta3

3. Sorry, but we can't reproduce such issue on more than 30 devices locally, this issue can be related to task killers, or killing PowerAMP when sd card unmounted (in this cases, PowerAMP process is gone and widget can't be updated), some broken PowerAMP API consumer, ROM issues or custom launcher app issue.

1. Not supported by Androids below 3.0. Thus, this is planned feature for Android above 3.0.

andrewiley

Initial (1x zoom) album art is set in skin. I.e. if skin designer decided there should be some padding by default, there will be paddings for 1x zoom (as in standard skins), but skin designer can set paddings to zero, etc.

Slartibartfast

I don't think I can reproduce it on my transformer (read, the issue is closely related to your device environment), but I will keep eye on this issue, may be some other reports will help to workaround the issue.

Share this post


Link to post
Share on other sites

andrewilley

Yes, just added such global setting. It basically switches between Filesystem last mod. timestamp and "first seen by PowerAMP" timestamp.

Thanks!

Seems to work perfectly in the new RC, thank you so much.

Andre

Share this post


Link to post
Share on other sites

Your main player screenshot indicates All songs playing (violin icon). When you see this icon, PowerAMP indeed plays All songs, as this is the selected mode. Sorry, I can't reproduce any of shuffle or folder mode issues you're describing with PowerAMP beta3. The only thing I can think of is some sqlite3 issue, but this certainly should affect almost all apps on your phone. Are you on stock ROM or some custom one?

I just found out how this issue with playback type not changing can be replicated (e.g. if you remember I lost my prev/next folder buttons no matter what Shuffle mode was set to, and we found it was struck in 'Library>All Songs' mode even though the Folders/Lib screen had the 'Folders' mode highlighted).

The problem is that the playback mode used in the Player screen does not always alter when you change the setting in the Folders/Lib screen from 'Folders' to 'Library' (or back). You must also start to actually play a new track in order to change the mode - although the new mode remains highlighted in the Folders/Lib screen even if you don't.

For example, say I'm listening to some music in Folders mode, and I hear a track which I decide I'd like to listen to more stuff by the same artist. I go into the Folders/Lib screen, select 'Library' and then 'Artist' mode (so the highlighted option at the bottom of the screen is now 'Library') and then press 'Player' to return to the playback screen. The same song is still playing as intended, but although I should now be in a Library mode, when I press the Next or Back buttons, PowerAmp is still operating in Folders mode and plays the next or previous track in the same folder, rather than now using the appropriate Library function and moving on to a new track by the same artist. If I go back into the Folders/Lib screen at this point, it says that the current mode is 'Library', when it plainly isn't.

My initial problem was actually the reverse of this - i.e. I had selected 'Folders' mode, and the Folders/Lib screen confirmed that the Folders mode was active, but PowerAmp was still working in 'Library>All Songs' mode, hence all the confusion. To fix this, I needed to chose 'Folders' mode and then start some new track playing (which I may not have wanted to do at that point) in order for the mode to really change. Issue is still present in the RC.

Andre

Share this post


Link to post
Share on other sites

Thanks for detailed description.

Right, currently, PowerAMP changes list mode when you start either song or whole list (via context menu => play or shuffle).

When you switch "tabs" in lists activity, it doesn't do anything to player.

And there are many list modes, not just two: folders, hierarchy folders, all songs, albums, artists, artist albums, genres, composers, playlists, etc. including combinations like genre/albums). They are indicated by unique icon in player track info area.

Share this post


Link to post
Share on other sites

Hmm, OK... So why is there still a selector at the bottom of the screen to switch between Folders playback mode and Library playback mode?

I assumed that whichever option I selected would then become the player's current operating mode when I went back to the Player screen. Otherwise why differentiate between the two operating styles in the first place, rather than just including them all in one long set of options?

Andre

Share this post


Link to post
Share on other sites

×
×
  • Create New...