Jump to content
Poweramp
Cpasley

Songs in playlist disappeared

Recommended Posts

 Opened Poweramp this morning to discover all songs in all my playlists (there are many) were gone. The playlists themselves are still there but no songs in them, bummer since I spent months putting them together, any ideas?

Screenshot_20191108-112342.png

Share this post


Link to post
Share on other sites

Most likely your sdcard was dismounted whilst your phone was switched on. When this happens both android and Poweramp will rescan, clear out old data (as it no longer exists) and if it finds tracks again, will rebuild its media database but unless you backed up your playlists as .m3u8 or .m3u, your playlists are empty as the refound tracks are treated as new tracks.

If you do not have an external sdcard then the above does not hold and something else happened but i cannotthink of what that might be.

Ps. I believe Poweramp even has a setting to prevent a rescan in cases as described above

Share this post


Link to post
Share on other sites
11 minutes ago, flyingdutchman said:

Most likely your sdcard was dismounted whilst your phone was switched on. When this happens both android and Poweramp will rescan, clear out old data (as it no longer exists) and if it finds tracks again, will rebuild its media database but unless you backed up your playlists as .m3u8 or .m3u, your playlists are empty as the refound tracks are treated as new tracks.

If you do not have an external sdcard then the above does not hold and something else happened but i cannotthink of what that might be.

Ps. I believe Poweramp even has a setting to prevent a rescan in cases as described above

Yeah everything is on a 256gb sd card, my bad for not backing them up, at least my music is still there. Thank you 

Share this post


Link to post
Share on other sites

Have you checked the relevant options in Settings > Library > Playlists? (especially 'Resolve Playlist Entries', which should be turned OFF to prevent this happening during automatic scans). If these are already turned off, it sounds like an old issue might have resurfaced.

Andre

Share this post


Link to post
Share on other sites
1 hour ago, andrewilley said:

Have you checked the relevant options in Settings > Library > Playlists? (especially 'Resolve Playlist Entries', which should be turned OFF to prevent this happening during automatic scans). If these are already turned off, it sounds like an old issue might have resurfaced.

Andre

Hey Andre

That's one thing had seen when troubleshooting, it initially was off but I had switched it back on in hopes of fixing my problem. I switched it back off after what you said.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...