Jump to content
Poweramp
maxmp

PowerAMP v2.0 beta 2

Recommended Posts

​With those lines or something? Can't it be just 1 color? I mean the Vol/Bal part.

Yes, there is slight gradient to slightly divide "decks" with the knobs. Aluminum theme has these clearly visible.

Black Neon theme has pure black decks.

rickytenzer

I'm not able to reproduce anything like this. What action for list item click do you have in Settings => (Folders/Library) Advanced => Lists => List Item Action? What happens when you click such artist album song? Just nothing? Are you able to add such songs to playlists or get their Info/Tags?

Thanks!

Share this post


Link to post
Share on other sites

Yes, there is slight gradient to slightly divide "decks" with the knobs. Aluminum theme has these clearly visible.

Black Neon theme has pure black decks.

rickytenzer

I'm not able to reproduce anything like this. What action for list item click do you have in Settings => (Folders/Library) Advanced => Lists => List Item Action? What happens when you click such artist album song? Just nothing? Are you able to add such songs to playlists or get their Info/Tags?

Thanks!

I have it set to play and go to main UI. When I select the song, it goes back to the player but does nothing. Either the song that was playing doesn't change or it just goes back to a paused player. I believe I can add the songs to the queue and I can definitely see the tag info.

Thanks for your reply!

Share this post


Link to post
Share on other sites
Could you maybe implement stock versions with the same layout in the other colours too, i.e with the title/seek-bar and the buttons-panel swapped round? (Or will the skin editor allow this to be done very easily, by someone who has never edited a skin in his life? :) ). Andre

It's quite possible.

Thanks for the request.

Share this post


Link to post
Share on other sites

When will streaming via Wi-Fi from PC be implemented? I want to save my microSD valuable space. ;)

Cheers!

Share this post


Link to post
Share on other sites

Hello there,

I want to buy your PA-Unlock app.

I haven't bought it yet and the period is over now. I used old version of Poweramp till now. Now when I downloaded new PA Beta 2 can I buy Unlock app from Android market or should I buy it from your page? I would prefer Android market but the question is if it will work from Adnroid market?

Thx for reply ;)

Share this post


Link to post
Share on other sites

loqan

You can purchase Unlocker either way you think is more appropriate for you. Any of them will work with Betas or final 2.0 release.

small cosmetic bug with widgets. with background set to transparent the border of the widget is still visible. also widgets no longer have "centered" text. everything is now left aligned.

The border/shadow will disappear for zero background transparency for small widgets and for large widget + style 3. Style1/2 looks better the way they are now. If you don't want border for large widget, just use style 3 for it.

Re: text centering - added it to the beta 3</div>

album art is still a little wonky when displayed under "library" view. currently it's picking the last songs embedded artwork instead of the albumart.jpg i have placed in each album's folder.

There is no any matching between folder and the album. Folder jpegs are for folder mode only. Album.jpeg will be used for album view only if any other images are failed to be found (i.e. selected/embed). You can have songs from same album all over various folders. It's not possible to guess which folder image should be used then, causing completely random images used for albums.

rickytenzer

I think I have identified and fixed the issue. Thanks for the help with finding this one (it also could affected genre/albums, composer/albums).

Share this post


Link to post
Share on other sites

There is no any matching between folder and the album. Folder jpegs are for folder mode only. Album.jpeg will be used for album view only if any other images are failed to be found (i.e. selected/embed). You can have songs from same album all over various folders. It's not possible to guess which folder image should be used then, causing completely random images used for albums.

rickytenzer

I think I have identified and fixed the issue. Thanks for the help with finding this one (it also could affected genre/albums, composer/albums).

Lol, it was pretty impossible not to find. ;-)

Will there be a new build soon? Otherwise I'll have to wait for 2.0 official as it's essentially unusable.

Thanks!

Share this post


Link to post
Share on other sites

Here's how List Options look like everywhere on my SE X10. The rest of UI is very polished so I doubt that it's designed this way ;).

Also, options for shuffle/repeat and rating stars over album art are not honored for me. They are always visible and clickable.

shot000001.png

Share this post


Link to post
Share on other sites

My opinion to improving latest Poweramp beta 2 are these:

1. Gesturing on a song which is at the end of its folder needs a gesture too much of length. It seems to fix the length of gesture at a song same as not end of folder.

2. Draging play que into the zero is too difficult. Of course, touching once a parameter above-left of play que makes that but it's not explained on Menu-Help.

3. Widgets need to have their options. I hide repeat/shuffle icon in the option, but widget doesn't.

4. List option could be select tabs to hide('Folders' and 'Library') on the menu of song list. Be simple :D

5. Why don't you get visualization like WMP or 'pado' - player which supports great visualization in 90's - in background of app?

screen shot of pado player is this : http://pds21.egloos.com/pds/201110/21/81/pado.jpg

Visualizaion is in player as background of UI.

Share this post


Link to post
Share on other sites

There is no any matching between folder and the album. Folder jpegs are for folder mode only. Album.jpeg will be used for album view only if any other images are failed to be found (i.e. selected/embed). You can have songs from same album all over various folders. It's not possible to guess which folder image should be used then, causing completely random images used for albums.

rickytenzer

I think I have identified and fixed the issue. Thanks for the help with finding this one (it also could affected genre/albums, composer/albums).

not sure... in the released version on the market this isn't an issue with the art under library/albums view.

what i am doing is on the album "broken" by nin, i also include at the end of the album select songs from the album "fixed" on those tracks from "fixed" i have the album art for that album embedded while in the folder the album is in i have the albumart.jpg for "broken". so when i look at it through library/albums unfortunately the album art for "broken" is shown in the list of albums as "fixed". i also have the "broken" albumart embedded for each song of the actual album "broken" just weird it seems to look at the last song of the album to get the art for the library/albums view. also does this for library/artist view.

Share this post


Link to post
Share on other sites

Anyone noticing that beta2 isn't picking up file based playlists anymore ( well, not all of them ).

I'm using iSyncrWifi and have a bunch of .m3u files in my /external_sd/syncr directory, Poweramp has picked up about 4 of them, but not the other 5-6...

Maybe it's just me?

Share this post


Link to post
Share on other sites

I think its just me - did an erase/rescan and everything seems back again.

Anyone noticing that beta2 isn't picking up file based playlists anymore ( well, not all of them ).

I'm using iSyncrWifi and have a bunch of .m3u files in my /external_sd/syncr directory, Poweramp has picked up about 4 of them, but not the other 5-6...

Maybe it's just me?

Share this post


Link to post
Share on other sites
not sure... in the released version on the market this isn't an issue with the art under library/albums view.

This is because PowerAMP v1.4 uses stock android library, which uses folder names as album names sometimes and picks album art from folders sometimes as well (picking logic differs a bit across android versions). This resulted in wrong album art forum topics for PowerAMP (and for any other 3rd party player out there).

Actually, picking album art from folder should work fine for those, who has perfectly organized libraries, but most of users do not have such.

I think I can add option to prefer cover image in folder for albums. Though, anyway it will actually affect only Albums list. Main player screen will prefer embed art anyway.

Share this post


Link to post
Share on other sites

Hi Max.

Loving 2.0 so far, two requests for the future:

- A replay-gain mode that uses album as source unless shuffle, then uses track. I have this in foobar2000 and its dead useful.

- A 3x1 widget, as wide tiles in launcher 7 aren't quite 4x1 and as such the controls are rather small even with album art off.

th_screenshot-1319181875074.jpg

Share this post


Link to post
Share on other sites

Sound quality of the beta 2 is just spot on,but I do find the stereo X and DVC kinda useless...

new UI is great,I love just about everything about this new release.

Old skin look so fugly next to the new default one.

Works bugs free on my N1(only one small pop)

Only improvement I could think of is spectrum analyzer for final 2.0 version realese..

We all know spectrum analyzer makes the bass deeper.....:)

Oh and max...you should publish a paypal account for donations,Ill be the first,even though

I've already bought two powerAMPs unlockers.

Share this post


Link to post
Share on other sites

Loving the beta, especially the stereo fx and the limit function. The new ui looks alot better to. An option to change the color of the widget text would be cool too. Great Work!!

Share this post


Link to post
Share on other sites

Found some bugs on the beta2.

If you set a rating with the start on the lock screen, on the next song, the star are not resetted IF the screen was shut when the song changed. They stay at the same rating they were for the other song. I also saw the rating in stars stay the same in the player screen (not lock screen), however, I did not try to reproduct. It may be the same issue.

As you probably received in my bug report sent by the application, there is a NullPointerException when trying to change the album art. This cause a crash in the program. User can select sd card album art, remove it by restoring Poweramp default album art of getting one from the internet.

In the settings->audio engine->Replay Gain->Replay Gain, if I set this property to "Apply Gain/prevent clipping according to Pe..." (the text is too long, it is not completly visible). Then my files with replay gain tags have a volume extremly slow, so much slow that on max volume I hardly can hear the sound. Maybe "prevent clipping according to ...." is intended to those who have android 2.3 and that feature "direct volume control or something". Maybe you could disable the option or document it somewhere that it's only available on android 2.3 ??

Also, I have an Archos player and your program, as other program behave weirdly with the lock screen. This is probably not your fault, probably Archos fault. Here is the bug :

If I activate the lockscreen and wait the screen timeout, the screen goes off. Then not long after the screen goes on again to show your lock screen. It then go off again, then go on again to the lock screen. Then goes of and stay off. The rest is normal behaviour : If I press the power button it goes on, and shut after the timeout. It will be ok UNTIL I unlock the phone and it re-lock itself.

I do not know if you have the time to check that and if it's really useful but I still hope.

Also, the performance for showing the album art in the album list seems slower than in Poweramp 1.4

good part :

loves the filter available everywhere

love your tag scanning algorithm. We can now trash the android media scanner.

LOVE the music queue.

I will continue to test and report bugs, But I am quite pleased

Share this post


Link to post
Share on other sites

Beta 2 works fabulously on my stock HTC Incredible. No issues so far, and I like the improvements over beta 1. The transition between album art when swiping left/right in the player is pretty fast. Looking forward to the official V.2 release! Android with Poweramp > iPhone.

Share this post


Link to post
Share on other sites

Bugs:

Auto resume on BT Connect still doesn't work properly

Sometimes it starts with first song in library (forgets last played song & forgets settings for shuffle etc)

Wishlist:

Bluetooth ID3 Tags :)

Share this post


Link to post
Share on other sites

Beta 2 works fabulously on my stock HTC Incredible. No issues so far

Aaand. That may be the defining comment to push me over the edge towards Beta 2.

Share this post


Link to post
Share on other sites

any news about fix hd2-miui crash with all 2.0 betas?

If you can capture the logcat after such crash (with CatLog app) and send it to poweramp.maxmpz gmail.com, this can help to identify and probably fix the issue.

Otherwise, sorry, but it's physically impossible to have each ROM+phone combination for local testing. PowerAMP is tested in-house only on latest stock updated firmwares.

Thanks!

Share this post


Link to post
Share on other sites

Minor Bug Report: Long-pressing on the 'Previous Folder' or 'Next Folder' buttons in the main player screen no longer skips to the first or last folder in the list. I often use the first-folder one as it takes me straight back to my podcasts directory for car journeys when I've been listening to other random music.

Andre

Share this post


Link to post
Share on other sites

I'm still having an issue I've had since 1.4 with my Samsung Epic 4G Touch (Galaxy S2) where after the phone connects to my car's Bluetooth radio, it will play music for 1 second and then pause. I have to start playback manually every time I start my car. I've played with every setting on both Poweramp and my phone (Resume on BT A2DP Connect enabled and have tried disabling Pause on Headset Disconnect). I know it's not my car since my EVO 3D did not have this problem at all. Maybe I'm missing something obvious, but I've tried about everything.

Share this post


Link to post
Share on other sites

×
×
  • Create New...