Jump to content
Poweramp
maxmp

PowerAMP v2.0 beta 2

Recommended Posts

rickytenzer

Auto advance list mode can be enabled by cycling Repeat mode (for any supported list types).

Thanks Max!

One last thing. There appears to be a major bug in going from beta 1 to beta 2 (I presume, unless it's just a bug in beta 2 in general). I can view all the artists/albums in my library, but for some reason when I go to a song in an artist's album through the library, it refuses to play it. I essentially have to trick PA into playing it by queueing it up or by playing all the artist's songs first.

Has anyone noticed this?

EDIT: I uninstalled and re-installed and it's happening again. My music is on my SD card and it refuses to recognize any one of them when I try to open them by going Library -> Artist -> Album -> Song. It works if I go Library -> Artist -> All Songs -> Songs.

It seems as if PA gets confused and thinks that "All Songs" is in fact the album.

Share this post


Link to post
Share on other sites

Can anyone answer how you reset the "most played" song list. For some reason I have 2 songs that claim to be played 9 and 6 times and to my knowledge have never been played at all. Is there a file you delete or a setting, have tried looking for some time and can not find anything.

Any help greatly appreciated.

Share this post


Link to post
Share on other sites

Thanks Max!

One last thing. There appears to be a major bug in going from beta 1 to beta 2 (I presume, unless it's just a bug in beta 2 in general). I can view all the artists/albums in my library, but for some reason when I go to a song in an artist's album through the library, it refuses to play it. I essentially have to trick PA into playing it by queueing it up or by playing all the artist's songs first.

Has anyone noticed this?

EDIT: I uninstalled and re-installed and it's happening again. My music is on my SD card and it refuses to recognize any one of them when I try to open them by going Library -> Artist -> Album -> Song. It works if I go Library -> Artist -> All Songs -> Songs.

It seems as if PA gets confused and thinks that "All Songs" is in fact the album.

Yes, I can confirm this too. Example: Song is playing or not, no matter, go to ''Library''-->''Artists''-->''Albums''===> some picked songs from other artists refuses to play, but not all. All songs are common mp3.

Anyway, it's a brilliant work Max.

Thank You for bringing back old skin, EQ assign for album, up/down gestures, volume round knob, fixing thumbnails, overall improvements, additions, and other fixes. Keep good work.

HTC Desire 2.3.3. Stock ROM.

Share this post


Link to post
Share on other sites

Installed the beta 2 today and all I can say:perfect.

the new layout of the equalizer is perfect,the sound is great with DVC off.

Still I dont see the point behind DVC,maybe it gives wider range,or higher volume,

But one thing for sure,it SUCKS.

everything is working and sounds great on my N1 2.3.6 stock.

Max,thank you so much for your time and great work.

Now its time for powerVID,no one can do it better than you.

Share this post


Link to post
Share on other sites

album art that i have in a music folder is not showing with the appropriate album. i have a folder called Music. inside are folders for each album. inside is a jpg with the album cover. but the jpg is not showing with the right album. using motorola xoom. music stored on external1.

Share this post


Link to post
Share on other sites

Hands down the best player I've ever seen, Android or otherwise. The bugs I saw in beta 1 appear to all be addressed. Awesome job!!

Share this post


Link to post
Share on other sites

small cosmetic bug with widgets. with background set to transparent the border of the widget is still visible. also widgets no longer have "centered" text. everything is now left aligned.

album art is still a little wonky when displayed under "library" view. currently it's picking the last songs embedded artwork instead of the albumart.jpg i have placed in each album's folder. the reason the embedded is different is for mix/compilation albums. i use a generic album cover for the entire album but for each track i embed the art for the album the song comes from. i figure this may be an issue with how android works since i remember you saying that the library list is or was handled differently then the folders view. "folders" view is working perfectly.

Share this post


Link to post
Share on other sites

Hi,

First of all again congratulations for Poweramp, definitely my favorite music app. Also thank you for bringing back the "Classic" skin which is the best in my opinion.

I have 1 issue with the new Beta2 and an issue already present in Beta1

- Beta1/Beta2 : I have a music collection of 1600 files, with all tags and album art correctly set. The full scan takes a bit under 30s which is fast. My trouble is about reboots... Every time I need to reboot my phone, Poweramp rescans the whole collection again :huh: These ~30s become quite annoying this time eventhough working in background but it's a bit I/O intensive and slows down the boot process as I use a third party launcher which also needs to set up, as well as an alternative lock screen, etc. you see the point right ? :)

This collection gets news files from time to time but not that often so I'd like an option in Settings to NOT scan the collection on every reboot. I have no problem doing it myself manually if I need to as I perfectly know when I add files to the collection.

- Beta2 : I set back the Classic skin, by far my favorite but the "Poweramp LockScreen" doesn't take it. In fact, it takes it but partially because the control buttons (Prev, Play/Pause, Next) seem to be taken from "Aluminium" skin. Checking the option "Use default theme" indeed switches to the "Neon" theme and unchecking it shows the same bug again, so no luck for now.

Finally, a suggestion :

- In the library listing, I miss a "Random 50" (or "Random 100") to build a playlist out of 50/100 randomly taken songs from the whole library. This is something I use a lot in my desktop player and it's very nice to play songs you "wouldn't think of" if you had to select songs yourself.

Keep up the good work ! :rolleyes:

Share this post


Link to post
Share on other sites

Love the new skin, and the player is working very well for me. Thank you.

Share this post


Link to post
Share on other sites

zifferal

What are file formats in your multidisc sets? (mp3/m4a/something else)? Note that disc tag (tpos for mp3) is not read at all currently by Poweramp (was deferred), but still it's possible to quickly add this for some formats.

Thanks!

Not zifferal, but since I'm experiencing the same issue, currently I'm using MP3 (with M4A on PA1.4, I would sometimes hear slight popping between tracks on gapless playback, and not hearing the same thing with MP3). But eventually it will be one of these (I'd use M4A for slightly higher quality at the same bitrate, all other things being equal). Hope this is helpful!

Thanks!

Share this post


Link to post
Share on other sites

Awesome build! I would say "release" but I'll reserve that for the final.

One thing I'm noticing, and I'm not sure I noticed this in beta1, or the previous stable release - due to how I'm syncing my music to my SGS2 device I have a few album folders that have album art, but no longer actually have any MP3/AAC files in them - however, Poweramp still shows them up as valid albums ( took me a while to work out why beta2 was adding 0 files to the queue - NO FILES *doh* ).

It'd be great if Poweramp hid them from view.

Share this post


Link to post
Share on other sites

Fantastic release! I have yet to come across any noticeable issue and it seems very stable. I had one question though, what are the different styles in the 4x2 and large widget for? They don't seem to change anything, no matter which of the 3 styles I choose.

Also, is there any way i can sync wirelessly to Media Monkey on my PC?

Share this post


Link to post
Share on other sites

Many thanks for updating!

So, I have a question. What about sorting songs on list by date of change at SD card?

Share this post


Link to post
Share on other sites

Love the new skin, and the player is working very well for me. Thank you.

I'm using the Aluminium skin. Not because I especially like the look (I actually much prefer the black/glowing interfaces) however I LOVE the positioning of the Play/Ffwd/Rwd/etc buttons at the very bottom of the screen, below the track title & seek bar. Not only does it feel more logical to have the seekbar nearer to the track art but it makes it MUCH eaiser to press the item I wanted to press, rather than catching other system buttons by mistake.

Could you maybe implement stock versions with the same layout in the other colours too, i.e with the title/seek-bar and the buttons-panel swapped round? (Or will the skin editor allow this to be done very easily, by someone who has never edited a skin in his life? :) ).

Andre

Share this post


Link to post
Share on other sites

Also found a minor bug in beta 2:

In Library mode, the 'Recently Added' category does not seem to work. When I select it, I see 200 very old tracks (although oddly not the very earliest tracks on the SD card) and using the List Options 'Reverse' mode doesn't do anything, I still see the same list of old songs in same order as before. I assume it should be sorting the list based on the most recently created (or modified? file dates first?

[Edit: In fact, 'By date added' sorting does not seem to work within a folder filelist view either, and there too 'Reverse' does not change the order of what is displayed]

Andre

Share this post


Link to post
Share on other sites

Gee! Real good. Has been working great for me so far. Keep it up!

Just one or two tweaks I would make. Do you know this when you are just flicking through songs to find the right one. Since I have piles of songs, I do that pretty often.

What I am asking here is that only the songs that have been played at least 10 should be added to Most played and recently played sections. No less than 10 secs. Because then there are a lot of songs I haven't actually listened to in these sections, cause just flipping through.

So if it weren't that difficult, I would really appreciated it.

Also, switching between the main panels (i.e. Folders, Player and Library) could be done by a swiping gesture. I would look much cooler this way.

Share this post


Link to post
Share on other sites

I noticed this on v1 but when I'm changing my song manually I hear a slight background noise whenever it shuffles songs.

Share this post


Link to post
Share on other sites

Is it normal the EQ looks like this?

1319106253.png

With those lines or something? Can't it be just 1 color? I mean the Vol/Bal part.

//EDIT

Maybe you can't see it well on the screenshot but on my phone (Galaxy S) I see a kind of lines...

Share this post


Link to post
Share on other sites

Yes, I can confirm this too. Example: Song is playing or not, no matter, go to ''Library''-->''Artists''-->''Albums''===> some picked songs from other artists refuses to play, but not all. All songs are common mp3.

I can also confirm that this is happening for me too... a bit odd. The albums play fine in folders mode but when in library mode they refuse to play.

BTW excellent work on the beta-2 :)

The genre split on "/" is gone - w00t B)

Share this post


Link to post
Share on other sites

Thanks Max!

One last thing. There appears to be a major bug in going from beta 1 to beta 2 (I presume, unless it's just a bug in beta 2 in general). I can view all the artists/albums in my library, but for some reason when I go to a song in an artist's album through the library, it refuses to play it. I essentially have to trick PA into playing it by queueing it up or by playing all the artist's songs first.

Has anyone noticed this?

EDIT: I uninstalled and re-installed and it's happening again. My music is on my SD card and it refuses to recognize any one of them when I try to open them by going Library -> Artist -> Album -> Song. It works if I go Library -> Artist -> All Songs -> Songs.

It seems as if PA gets confused and thinks that "All Songs" is in fact the album.

I'm experiencing the exact same thing. I'm on a DROIDX and I tried uninstalling and erase and scan, nothing fixes it. Can't play most of my stuff from artist. Its basically unusable so I just went back to Beta 1.

Anyway besides that great job. 2.0 is awesome.

Share this post


Link to post
Share on other sites

×
×
  • Create New...