Jump to content
BROKEN

DTS/ Poweramp/ Pie/ LG V30

Recommended Posts

On 8.0 with DVC on, I was able to play music with DTS on. After updating to 9.0, with DVC on, DTS no longer works.

If I turn off DVC, DTS works but the audio quality is horrible and output is 16bit.

This is a bug in Poweramp since UAPP ( USB Audio Player pro) can play direct bit perfect 24bit output with DTS on. Even the stock LG music app can play with DTS on.

Share this post


Link to post
Share on other sites

The built in system wide effects usually don’t work with hi-res and/or DVC.

Some devices/firmwares may force standard resolution if system effects are enabled (e.g. dolby for OnePlus and similar devices).

PS UAPP doesn’t show the actual playback parameters for internal dacs -  it shows the user selected parameters, in your case resampling back to standard resolution happens, most probably, allowing system effect.

Share this post


Link to post
Share on other sites
1 hour ago, maxmp said:

 

PS UAPP doesn’t show the actual playback parameters for internal dacs -  it shows the user selected parameters, in your case resampling back to standard resolution happens, most probably, allowing system effect.

Actually UAPP is doing 24bit with DTS:X. It's easy to check with audio flinger.

Poweramp used to as well on 8.0

I can't see the reason why this would change on 9.0

Share this post


Link to post
Share on other sites

@BROKEN then it should work with Poweramp Hi-Res output ("No DVC" should be enabled for that output) too. Unfortunately my LG devices stuck on Android 8. 
BTW That DTS thing (At least for G7 @ 8.0) does small equalization + some stereo expansion - easily reproducible via Poweramp tone + StereoX controls. In next builds I will rename StereoX to DSTHD HRXS 3D PRO 🙂

Share this post


Link to post
Share on other sites
27 minutes ago, maxmp said:

@BROKEN then it should work with Poweramp Hi-Res output ("No DVC" should be enabled for that output) too. Unfortunately my LG devices stuck on Android 8. 
BTW That DTS thing (At least for G7 @ 8.0) does small equalization + some stereo expansion - easily reproducible via Poweramp tone + StereoX controls. In next builds I will rename StereoX to DSTHD HRXS 3D PRO 🙂

DTS:X works without DVC. However, on 8.0, I used to be able to enable DVC to make it work.

I don't think the G7 is able to use DTS:X.

The V30 has the DTS framework, LG just never turned it on. I had to enable it in build prop.

ro.lge.globaleffect.dts=true

If it's no longer possible to enable DVC, I hope you can optimize Poweramp some how so that audio quality is not killed. The music gets highly distorted, even with DTS off and Poweramp equalizer turned off.

Screenshot_20191029-161001.png

Screenshot_20191029-161009.png

Share this post


Link to post
Share on other sites

My G7 @ 8.0 has DTS:X, but V30 @ 8.0 (LG-H903DS) - doesn't, so this may be region / per specific model feature.

Also, sound by default shouldn't be distorted with the default (Hi-Res or standard res) output and flat/disable Equalizer/Tone - no matter if DVC is no or off. Try Restore defaults for audio outputs?

Share this post


Link to post
Share on other sites
1 hour ago, maxmp said:

My G7 @ 8.0 has DTS:X, but V30 @ 8.0 (LG-H903DS) - doesn't, so this may be region / per specific model feature.

Also, sound by default shouldn't be distorted with the default (Hi-Res or standard res) output and flat/disable Equalizer/Tone - no matter if DVC is no or off. Try Restore defaults for audio outputs?

Thanks, I'll try resetting the audio and report back.

The V30 got the DTS framework on 8.0. Not sure why LG did not enable it for the device. V30 is not intended to have DTS so I'm unsure why it got the framework. Only way to turn it on is with root.

Also I could have sworn LG-H903DS users on XDA got the framework as well. Might want to check out XDA since it seems every V30 can get root.

Share this post


Link to post
Share on other sites
6 hours ago, maxmp said:

 

Also, sound by default shouldn't be distorted with the default (Hi-Res or standard res) output and flat/disable Equalizer/Tone - no matter if DVC is no or off. Try Restore defaults for audio outputs?

With DVC off, audio is still distorted.

I'm using CCA C10 IEM. 4 BA and 1 DD on each side.

Also want to note, with DVC off, bit rate is 16bit.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...