Jump to content

Headphone buttons not responding.


Recommended Posts

Not sure if this is an Android Issue or related to the app.
I am Using the latest Poweramp v3 from Play Store. (v3-build-845-arm64-play [845004-fe2ba78e)

My phone model is Honor 8x by Huawei and using the latest android Version which is 9.1.0.

I connect my 3.5 headphones and the buttons work fine for a while, then It wont Skip or pause any song, this happens randomly.
Probably related to Headset Micro Service? Disconnecting the device and connecting it again lets me skip songs, but the issue keeps repeating.
I already tried by disabling  Battery Optimization, even given special access to disable anything related to battery optizations,  Write System Settings on, keeping the service when the screen is off, respond to headset buttons option, using WakeLock, Keep notification and always keep notification.
Nothing Works.
Thanks in Advance!

Edit: I found out, that a third-party skin for the app was the one causing trouble, not sure how is messing with the settings, but I changed the skin and it works as intended now!

I take it back, is still giving me the same error, help please. 

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Create New...