Jump to content

Recursive Folder Play

Recommended Posts

  • Replies 33
  • Created
  • Last Reply
On 10/29/2019 at 12:19 AM, andrewilley said:

For example, if I am viewing the subfolders contained within /MusicFolders/50 Music/ and I tap on the Play icon at the top of the screen, it works as expected and I start hearing the contents of the first folder in that displayed list (which would be /MusicFolders/50 Music/10cc/*.mp3 in this case). However if I drill down one layer further - for example into /MusicFolders/50 Music/Adele/ - then when I tap on the Play icon (expecting to hear the songs  /MusicFolders/50 Music/Adele/21/*.mp3 and then /MusicFolders/50 Music/Adele/25/*.mp3 ), Poweramp instead starts playing the contents of some higher level folder, in this case the songs in /MusicFolders/50 Music/[Songs]/*.mp3 .

The above Play button functionality within nested folders is still not working for me for build 853.

I've checked @Squeller's post ( https://forum.powerampapp.com/topic/17860-recursive-folder-play/?do=findComment&comment=79379 ) and I tried renaming my Adele folder to 1 Adele as a test, and the Play button then worked correctly inside it, playing the subfolders 21 and 25 in order as expected, so he does seem to have hit upon the problem.


With regards to sorting, when in Folders Hierarchy and using By Filename sorting, drilling down into 50 Music I still still see the following folder order, whereas I would expect to be seeing the [Songs] folder at the end of the list.


(...etc...etc... down to...)
War of the Worlds

My naming logic in Folders mode is to use folder names starting with regular parentheses "(" when I want to push an item to the front of a list - i.e. before numeric and alphabetic folder names - and square brackets "[" to push something after the end of the main alpha list. As shown above, Folders Hierarchy is still not working that way. I don't use any lower-case folder names by the way.


Link to comment
Share on other sites

On 11/7/2019 at 6:06 PM, maxmp said:

I can’t reproduce any issues with playback button in build 852.

It's still exactly as I described. Have a folder "Hello" with subfolders in it and a folder "00" beside the Hello folder. Go into Hello, press play and it plays 00 contents instead Hello subfolders. 

Link to comment
Share on other sites

  • 3 weeks later...
5 hours ago, Squeller said:

I will rename all folders and subfolders to lowercase, ugly, but I hope it works. Will report back. 

Don't do it, it's not worth it. a) Still weird playback, b) TotalCommander Android fails at some point, c) now I have 50 percent lowercase folders, ugly. I accept the button to not work. 

Link to comment
Share on other sites

  • 1 month later...

I've checked, and yes this issue still appears to be present in latest build.

@maxmp it seems to be related to situations where some containing folder names start with either uppercase letters and/or numbers (it's a bit hard to be 100% certain). To demonstrate, a simplification of the folder structure that I have which causes it is as follows (obviously there are lots more folders and files, but this structure should suffice for testing):

    50 Music/



                02-AnotherAdele19 Song.mp3




In Folders Hierarchy mode, drill down mode into the Adele folder so you can see its subfolders (19, 21 and 25) and tap the Play icon. What you would expect is for all of the songs in the album 19 to play, then 21 and 25. What actually happens is the first track in the [Songs] folder starts playing, and that folder continues.


Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

  • Create New...