Jump to content
Poweramp
Spyglass Jack

Recursive Folder Play

Recommended Posts

OK, this is driving me nuts. In V2, I could play a bunch of folders (e.g., all of a band's albums) simply by opening their parent folder and clicking play.

When I try to do that with V3, it will play the first subfolder and stop. Is there a way to tell V3 to play ALL the files in the hierarchy?

I don't want to create a queue or a playlist, I simply want to have it play everything under the opened folder.

Thanks!

Share this post


Link to post
Share on other sites

Repeat mode should be set to 'Advance List' ('List' being the old v2 word for what is now referred to as 'Category'). That way playback will continue on to the next album (or folder,or  whatever your chosen listening category is) after the current one finishes.

@maxmp We've discussed this a few times, but the 'Repeat' icon options are getting a bit dated now, and the wording needs updating to v3 'Category' terminology. Or better still, could you take the opportunity to add that 'single song playback' option that has been so often requested at the same time? (https://forum.powerampapp.com/topic/16724-option-for-stop-after-actual-song/?tab=comments#comment-71539) That would result in six simpler to understand, and more elegant, play/repeat options - only one of which is actually new (the 'one song' option):
Play One Song | Play Current Category | Play All | Repeat Song | Repeat Category | Repeat All

Andre

Share this post


Link to post
Share on other sites

My problem stemmed from the fact I completely forgot there was a "main" screen, because I don't see a button for it, and I never thought to "swipe" back to it. So, I never saw the repeat options when I was hunting for a solution.

Thanks.

 

 

Share this post


Link to post
Share on other sites

That Play button is unusable for me. I'd say it's bugged.

It plays all files in that category level. Not playing files from subfolders. If only subfolders are present, it plays files from a higher level, which is unexpected and confusing. 

Share this post


Link to post
Share on other sites

Ok, inconsistent behaviour. I set playback to "advance list" at another place, which is clunky. 

Then I use that play buttons. In most cases it insists on playing back stuff from a higher hierarchy, in rare cases it plays as expected from the first visible subfolder. 

Share this post


Link to post
Share on other sites

Please watch the video. It plays the exm folder as expected. All others which I tested it does not.

I forgot to include sound, but you can see, most of the time it starts playing that "Freeman Hardy..." track. Instead of playing tracks inside the visible scope. 

 

Share this post


Link to post
Share on other sites

Issue still exists in the last two betas. I still don't get why the play button mostly plays stuff outside the visible scope instead of subfolders.

I wonder if nobody else has this problem. 

Share this post


Link to post
Share on other sites

I don't know what's different about your setup that is causing this either, it works as intended for me. It might be worth setting PA back to all default settings (clear app data) and see if that changes things? As a precaution, you should export your current settings and any internal playlists first. 

Andre

Share this post


Link to post
Share on other sites

*sigh*, yes, I'm doing this. Will see after the scanning if it works out. Will have a close look on every setting then. 

Share this post


Link to post
Share on other sites

An observation: it now always plays "05 Sweet Exorcist" track. It's displayed on top of the "_Diverse" folder.

After restore settings it always plays "Freeman Hardy" track as shown before. It is now also on top of that folder.

Both files are in the library in both cases. 

Share this post


Link to post
Share on other sites

I've just managed to duplicate this issue. It only seems to occur when you are several layers deep in Folders Hierarchy.

For example, if I am viewing the subfolders contained within /MusicFolders/50 Music/ and I tap on the Play icon at the top of the screen, it works as expected and I start hearing the contents of the first folder in that displayed list (which would be /MusicFolders/50 Music/10cc/*.mp3 in this case). However if I drill down one layer further - for example into /MusicFolders/50 Music/Adele/ - then when I tap on the Play icon (expecting to hear the songs  /MusicFolders/50 Music/Adele/21/*.mp3 and then /MusicFolders/50 Music/Adele/25/*.mp3 ), Poweramp instead starts playing the contents of some higher level folder, in this case the songs in /MusicFolders/50 Music/Adele/[Songs]/*.mp3 .


By the way @maxmp , while researching this I found that there seems to be a discrepancy in the sorting order used in Folders (set to sort 'By Path') vs Folders Hierarchy (set to sort 'By Filename' as there is obviously no 'Path' option). I use round brackets "(" at the start of folder names to force items to the top of a list, and square  brackets "[" to force things to the end of the list.

In Folders mode, the first few items of my 50 Music folder are shown as expected, thus:
10cc
ABC
21 - Adele
25 - Adele

(...etc...etc... down to the end of the list...)
War of the Worlds
[Songs]

Whereas in Folders Hierarchy, drilling down into 50 Music , I see:

10cc
[Songs]
ABC
Adele

(...etc...etc... down to...)
War of the Worlds

Not sure why the square-bracketed item [Songs] is being sorted in between numeric and alphabetical names in Folders Hierarchy mode, but where I want it to be (i.e. at the end of the alpha list) in plain Folders mode.

Andre

Share this post


Link to post
Share on other sites

Yes, observed the sorting thing as well.

I disagree about the depth of folders. I found it: Play button works as expected only inside folders which start with a lowercase character or number! Please have a look!

I. e. if a folder starts with a capital letter, PA plays something else, as already described. 

Share this post


Link to post
Share on other sites

Thanks for the details on the problem - most probably will be fixed in the next 850 build.

Share this post


Link to post
Share on other sites

@andrewilley regarding folders sorting. (Plain) Folders uses case-sensitive sorting when sorted by Path. Folders hierarchy uses case-insensitive sorting for its (default) path sorting. For the next 850 build I'll try to use case sensitive sorting in both cases, though, somebody may complain (or not) as folders hierarchy sorting will change a bit.

 

Share this post


Link to post
Share on other sites
52 minutes ago, maxmp said:

 For the next 850 build I'll try to use case sensitive sorting in both cases, though, somebody may complain (or not) as folders hierarchy sorting will change a bit.

Yes, I can see that might causing problems for people who were depending on the old functionality in the other direction.

Perhaps an option for choosing whether file/path sorting should be strict and literal ASCII, or more of a smart system rather like Windows uses (case insensitive, strings of several numbers treated as numeric values rather than strict ASCII so '9' comes before '10', etc)

Andre

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...