Jump to content
Poweramp
smiller

Files with foreign characters in the filename will not be imported from .m3u playlists

Recommended Posts

I have entered a formal bug report on this but am mentioning it here in case anyone has any input. I have noticed that when importing .m3u playlists, any filename containing foreign characters will be skipped and not populated into the playlist. For example, if the filename contains Dvořák the file will be skipped during the playlist import scan, but simply changing the name to Dvorak will result in the file being properly included in the playlist. This is with v3-841on Android 10, but I have a suspicion that the bug is present on all versions.

Has anyone else come up against this?

 

Share this post


Link to post
Share on other sites

If you are using non regular-ASCII characters, you need to use .M3U8 format (which uses UTF-8 encoded text) rather than plain .M3U (which officially supports regular alpha-numeric characters only). There is an override setting in Settings > Library > Scanner which might help you too (from Poweramp build 842 onward).

Andre

Share this post


Link to post
Share on other sites

Ah, understood, thanks. Knowing this, in my case the easiest solution would probably be to simply eliminate any non-standard ASCII characters in filenames since the number of non-compliant files is not large. Thanks for the prompt response.

 

Share this post


Link to post
Share on other sites

Or just turn that override switch on. Or rename the playlist files to use the .m3u8 extender. Either should do the trick, no need to mess with your files.

Andre

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...