Jump to content

Poweramp Builds 842-853


Recommended Posts

Hey guys,

Anyone know how to restore the shuffle function back to normal? What I mean, when I select a song from "Recently Added" for some reason the Shuffle Mode automatically goes to "Shuffle Songs" which before this update, it would remain on the last used shuffle mode, in my case "Shuffle All". I like to have Poweramp always on "Shuffle All", is there a way to keep this shuffle mode all the time?

Link to post
Share on other sites
  • Replies 243
  • Created
  • Last Reply

Top Posters In This Topic

@technoviking10 due to the playlists (including smart playlists) new capability of having songs which are not in "All Songs" category (such as streams or playlist tracks which are located outside of Poweramp library/folders), it's not possible to use Shuffle All mode (which shuffles exactly All Songs category) there.

Or, if we use Shuffle All mode in a playlists, it will skip all the non-library/folders tracks/streams.

Link to post
Share on other sites
6 minutes ago, maxmp said:

@technoviking10 due to the playlists (including smart playlists) new capability of having songs which are not in "All Songs" category (such as streams or playlist tracks which are located outside of Poweramp library/folders), it's not possible to use Shuffle All mode (which shuffles exactly All Songs category) there.

Or, if we use Shuffle All mode in a playlists, it will skip all the non-library/folders tracks/streams.

So everytime I select a song from "Recently added" but I want the next song to be random and be selected from "All Song", I will have to manually change the shuffle mode to "Shuffle all" all the time?

Link to post
Share on other sites
On 9/29/2019 at 7:58 PM, maxmp said:

As for time error for some tracks - I need those tracks to test - so if it's possible please share them for the testing.

For now I've re-encoded the files as flac and the thing with the length time is gone, so I'll probably stay with this for a while longer (I prefer Tak over flac for some files as it has better compression, a few megabytes here and there group up to form almost a gigabyte after a certain point) and wavpack to compress DSD and 32bit files. Is something wrong with my encoder? I use foobar2k with the command line version of Tak 2.3.0 and wavpack 5.1.0 to do those files and this only seems to happen on Poweramp...

I noticed that this seems to happen only with hi-res files, the CD quality ones seems to be unaffected. I'll make some and upload somewhere so you can check it, but this will probably take some days since my upload rates are abysmally low so I'll wait until I go to somewhere with better connection speeds

Link to post
Share on other sites

@ScarletNeko if you can share one of such buggy tracks with me (gpmaxmpz@gmail.com) I'll check and probably fix that. The problem with many formats that there is no any standard and tracks in the wild may vary in many parts depending on encoder and settings. Thanks!

Link to post
Share on other sites
On 9/30/2019 at 6:13 PM, prag.un said:

thanks for adding an alternative font and the various other icon options.

I'm facing an issue with the search button and the library button. upon clicking the search button, only my keyboard opens up but I'm not directed to the actual search page (attached a screenshot for reference). and for the library button, it just won't respond at all. can't get it to work until I force close and restart the app a few times.

I hope you get a chance to look into this.

cheers! :)

 

edit: I'm using OnePlus 5 with the open beta 35

Screenshot_20190930-204004__01.jpg

I'm facing the same issue, hope you could do something.

Link to post
Share on other sites
On 10/2/2019 at 2:15 AM, maxmp said:

Or, if we use Shuffle All mode in a playlists, it will skip all the non-library/folders tracks/streams.

Sounds very sensible to me. Why would you want a streaming audio station to appear in a shuffle list anyway? It would never end, and so never be able to shuffle on to something else.

Come to that, I've been suggesting for a long time that some types of track really should not appear in Shuffle sequences at all. It makes no sense to me when listening to shuffled music to suddenly hear a 90 minute podcast, or a two-hour concert, or an episode of the Hitch-Hiker's Guide to the Galaxy, or a single chapter of an audio book. 

Andre

Link to post
Share on other sites
3 hours ago, Bernardo said:

I'm facing the same issue, hope you could do something.

 

2 hours ago, Bernardo said:

@maxmp Motorola Moto G5 plus, I'm using v3-build-843-arm32-play

Same device (Moto G5+), same problem with the search function, have to force close the app when hitting the search button by mistake. Running latest Poweramp build.

@prag.un who reported this bug first has a different device, One Plus 5.

Link to post
Share on other sites
12 hours ago, andrewilley said:

Sounds very sensible to me. Why would you want a streaming audio station to appear in a shuffle list anyway? It would never end, and so never be able to shuffle on to something else.

Come to that, I've been suggesting for a long time that some types of track really should not appear in Shuffle sequences at all. It makes no sense to me when listening to shuffled music to suddenly hear a 90 minute podcast, or a two-hour concert, or an episode of the Hitch-Hiker's Guide to the Galaxy, or a single chapter of an audio book. 

Andre

Absolutely! 👍

Link to post
Share on other sites

 

12 hours ago, andrewilley said:

Sounds very sensible to me. Why would you want a streaming audio station to appear in a shuffle list anyway? It would never end, and so never be able to shuffle on to something else.

Come to that, I've been suggesting for a long time that some types of track really should not appear in Shuffle sequences at all. It makes no sense to me when listening to shuffled music to suddenly hear a 90 minute podcast, or a two-hour concert, or an episode of the Hitch-Hiker's Guide to the Galaxy, or a single chapter of an audio book. 

Andre

+1

BTW, 843 solved my problems, does not crash any more. Thanks Max!

Link to post
Share on other sites
On 9/30/2019 at 6:32 AM, Asenah maasenah@gmail.com said:

Yeah it's now working after disabling the volume panel. Cool!👍👏

@maxmp a bug when doing a search of song, the songlist and main player collages whenever I press the song playing.

Huawei Y6 Pro 2019

Android 9.0 (EMUI 9.1)

Latest build

Link to post
Share on other sites
  • andrewilley changed the title to Poweramp Builds 842-853
  • maxmp unfeatured and unpinned this topic

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...