Jump to content
Poweramp
maxmp

Poweramp Build 840-841

Recommended Posts

On 8/9/2019 at 7:40 PM, maxmp said:

@superluig164 correct, see https://developer.android.com/preview/privacy/background-activity-starts for details. The limitation is due to inability to start any activity from "background" app.

As usually, there can be "workarounds", as soon as they are discovered, I think I reenable this, but at the moment it won't work. Thanks!

Thanks for the clear explanation, is not really a super deal breaker but i will miss being able to forward in a song without having ty unlock the phone lol

Share this post


Link to post
Share on other sites
On 8/17/2019 at 1:47 AM, Prasad1337 said:

Sucks about the lockscreen.. feels like a huge step backwards! :(

Personally I feel that each new Android release gets closer and closer to the Apple philosophy or "we will tell you how it now works, and you will like it" (SD Card access keeps getting worse and more restrictive too). Which was precisely the reason I went with Android rather than iPhones in the first place.

Andre

Share this post


Link to post
Share on other sites
21 minutes ago, andrewilley said:

Personally I feel that each new Android release gets closer and closer to the Apple philosophy or "we will tell you how it now works, and you will like it" (SD Card access keeps getting worse and more restrictive too). Which was precisely the reason I went with Android rather than iPhones in the first place.

Andre

I feel this too.  It really sucks.  I hope either Google sees the light and fixes it, or something else comes about with the original Android vision that I can switch to.

Share this post


Link to post
Share on other sites

@maxmp

I’ve been using Poweramp on my Fiio M11 perfectly, but I have two questions and I’m hoping that at least a fix is available for one of them at least because it is making me considering changing apps.

Recently I’ve got myself some DSD files, in which when I play using Poweramp the volume is extremely low (DVC is off, Hires output is on) when I play any other track, like a FLAC then the volume is loud and crisp but only DSD (DSF files) play at a volume that is way too low.

the same DSD in Fiio Music is played at an actual louder volume than the regular FLAC files, so I at least know it’s not the file. Any chance there will be a fix on the volume levels of DSD files? 

-

Another thing I’ve noticed with the 64 bit builds is that some visualisations play extremely laggy. When I switch to the 32 build then they are fine. On 64bit the app runs fine, it’s just visualisations are jumpy, and I noticed there is no 32 bit build for the latest release, which is concerning.

any idea about these issues I’m having?

EDIT: oh and I’m release 838, since that was the latest or last with a 32 bit build available. 

Share this post


Link to post
Share on other sites
8 hours ago, mehrro said:

Recently I’ve got myself some DSD files, in which when I play using Poweramp the volume is extremely low

That's normal, there's a lot of DSD files and even PCM formats when it's on rates like 192k and up that are like this. I don't think I can explain but yeah it happens. To level the volume you probably should try using that thing called Replay Gain (or RG for short). I'm not sure of the proceedings since I don't use it but I know programs like foobar2000 and aimp for PC has a replay gain feature that scans and apply the tag for it.

8 hours ago, mehrro said:

Another thing I’ve noticed with the 64 bit builds is that some visualisations play extremely laggy.

The visualizations has some settings, maybe try the strict rendering option, or trying switching the crop aspect. There's the HD switch as well that you can try activating and deactivating for testing. I never had problems with the visualizations on 64bit builds so I'm saying just some things to try and see if something changes.

Share this post


Link to post
Share on other sites

Thanks for the reply. If the DSD is meant to be like that, then how do you explain why Fiio Music player actually plays those DSD files louder than the FLAC files? 

Ill experiment with the Replay Gain, but hopefully it doesn’t also alter the volume of the FLAC files I have. Everything plays fine except the DSD, and as I mentioned other programs play them nice and loud, so I’m assuming it’s something within Poweramp.

 

In regards to the 64 bit, it’s strange that you don’t get lagginess on some of the visualisations. Some play fine but others are laggy, which I thought weren’t optimised for the 64 bit builds. I have the crop and HD turned on, it plays fine in 32bit but same settings, even if I turn them off, still cause lag in the visualisations.

Share this post


Link to post
Share on other sites
7 hours ago, mehrro said:

If the DSD is meant to be like that, then how do you explain why Fiio Music player actually plays those DSD files louder than the FLAC files

It probably has some kind of replay Gain or other kind of pre amp speficially for DSD maybe. I do have a few albums that has replay Gain info and on my PC, they play with same loudness as others on aimp but on foobar I need to turn on the replay Gain for everything, which actually reduces the volume of other things a little and boost the ones that need until they match. On Poweramp they actually play fine as well, I think I have replay Gain by album activated.

 

7 hours ago, mehrro said:

I have the crop and HD turned on, it plays fine in 32bit but same settings, even if I turn them off, still cause lag in the visualisations.

I indeed never had problems with visualizations since the 64bit builds started, and I don't remember seeing people talking about this. I use just the HD slider, but even with crop aspect nothing changes on performance. Sometimes I go through visualizations when I'm bored and never had problems with any, so I probably can't help with that.

Maybe doing a clean install of your Poweramp? Or deactivating any kind of battery treatment for Poweramp (depending of the device it can kill the Poweramp process or slow it down to save battery and so on)? You probably should poke Andre or Max for this one

Share this post


Link to post
Share on other sites

It takes forever to get new updates on the play store. I am still on 838. I just uninstalled and reinstalled the app. Seems like the updates on play store just take forever.

Share this post


Link to post
Share on other sites

Was the option for a sample rate more than 96kHz taken out? Because the option was there before, and now it's not. I have no idea why. I had it the highest one (forgot which one it was) and just saw that it's at 44.1kHz, while it should be at the highest sample rate. It's been anabled and I was using it before, but I dunno what happened to it. I have a Galaxy S10+ running the latest Android version :)

Share this post


Link to post
Share on other sites

@Chubby Doughnut no, actually Samsung improved hi-res support in latest “security” patches and that’s fully supported by 841. Try to use Restore defaults on Hi-rea output and adjust sample rate (Samsung still supports just 192kHz/24bit/DVC and 384kHz/32bit/no DVC). Thanks! 

Share this post


Link to post
Share on other sites

Hello,

I have a small problem with playing with the Hidizs Sonata HD.

The device is recognized as a USB DAC and plays music as well as sound, there is nothing to complain about.

And now the problem, a few seconds after the display turns off, the sound is gone.

The player keeps running, does not pause or something similar.

As soon as the display is on again, the sound is also there again.

The same happens even if Poweramp is moved to the background and I write a message or something similar.

In these cases, the sound is always gone for 1 to 2 seconds and then back.

Poweramp does not pause the playback but only the sound transmission is gone.

My device is a Porsche Design Mate RS (Neo-L29)

Android 9 and EMUI 9.1, no root or other modifications.

Can someone help me to fix that please

Share this post


Link to post
Share on other sites
On 8/18/2019 at 10:32 PM, andrewilley said:

Personally I feel that each new Android release gets closer and closer to the Apple philosophy or "we will tell you how it now works, and you will like it" (SD Card access keeps getting worse and more restrictive too). Which was precisely the reason I went with Android rather than iPhones in the first place.

Andre

Agreed. From devices to the OS, these manufacturers need to stop copying Apple awkward movements that even Apple fanboys don't like. Google's new slogan, "we're the same, but different, and those differences are coming to an end.

Share this post


Link to post
Share on other sites
On 8/28/2019 at 6:46 PM, SynekPablo said:

Hello,

I have a small problem with playing with the Hidizs Sonata HD.

The device is recognized as a USB DAC and plays music as well as sound, there is nothing to complain about.

And now the problem, a few seconds after the display turns off, the sound is gone.

The player keeps running, does not pause or something similar.

As soon as the display is on again, the sound is also there again.

The same happens even if Poweramp is moved to the background and I write a message or something similar.

In these cases, the sound is always gone for 1 to 2 seconds and then back.

Poweramp does not pause the playback but only the sound transmission is gone.

My device is a Porsche Design Mate RS (Neo-L29)

Android 9 and EMUI 9.1, no root or other modifications.

Can someone help me to fix that please

The problem has resolved itself, I do not know how or what it was.

Everything works now as it should.

Share this post


Link to post
Share on other sites

A question, do you need to be on the full version to enable 24bit/96khz and above?

I am on trial version and using Samsung Note10+ with Hidizs Sonata HD (Mode D firmware) but it is only detecting as 16bit/48khz.

Share this post


Link to post
Share on other sites
13 hours ago, Josezy said:

A question, do you need to be on the full version to enable 24bit/96khz and above?

I am on trial version and using Samsung Note10+ with Hidizs Sonata HD (Mode D firmware) but it is only detecting as 16bit/48khz.

I use the full version with my Note 10+ (Exynos) and I only get 24bit/48khz out with the included AKG USB-C headphones and also with my dongle (DAC in the dongle did output 192khz on my S9+) ... 

Screenshot_20190901-212518_Poweramp.jpg

Share this post


Link to post
Share on other sites
14 hours ago, Josezy said:

A question, do you need to be on the full version to enable 24bit/96khz and above?

No, the trial is only time-limited, all features are exactly the same as the full licensed version.

Andre

Share this post


Link to post
Share on other sites

Hi guys
mi9t device + ainur sauron driver:
only with the HI-RES audio mode activating the DVC the volume is lowered by a lot (but really a lot).
with opensl and java output, it works regularly.
does anyone have the same problem?

Share this post


Link to post
Share on other sites

So... This only happens when using Poweramp:

When I listen to music, "ringtone" volume has to be at max volume for Poweramp to work. When I lower/turn off "ringtone", Poweramp goes silent.

Other music apps don't do that.

This means that when I'm listening to music and someone sends me a message through Facebook Messenger I go deaf for an hour or two. 

I'm using Poweramp's latest version and I own a Huawei p30 pro (all updated to latest versions). 

Is that a bug? Should I report it?

Share this post


Link to post
Share on other sites
7 hours ago, DenisGuy said:

When I listen to music, "ringtone" volume has to be at max volume for Poweramp to work. When I lower/turn off "ringtone", Poweramp goes silent.

Are you listening using regular or high-res outout modes?

Andre

Share this post


Link to post
Share on other sites
4 hours ago, andrewilley said:

Are you listening using regular or high-res outout modes?

Andre

I hadn't noticed, you're right: I get this symptom only with Hi-Res output

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...