Jump to content
Poweramp
maxmp

Poweramp Build 840-841

Recommended Posts

I previously had a 5.1 channel version of Queens Greatest Hits album that wouldn't play properly (missing channels) on previous versions of Poweramp. It now works well on build 840. Thanks Max!

Share this post


Link to post
Share on other sites

The bug has become a feature: D

But the feature is really cool! On a dark theme and spectrum-centered-wide, like, the playlist looks fine.

Share this post


Link to post
Share on other sites

Visualization feature in Library is very good. It will be perfect if there has different Transparency settings.

Share this post


Link to post
Share on other sites

Thanks for the update btw.

Hi-Res for Kirin 960 stopped working again after update. No Audio but the option is enabled.

Here's the logs:

22:56:41.536 v3-build-840-arm64-play
Device: HUAWEI HUAWEI VTR-L29 VTR-L29 VTR [arm64-v8a, armeabi-v7a, armeabi]

FAILED to read=/vendor/etc/audio_output_policy.conf
FAILED to read=/vendor/etc/audio_io_policy.conf
FAILED to read=/system/etc/audio_policy.conf
reading=/vendor/etc/audio_policy.conf
has outputs_primary, sampling_rates=48000
has usb
has usb outputs
has usb_device, sampling_rates=dynamic
has usb formats=dynamic
USB can handle Hi-Res - sdk=28
OK flags=0x804040400000000
FLAG_VARIANT_DIRECT_HD
FLAG_NEEDS_DIRECT_PCM
FLAG_SUPPORTS_USB
FLAG_SUPPORTS_LDAC
INTERNAL_OUTPUT_FLAG_SR_192K
INTERNAL_OUTPUT_FLAG_SR_176K
INTERNAL_OUTPUT_FLAG_SR_96K
INTERNAL_OUTPUT_FLAG_SR_48K
INTERNAL_OUTPUT_FLAG_SR_44K
 

 

Share this post


Link to post
Share on other sites

@Jae there were no hi-res/audio related changes in 840. Check if Ringtone volume is set too low - it affects hi-res volume for some reason on Huaweis. 

Share this post


Link to post
Share on other sites

Is it possible to add option to have blurred album art library background in addition to the new visualisation library background which does look fantastic!!

Share this post


Link to post
Share on other sites

@maxmp

 

Hi,

I have a Huawei MediaPad M5 10.8inch with the following specs :-

 

CPU: HiSilicon Kirin 960s, Octa-core; 4×A73 (2.1 GHz) + 4×A53 (1.8 GHz)

Audio : 4 Speakers + 4 SmartPA:

Smart channel switch

Patent Histen sound effects

Harman Kardon tuning and certification

Hi-Res Certificated, Hi-Fi DAC AK4376 and noise cancelling

 

 

The DAC on the tablet has the AK4376 which has the following specs:-

 

AK4376
32-bit Advanced Stereo D/A Converter with Headphone Amplifier
DR,S/N: 125dB THD+N: -107dB Support up to 384kHz Sampling Rate

 

 

Now before the Oreo update the software was working fine and using the DAC correctly 32bit and 384kHz on the wired hires output. After the Oreo update the Hi-Res showed no Wired output so no headphones but your recent update Build 839 fixed the issue and shows Hi-Res wired and working now, BUT only at 192Khz and 16bit or 24bit which is not correct and same issue on build-840, so I'm guessing the DAC is not being used correctly or at all and only the Kirin 960s DAC is being used. I purchased the device and your software because it did work correctly before and for long periods of time it didn't work at all due to Oreo update and no working solution with Poweramp until recent Build 839 and build-840 has same issues too, but still no 32bit and 384Khz as was before the Oreo update.

 

These are the only logs available on the device for Poweramp and as can be seen it only shows 192Khz and no mention of the DAC and also there is none of these files on the device :-

audio_output_policy.conf
audio_io_policy.conf
audio_policy.conf
 

 

 

01:40:07.651 v3-build-840-arm64-play
Device: HUAWEI HUAWEI CMR-W09 CMR-W09 CMR [arm64-v8a, armeabi-v7a, armeabi]
 
FAILED to read=/vendor/etc/audio_output_policy.conf
FAILED to read=/vendor/etc/audio_io_policy.conf
FAILED to read=/system/etc/audio_policy.conf
reading=/vendor/etc/audio_policy.conf
has outputs_primary, sampling_rates=48000
has usb
has usb outputs
has usb_device, sampling_rates=dynamic
has usb formats=dynamic
USB can handle Hi-Res - sdk=28
OK flags=0x804040400000000
FLAG_VARIANT_DIRECT_HD
FLAG_NEEDS_DIRECT_PCM
FLAG_SUPPORTS_USB
FLAG_SUPPORTS_LDAC
INTERNAL_OUTPUT_FLAG_SR_192K
INTERNAL_OUTPUT_FLAG_SR_176K
INTERNAL_OUTPUT_FLAG_SR_96K
INTERNAL_OUTPUT_FLAG_SR_48K
INTERNAL_OUTPUT_FLAG_SR_44K
 
 

DAC details here :-

https://www.akm.com/akm/en/aboutus/news/20160115AK4376_001/

 

Tablet details here :- https://consumer.huawei.com/uk/tablets/mediapad-m5/tech-specs/

 

The device is also Hi-Res Certified .

 

Any help to make this device work correctly would be great, as I only purchased it for this reason as it had a great DAC and your software made it shine and work great before the Oreo headache update that broke Hi-Res support for wired and I don't want to use external DACs and that was the reason for this device as it had a Great DAC built in.

 

Thanks and hope to hear from you with a fix and also some reasons why the missing files on this device on Oreo (not sure if they were there before as all worked 100% before this update) :-

Missing files.

audio_output_policy.conf
audio_io_policy.conf
audio_policy.conf
 
 

 

 

Share this post


Link to post
Share on other sites
8 hours ago, cees said:

Is it possible to add option to have blurred album art library background in addition to the new visualisation library background which does look fantastic!!

+1

Also needs independent Transparency customize option for new visualization.

Share this post


Link to post
Share on other sites

@Purgatory thanks for the detailed report. Many Huaweis do declare 384kHz but all device I have on hands fail to play anything with this sample rate, so it’s disabled. I’ll try to get MediaPad for tests and if it supports 384kHz for current ROM, 384kHz will be reenabled. (Please note that OEMs may modify audio features in ROM updates, for example Samsung “nerfed” their Hi-Res support for all major Android versions 7-8-9 and Qualcomm based ROMs downgraded it for 8-9). As for bits, Poweramp always tries to use the max available bitdepth. The number you see is as reported by audio subsystem for driver-SOC edge.

Share this post


Link to post
Share on other sites

Man I love PA, it is hard not love Mr Max , you deserve to be appreciated. I love every single feature of this great app, thank you.

I have LG V30 quad dac feature + PA =====  great feeling

Share this post


Link to post
Share on other sites

Poweramp lock screen doesn't work in Android Q, I'm sure you're prolly working on that but since I'm currently on Q, figured id mention it as everything else seems to be working fine

Share this post


Link to post
Share on other sites

@thesleezking Sorry, but Google removed that functionality from Q. May be 3rd party ROMs will allow that, to date, they don't.

Share this post


Link to post
Share on other sites
38 minutes ago, maxmp said:

@thesleezking Sorry, but Google removed that functionality from Q. May be 3rd party ROMs will allow that, to date, they don't.

Apps can't display over the lockscreen anymore?  Wow.  Android's really regressing,

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...