Jump to content
Poweramp
Sign in to follow this  
Madthunder

Problem with volume levels under advanced tweaks

Recommended Posts

Build: v3 836, 838, 839

Device: Nokia 6.1 (2018)

Android Version: Pie

Rom: Stock

When volume levels is set to something other than system default, changing volume works as expected in the app but becomes bugged outside the app.

Pressing the volume up key increases the volume but the second volume slider for chromecast is increased at the same time.

Pressing the volume down key does nothing because both volume sliders become stuck.

I can still manually adjust media volume in the android sound settings.

The only way to fix this is to either force quit Poweramp or stop the player service under developer options -> running services -> Poweramp.

The problem appeared after the June security update but that could be a coincidence.

 

 

Share this post


Link to post
Share on other sites

Thanks for the feedback. I can't reproduce this on Pie devices, will try to test exactly your phone soon.

Share this post


Link to post
Share on other sites

Any update on this problem? Were you able to reproduce the issue? I will send you the logs I tried to record.

Share this post


Link to post
Share on other sites

No. I don’t have exactly 6.1, but my Nokias 5, 7.1, 8 all on latest Pie work fine with advanced volume levels (tried 100). I guess, the issue you’re experiencing is related to some other app which intercepts volume presses. This can be any app which eg. tries to switch tracks with volume presses, apps which do photos on volume presses, any other apps with volume key assignment.

PS I was able to reproduce something like you're describing on another device (OP7Pro) after it updated to latest "security" patch, so will try to fix it for 841. The issue happens only when Poweramp is paused. Thanks!

Share this post


Link to post
Share on other sites

Thanks for the update. I tried it again and I think you are right. The problem only occurs when Poweramp is paused. I'm looking forward to the fix!

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×