Jump to content
Poweramp

Recommended Posts

Posted (edited)

Yo, almost everything seems to be working fine so far, and the equalizer/tone values are very helpful now, I'll redo my equalizer settings later to get more precision

But there's two things I noticed that seems weird. One is, when you click on the equalizer button, from the bottom navbar, the animation is fine but when you go back to the now playing screen, from the equalizer screen, the transition is very sharp

The blurred background simply pops in without any animation at all as soon as you click the button to go back, but the rest of the UI do the animation. It didn't happened on previous builds. This is 100% reproducible as it always happen. Video included.

It's not a player breaking feature, but maybe it weren't supposed to act this way? I mean, the older builds the blurred background had a fade in animation as well...

I'll say the other one on another post to not make this yet longer

 

LG G7, Stock LG UI ROM, Android 8.0.0, Poweramp V3 build 839

 

Edited by ScarletNeko
Deleted the video as the thing had been solved and to get some space back

Share this post


Link to post
Share on other sites

The other thing I've noticed is actually for a long time already, not exclusive to this build but since Poweramp got support for wavepack5. It's just a strange behavior with the music length, it doesn't affect anything with the exception of that feature that remembers where you stopped on a long file, used for podcasts.

So, for example, the audio time is 4m09s, but if you skipped to another track on the 1m mark, when you get back it will start from where you stopped. Even tho this feature is settled for 30min+ files for me. But other than this and the weird time stamp, everything play and work fine.

Oh also, this just happens on the music library, when you play the file, the now playing screen shows it correctly and seems to happen at random. Happens more time than not and it seems to pick a specific file to do this... I have other wavpack files that never happened and others that on each build they cycle between happening or not.

Already tried changing the name and tags, re encoding them, changing the source file and even the encoder, it simply doesn't change at all.

The files in which this is most likely to happen is wavpack files with DSD streams on it.

20190731_080130.jpeg

Share this post


Link to post
Share on other sites

@ScarletNeko I tried couple of dsf.wv files I have and I can't reproduce behavior you're describing. Note that there is per folder and per playlist option to force per-track permanent position (via header menu / List Opts / Per-track position). This will apply such stored position when track is played from these categories, but won't do it e.g. for All Songs/Shuffle All/Search results.

Share this post


Link to post
Share on other sites
Posted (edited)
On 7/29/2019 at 11:17 AM, maxmp said:

@Onurtag the issue with visualizator visible in library is due to the (non default) Show album art option disabled. To be fixed in the next build. Again, if you think it’s useful, I can add a new option to allow visualization in library as well.

+1

This would be amazing I have the same thing happening on my pixel 3xl and I'm temporarily using my pixel 2 xl and was wondering how to get it to work on there too.

Also is it possible for a option for the visualization shuffle to only shuffle liked/favorited visualizations?

Edited by Mrfantastic

Share this post


Link to post
Share on other sites
Posted (edited)

Hey, it's me again! This time I'm with what might be a real bug

But the thing is, that's actually a very cool bug, lol

Just play a music, select a visualization and keep the visualization option on "Fade Controls", now just wait for the controls and album art to fade and click on where the album art would be. Now you'll have a list with a dynamic background.

Although that's a bug, it's actually very interesting, lol. For me this just happens on the first level tho, if I go back one folder by swiping left or right, it goes back to the normal behavior.

LG G7, Stock LG UI ROM, Android 8.0.0, No root nor any modifications. Poweramp V3 build 839

Screenshot_2019-08-01-15-37-36.png

Screenshot_2019-08-01-15-38-55.png

Edited by ScarletNeko
Added device info

Share this post


Link to post
Share on other sites
13 hours ago, ScarletNeko said:

Just play a music, select a visualization and keep the visualization option on "Fade Controls", now just wait for the controls and album art to fade and click on where the album art would be. Now you'll have a list with a dynamic background.

But the thing is, that's actually a very cool bug, lol

 

As so many people seemed to like this 'undocumented feature' (aka bug :) ) Max has now made it an official selectable option in Settings > Visualisation from build 840 onwards. If you want to keep it, please turn this option on. 

Andre

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...