Jump to content
Poweramp

Recommended Posts

Hi all. I cannot find the setting to remove all fade in and out. I'm not a fan of "modifying" the music in any way whatsoever and would like to hear the music as the artists intended. 

My main issue at is when I play an album from the start I am missing out on hearing a nanosecond or something very short due to a fade in that I have already disabled in the settings. It's mostly prominent in music that has a strong or abrupt start, no natural or artistic fade in. So I am wondering if there is another setting I am missing that I also need to disable.

Can someone please point me where all the fade in and out settings are located so I can confirm I've done all I can to avoid this fading? 

Share this post


Link to post
Share on other sites
5 hours ago, griff said:

Can someone please point me where all the fade in and out settings are located so

That would be

Settings > Audio > Crossfade, Fade, and Gapless

Screenshot_20190716-064032_Poweramp.jpg

Share this post


Link to post
Share on other sites

Also please ensure that you are using at least build 838 of Poweramp, as prior to that there would most likely be a very short fade-in anyway (this was originally put in place to avoid potential clicks when abruptly beginning a loud-starting track).

Andre

Share this post


Link to post
Share on other sites

Hi guys, thanks for the replies. 

Andre, yup, I'm on 838. 

Thanks Blaubär. Looks like some of those settings had restored to default, and I've now fixed them. I think this should solve the issue. I'll post here again if not. :)

Share this post


Link to post
Share on other sites

Hi again guys. 

I've put all my settings for fade to zero or the smallest values I can within the limit of Poweramp's given options. In some cases the smallest is 10ms. This is not enough IMHO. We should have an option for zero. I am still hearing the music being "edited" by PA. Songs with sudden or abrupt starts are being "edited" or having the very start of the song cut (fade in). I really hate this. 

Can anything be done about this at all, other than ask Max to please give us the option to NOT have the music "edited"?

To be clear, the settings I'm looking at are all in Settings > Audio > Crossfade, Fade and Gapless. And then you've got the following options... 

  1. Auto-advance Fading (I've set it to No fading)
  2. Manual Track Change Fading (I've set to No fading)
  3. Play/pause/seek/manual track... (Both disabled)
  4. Preload Gapless Tracks (set to 0ms) <- Side note: Would this be good to increase for gapless improvement?
  5. Crossfade Length (set to 1000ms - lowest we are given)
  6. Short Manual Crossfade Length (set to 10ms - lowest we are given)
  7. Seek Fade Length (set to 10ms - lowest we are given)

And for the record, I'm on PA v3-build-838, Full Version. 

Share this post


Link to post
Share on other sites

Good question... I will do further listening tests and report back. 

Share this post


Link to post
Share on other sites

So far I've only noticed it on 44.1KHZ 320KBPS MP3 files. But this is what a massive majority of my music library is encoded as. 

Share this post


Link to post
Share on other sites
Posted (edited)

How were the files encoded and with what (VBR or CBR / LAME or Fraunhofer / DBPoweramp, EAC, Nero or other ripper)? Does the problem happen from song to song when playing an album?

I ask because I normally listen to whole albums ripped with DBPoweramp using the LAME encoder set to highest quality VBR and I have no loss of song starts and gapless works perfectly where appropriate like on DSOTM.

EDIT: Also no problem when going from song to song from an .M3U playlist. And one more note, I play music almost exclusively using the PA Queue.

Edited by w3wilkes
Add info

Share this post


Link to post
Share on other sites

Hi. I just noticed another instance of this happening. So that's three albums I can confirm that have it now. And yes, it's on several songs in those albums. This album is also 44.1KHZ 320KBPS MP3.

I only notice it on songs that have sudden / abrupt starts, as I notice the very start being cut. I should clarify when I say "sudden / abrupt" I mean these songs start in full swing from the very first second. I think it's safe to say most songs do not begin this way, so it's not easy to detect. 

I use MediaMonkey to rip my music, so I am certain these three instances / albums were encoded with that, and I'm pretty sure my settings at home are LAME. Yes, the problem occurs when I play the albums in full, and also when I restart the song it still occurs. 

I will rerip the albums that have this issue and play them again. I will also test on other sources (computer at home, wife's phone). I will also play The Dark Side of The Moon today and test that out. Though, gapless is not necessarily the issue here. 

Share this post


Link to post
Share on other sites

Could you upload one of the problem MP3 tracks that should start instantly? And possibly also a short video indicating to us how it sounds on your system when you start that track at the beginning?

Andre

Share this post


Link to post
Share on other sites

Hi again. I did some testing. Played one of the suspect songs in the car. I have Android Auto, so my phone is plugged in via USB. The song played correctly (the very start was NOT cut). This led me to think playing through the 3.5mm headphone jack was the only way to reproduce the issue. Turns out it is. Playing music through my phone using wired headphones is how I first discovered this issue. So later I tried playing the suspect song on the phone's loud-speaker, and there is no issue there. To be sure, I re-riped two CDs that contained suspect songs, the abovementioned one included. I use MediaMonkey, and these settings.

On top of this, I noticed those 2 albums and another 2 albums with suspect songs had large album artwork (300 DPI and over 1000 x 1000 pixels). I changed all the album art to 72 DPI and 700 x 700 pixels. Copied the re-riped albums to my phone, played them, there was no change, sadly the issue persists. :(

Then I saw Andre's last post, and have just made a video showing the issue. Please see it here

I just found the cause. It's the Hi-Res Output Buffer that has done this. I had to enable this recently due to the current version of PA (v838) randomly skipping during song playback. It's in Settings > Audio > Output > Hi-Res Output. I posted about this earlier in the month (it's in this thread). Anyways, in that setting I had both Wired Headset / AUX and USB DAC enabled, and in their respective settings, I had the Buffer Presets set to Huge. I've now tested Buffer sizes Large and Normal, both still reproduce the issue. Only disabling Hi-Res Output will play the song without cutting the start.

What to do? Let the music skip randomly on nearly every song, or let the start on some songs be cut off? I'm a fairly OCD kinda person so both are not ideal. :(

Share this post


Link to post
Share on other sites

Ahhh, Hi-Res. That's why I've not seen this issue. Since all my music on my phone is highest quality MP3 VBR there's not much point to Hi-Res since Hi-Res should have no effect on even the highest quality MP3. And not to start a flame war but, my opinion is that even native CD quality 44.1kHz / 16 bit ripped to lossless FLAC or WAV will gain nothing from Hi-Res. The majority of "Hi-Res" type downloads are really just resampled from original analog recordings which I don't think gain anything other than extracting money from your pocket.

Share this post


Link to post
Share on other sites

Heh... yeah I only enabled Hi-Res Output cos I wanted to kill the awful skipping I was hearing since updating to PA v838. 

I am aware in the Hi-Res Output setting it does warn that it is experimental. So maybe it has a bug causing the fade in / cutting start of music issue I'm having. 

Share this post


Link to post
Share on other sites

For 838, when you set manual crossfade to No fading no any fade applied. (Poweramp doesn’t apply any smoothing in this mode, so fast track manual change from loud sound to silence may cause pop/click).

As for auto advance, if set to No fading, there were no fading prior 838 as well, tracks played in gapless mode.

If you think some track beginning is skipped, please send this track for tests (via Poweramp list Send action / Gmail / gpmaxmp@gmail.com). Thanks!

Share this post


Link to post
Share on other sites

Something with the last update completely screwed up my entire library as well in this manner. I have followed every tweak I could find in the forums to ensure that I am getting truly gapless playback - essential for huge chunks of library, jazz albums, live performances, etc. - and it kept happening.  I finally said to hell with it and rolled back to v.2.  Sorry, I gave v.3 a good long trial and the 'cons' just continue to outweigh any 'pros' for me.  (FWIW, formats are either FLAC or mp3 320 kbs, on a fast SD card.)

Share this post


Link to post
Share on other sites

@Flabbergast to the date on latest release build (838) all gapless tracks reported previously by users are played OK and issues were resolved. If you feel some couple of tracks is not gapless for you, but they should - please send them for testing, preferable via player itself - in lists / Select / Send / Gmail / gpmaxmpz@gmail.com. Thanks!

Share this post


Link to post
Share on other sites

It was literally almost everything in my library of over 100 GB.  I guess I can send the last thing I was playing which was the straw that broke the camel's back..  Sorry, but I have no time and little desire to troubleshoot v3 when v2 is playing things just perfectly now.  I appreciate that a lot of work was put into the new version of this inexpensive audio player that has given me many hours of enjoyment, but I find nearly everything about v.3 from the UI to the setting controls to be non-intuitive and cumbersome.   Good luck and maybe I'll check back in a few months and try it again!

Share this post


Link to post
Share on other sites

Hi Max. 

 
 
 
 
2
On 7/26/2019 at 8:55 PM, maxmp said:

For 838, when you set manual crossfade to No fading no any fade applied. (Poweramp doesn’t apply any smoothing in this mode, so fast track manual change from loud sound to silence may cause pop/click).

As for auto advance, if set to No fading, there were no fading prior 838 as well, tracks played in gapless mode.

I'm not using any crossfading. Auto-advance Fading is also set to No.

 
 
 
 
On 7/26/2019 at 8:55 PM, maxmp said:

If you think some track beginning is skipped, please send this track for tests (via Poweramp list Send action / Gmail / gpmaxmp@gmail.com). Thanks!

There are actually LOTS of tracks that are subject to the starts being cut. To be clear, it's not skipping per se. What is happening is that the first half-second, split second, or even a full second, is simply not being played. And it's happening to a LOT of tracks. I've noticed it on 4 or 5 albums, and around half the songs on these albums. But I'm hearing it only on the songs with sudden starts. To be clear, it's where the music is loud from the get-go. So no artistic fade in. Some tracks I can also hear that the end is being cut too. I should have mentioned this earlier but I forgot. 

Did you watch the video I uploaded? Please watch it, here's the link. I think the video explains the issue VERY well. And as mentioned in this post of mine above, when I disable Hi-Res Out the issue does not occur AT ALL. 

I can still send you some of these tracks that are subject to this issue, but is it absolutely necessary? I think the video shows clearly what the issue is, and that it plays perfectly fine without 3.5 plugged in. Please let me know because I can certainly make more videos showing this issue on another track, and show when I disable Hi-Res Output how it plays perfectly fine too. 

Share this post


Link to post
Share on other sites

Hi again all. My issue is now resolved.

Long story short: This thread is about the first split second or two (and sometimes last split second or two) being cut from playback. I worked out this issue was directly caused by Hi-Res Output on 3.5 headphones or 3.5 speaker playback. Using the phone's speaker did not have this issue. So disabling Hi-Res Output solved that issue. BUT the reason I enabled Hi-Res Output in the first place was because I was hearing skipping and stuttering on EVERY song (sometimes as much as three times per song). It was intolerable. I was certain the skipping and stuttering started when I updated from v3 build 830 to build 386 and it persisted when I updated again to build 838. So I've reverted to build 830. I get no skipping or stuttering in my playback on build 830, and it's been a couple of days now. My phone is not that old, so I don't think it's unreasonable that a 3 year old phone should be able to handle PA's latest version properly, but it seems that might not be the case. I'm using LG V20 (released Oct 2016). 

I'm posting this solution in the Skipping and Stuttering Songs thread too for others that might need it. 

Share this post


Link to post
Share on other sites

hi I just tested latest build 841 with a wired headphones, and the fade in bug when "tap to play" a song is still there. I spent over an hour customizing Poweramp settings. I disabled all possible settings and tested on 3 different phones with 3 different Android versions ("LG G3 with Android 6", "HTC U11 with Android 8.1", "Motorola G4 with Android 7".
Played is in pause mode, then "tap to play" and the fade-in is there, not just at the beginning of the track, even in the middle. I already tried 4 different headphones, same results. HD audio setting is not enabled. No stutter or skipping, just the tiny fade-in. No fade-out at the end of the song though or when switching songs. I even tried to disable all settings to see if something was causing it... no luck. Maybe my phone is too old ?

Note: it only happens when player is paused. If you tap "next" or "previous" while a music is playing, to this bug doesn't happen.

I tried 320kbps mp3 files and flac files. All the same. I only use flac audio files, never mp3.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...