Jump to content
Poweramp
Yahoo302

Songs in album not showing up

Recommended Posts

After downloading music to my phone, many times only 1 or 2 songs will be showing in the album. I can find the music file via a file manager and play it via Poweramp, but it won't actually be on the album in Poweramp. 

How can I fix this? 

Thank you

Share this post


Link to post
Share on other sites
37 minutes ago, Yahoo302 said:

After downloading music to my phone, many times only 1 or 2 songs will be showing in the album. I can find the music file via a file manager and play it via Poweramp, but it won't actually be on the album in Poweramp. 

How can I fix this?

I assume that the files reside in directories that you enabled in Settings > Library > Music Folders, or that the whole device is read. If need be, fix this.

First you should try a rescan : Settings > Libary > Rescan

If that doesn't help, a full rescan : Settings > Libary > Full Rescan

If that doesn't help : could it be that the files don't have an album-artist tag, so that they don't show up in the album, but are known to Poweramp in other categories ? Look in Library > Folders and Library > Folders Hierachy

Share this post


Link to post
Share on other sites

All songs in the album are properly tagged, and I did a full rescan etc. 

What's weird is how the 2 songs that actually display in the album are in 2 different folders. I'll show the picture. 

Does this have anything to do as to why only 2 songs are showing up? 

Screenshot_20190702-231652_1.jpg

Share this post


Link to post
Share on other sites

Could you try launching one or two of the 'missing' songs in PA via a file manager app, then long-press on the album art area and choose Info/tags and see if there is anything odd about the results?

Andre

Share this post


Link to post
Share on other sites
3 hours ago, andrewilley said:

Could you try launching one or two of the 'missing' songs in PA via a file manager app, then long-press on the album art area and choose Info/tags and see if there is anything odd about the results?

Andre

I've done that, there is nothing odd about the results except that thete is no option to go to album. 

Share this post


Link to post
Share on other sites

One of the files is a cue file - if you disable cue, are then the irregularities gone ?

Share this post


Link to post
Share on other sites
2 hours ago, blaubär said:

One of the files is a cue file - if you disable cue, are then the irregularities gone ?

I'll try that, how do you disable cue? 

Share this post


Link to post
Share on other sites
3 minutes ago, Yahoo302 said:

I'll try that, how do you disable cue? 

Settings > Library > Scanner > Parse CUE Files

Share this post


Link to post
Share on other sites
1 minute ago, blaubär said:

Settings > Library > Scanner > Parse CUE Files

It worked! Thank you sir. 

Share this post


Link to post
Share on other sites
On 7/3/2019 at 9:12 AM, blaubär said:

Settings > Library > Scanner > Parse CUE Files

Thanks a lot, this worked for me as well!

Share this post


Link to post
Share on other sites

In Poweramp, CUE files are not necessary except in cases where you have one large audio file which you want to split up into individual smaller tracks (such as one file encompassing a whole CD).

If your music is already stored as individual audio files, with their own tags for title/artist/etc, then adding an extra CUE file which duplicates that same information is not necessary and it's probably best to delete them to avoid confusion.

Andre

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×