Jump to content
Poweramp

Recommended Posts

It's the first time that i got a message that Poweramp needs to close because of high cpu usage, I have a Samsung Note8 SM-N950F on oreo

Share this post


Link to post
Share on other sites

Is there actual high usage? This message may be shown for any long running background process, and music playing is usually a long running background process. 

Share this post


Link to post
Share on other sites
10 minutes ago, maxmp said:

Is there actual high usage? This message may be shown for any long running background process, and music playing is usually a long running background process. 

Ok thanks Max,no I didn't think it was high,it was just that I have never received a message like that before and I thought something was wrong.

Share this post


Link to post
Share on other sites

I have a 32 bit device. I have my whole library in .opus and recently I've noticed Poweramp randomly skips tracks or displays a toast that the file is unplayable, yet still plays it (also the play time counter seems to be stuck at 0:00 when that happens and sometimes the wave seekbar stays flat). Force closing Poweramp fixes it momentarily.

Share this post


Link to post
Share on other sites
7 hours ago, LPW00 said:

I have a 32 bit device. I have my whole library in .opus and recently I've noticed Poweramp randomly skips tracks or displays a toast that the file is unplayable, yet still plays it (also the play time counter seems to be stuck at 0:00 when that happens and sometimes the wave seekbar stays flat). Force closing Poweramp fixes it momentarily.

Could you send me one of such tracks (you can do it directly from Poweramp lists / long press track / Send / Gmail / gpmaxmpz@gmail.com) for tests? Thanks!

Share this post


Link to post
Share on other sites
3 hours ago, h.h said:

hi

what is  PA 64-bit Specification?

It’s just a build for Arm 64 architecture. It generally a bit faster (less battery used) for some codecs, a bit worse for others (in a +/-10% range). 64-bit are required for Play apps starting from 1st August’19, that’s why this is pushed, otherwise 32-bits builds are just fine.

Share this post


Link to post
Share on other sites
43 minutes ago, maxmp said:

 

Have problem with playing flac on background. 

With background playback, flac files are sometimes skipped.  mp3 plays without problems.

If I understand in background codec for flac sometimes.

В фоне иногда пропускаются flac файлы, если зайти в PA и снова выбрать этот flac файл то он начинает его воспроизводить, и следующий за ним тоже.

С прошлыми версиями проблем не было.(830-832)

Poweramp 834

Mi Mix, Android 8.1, Resurrection Remix 6.1

Arm64

Share this post


Link to post
Share on other sites
1 minute ago, Rim13 said:

With background playback, flac files are sometimes skipped.  mp3 plays without problems.

Is it always the same songs that are skipped (e.g. if you play one album, are there certain songs that always skip when PA is in the background) or is it completely random and will work one time and then fail the next time you listen to the same album?

Andre

Share this post


Link to post
Share on other sites
15 minutes ago, andrewilley said:

Is it always the same songs that are skipped (e.g. if you play one album, are there certain songs that always skip when PA is in the background) or is it completely random and will work one time and then fail the next time you listen to the same album?

Andre

This happened several times when I listened to all the tracks in the collection in alphabetical order.

If in the background, after mp3 the next flac, then it is skipped until the next song is in mp3 format again.  

Moreover, if you manually start the skipped track, then everything will play for a while normally, without gaps.

Share this post


Link to post
Share on other sites

There is still a problem to ask for help, my phone set hi-res output when the sampling rate can not be selected to 44.1khz, mobile phone and PA output display are 44.1khz, but my external decoder display is indeed 48khz, another phone can not be set Below 96khz.

Share this post


Link to post
Share on other sites

I also have the problem that tracks are not completely played.

It regularly happens that the playback jumps to the next track.

With gapless albums, the player always makes a short break between the tracks.

Although gapless playback is enabled.

This only happens when playing FLAC files with MP3 files, there are no problems with the playback.

I was able to fix the problem for a short time by dialing the audio buffer without adjusting it.

But after 2 tracks the problems were back.

The problems occur only since the update on ver. 834.

My device is a Porsche Design Huawei Mate RS (NEO-L29), the OS is Android 9 and Audio Output is Fiio Btr3 (OpenSL ES HD)

Share this post


Link to post
Share on other sites
11 hours ago, maxmp said:

Could you send me one of such tracks (you can do it directly from Poweramp lists / long press track / Send / Gmail / gpmaxmpz@gmail.com) for tests? Thanks!

What kinda song would u prefer lol

Edit: can't do anything wrong with Jimi Hendrix, amirite?

Edit2: I just noticed it happens with flac titles too. I thought all my music was converted to opus but apparently I forgot some and it had the same issues. So maybe it's format unrelated? Idk I only use these two formats.

Share this post


Link to post
Share on other sites

so I've downgraded to ver. 832 and Poweramp is playing great again.

No skipping and no gaps when gapless album is playing.

Share this post


Link to post
Share on other sites

Again, if you find some track not played correctly, please share the failing track (via in app Send / Gmail / gpmaxmpz@gmail.com) for tests. Thanks!

Also, do you use SoX resampler? SoX was updated recently too, and I already identified and fixed few bugs in it, but it seems SoX may affect that skipping behavior you're describing. Does it help if SW resampler is enabled?

@LPW00 btw I got your track, thank you, and there is zero issues with it for build 834.. Are you sure that’s the one failing?

@SynekPablo there were few issues with codecs causing gapless failures in build 833, but for 834 all gapless test cases pass OK. Can you please send 2 files which fail to be gaplessly played for you? Thanks?

Share this post


Link to post
Share on other sites

I think its still buggy, i swear one of my songs just swap to the next song without finishing.

Share this post


Link to post
Share on other sites

 

2 minutes ago, MTK said:

I think its still buggy, i swear one of my songs just swap to the next song without finishing.

Do you use SoX resampler?

Share this post


Link to post
Share on other sites

has the remote control function been fixed, id like to use the app on my android tv box, in previous versions my remote control did not work up down arrow keys to scroll to albums enter key did not function either, my box is an android t95z plus

Share this post


Link to post
Share on other sites
1 hour ago, maxmp said:

 

Do you use SoX resampler?

Yes, it's on that.

Share this post


Link to post
Share on other sites

@maxmpThanks for the constant updates. 

Still I am waiting for the Mouse Scroll support in library views. 

Please implement it in the next update. 

Share this post


Link to post
Share on other sites
21 hours ago, maxmp said:

It’s just a build for Arm 64 architecture. It generally a bit faster (less battery used) for some codecs, a bit worse for others (in a +/-10% range). 64-bit are required for Play apps starting from 1st August’19, that’s why this is pushed, otherwise 32-bits builds are just fine.

I think the sound quality is also better in pa 64-bit

Does the 64-bit affect it?

Share this post


Link to post
Share on other sites
3 hours ago, MTK said:

Yes, it's on that.

Ok, please switch to sw resampler temporarily until build 835. Thanks!

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...