Jump to content
Poweramp
maggior

Android Auto Can't Play Requested Album

Recommended Posts

I normally listen to albums when I listen to music.  What I have found is that when I request AA (configured to use Poweramp as the player) to play an album, it will play some random song from that album and proceed to play songs alphabetically in my library from there.

As an example, I'll say "Play the album To The Bone by Steven Wilson".  It will play the 7th song on the album called "Blank Tapes".  Following that, it will play a song that comes next alphabetically based on the song title...something starting with "Bl...".  The album happens to have a song titled "To The Bone" also.  if I just say "Play To The Bone" or "Play To The Bone by Steven Wilson", it does the same...it plays the 7th song on the album called "Blank Tapes".

So far, all I can get to work is:

- Play a specific song

- Play songs from a particular artist

- Play a playlist

 

Is this a known issue?  

 

Thanks!

Share this post


Link to post
Share on other sites

From what you describe, it sounds very much like PA is running in All Songs mode, which would happen if a title is launched from an external file explorer rather than from within PA's own library. 

What happens if you launch the song manually in the Poweramp app, from the relevant songs list in Albums library view?

Andre

Share this post


Link to post
Share on other sites

Using the PA UI on my phone, if I select an album from the list of albums and I select the first song to play, it will play through the album as you would expect.

Within AA, it's as though it's playing the song from the All Songs list.  I don't see that I have any control over this behavior.  Even when I say "Play the album..." it behaves in this weird way.

Share this post


Link to post
Share on other sites

When you start an album song playing from AA, how do you do it? When it's playing, try going to the phone PA interface and tap on the artwork to see what library category list it takes you to. You can also tap on the metadata line at the bottom of the player screen a few times to see the category and current / total tracks info (such as "ALBUMS - 1 / 14"). I assume you do have Shuffle turned off and nothing in the Queue (although the problem you describe does sound like All Songs mode is in use).

Andre

Share this post


Link to post
Share on other sites

When this happened, I tapped something on the aa screen that showed what category Poweramp was in and it was "songs".

FWIW, when I use Google assistant to do the same thing, it say "sorry something went wrong...". Perhaps this is another clue.

Share this post


Link to post
Share on other sites

Try the voice command "Play <albumname> as album". Voice commands do seem a bit of a black art though, I find they work most of the time, but occasionally something just fails. "All Songs" is the default mode if you give it a track title though.

Andre

Share this post


Link to post
Share on other sites

I tried that and it didn't work :(.  It says something along the lines of can't complete request....not found.

I appreciate the suggestions.

Am I the only person experiencing this issue?  Aa seems a bit wonky itself.  At one point it was playing my request from Google music even though I set Poweramp as the default player.

Share this post


Link to post
Share on other sites

I thought this might be related to albums with songs that match the album title, but asking AA to play Abbey Road on Poweramp played some random song in the album and when I looked, PA was in "song" mode.

Share this post


Link to post
Share on other sites

This problem is quite limiting in the functionality of PA when used with AA.  Can anybody say if this is a bug or if I am just not doing something correctly?  At least the maps in AA are really cool with real time traffic :).

Share this post


Link to post
Share on other sites

maggior, I'm experiencing exactly the same thing. Did you ever find a solution?

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×