Jump to content
stevewilson

No longer able to see or choose music folders for library

Recommended Posts

@NerdRocker if you have time/wish to experiment, what happens if you update to 830 again? (The issue may be related to rare database corruption which is restored by (clean) re-installing to previous build, so it may continue to work OK in 830).

Share this post


Link to post
Share on other sites

I can confirm this problem as well.

Having trying out the iOS-platform for a while I went back to the Android platform. So I logged into my google account on a new S10 plus, it restored my apps. Poweramp included.

I copied over my folder with music and noticed quite quickly the same problems that some other person mentioned. The songs skips and I get something like "could not be played" a lot, can not remember the exakt phrase.

The same thing others describe is also hitting me, the thing where I can not select folders but only choose internal storage.

I am not comfortable installing apps from any site, this site included, and would prefer to get a fixed version from the google play store.

 

This must be a permissions thing or something with how the folder is mounted for reading. I also noticed that sometimes even though it says that it can not play a file, if you continue to press the play button, it actually will play it. That could mean that there is an intermittent reading problem. It might very well also be an Android bug as well. As a developer you sometimes pull your hair trying to solve an issue when eventually it turns out it was an OS bug. Neither Apple nor Google are perfect in this.

Thanks for still developing this app, the sound settings are just leaps and bounds over other music-apps 👍🏿

 

Screenshot_20190614-101305_Poweramp.jpg

Share this post


Link to post
Share on other sites

@maxmp, I installed the 830 apk from your site and it worked too. It sounds like you're onto something with the Play Store restores.

I'm like most other people having the problem. I got a new S10+, restored all my apps from Google Backup and encountered this problem.

Let me know if you'd like me to test anything else.

 

Share this post


Link to post
Share on other sites
8 hours ago, skitapa said:

I can confirm this problem as well.

Please try installing build 830 as a direct download from the website here - https://forum.powerampapp.com/files/category/2-poweramp-v3-latest-releases/ - which will overwrite the Google Play installed version (you'll still get updates through the Play store later, it won't unlink the app from the store).There shouldn't be a difference between the two builds, but this does seem to be helping for other people.

Andre 

Share this post


Link to post
Share on other sites

FYI, I´ve just experienced this exact issue but now with Android 10 on my Huawei P30 Pro.

Reinstalling 852 from here solved the problem.

Thought you´d like to know.

 

Hugo

 

Share this post


Link to post
Share on other sites

If you can reproduce the issue constantly - it well be helpful if log can be captured and shared with me. Unfortunately, all my Android 10 devices have no such issue, but Poweramp uses the new Storage Access Framework (SAF) API and only few apps on Play use that, so I guess this API is not well tested by OEMs and bugs are possible.

Another known app which uses SAF on 10 is Solid Explorer.

SAF is generally not a new API, but in Q Google added new functionality and made it mandatory for first betas, then they allowed “legacy” mode, this is why most apps not updated to use it and keeping legacy mode.

Share this post


Link to post
Share on other sites

Hi everybody, I've a similar problem, Poweramp losts access granted to sd card, every time i restart the phone, i'm using the last one 860v, and custom rom over android 10, ask me for more details if you need. Thanks in advance.

TgxN3xG.jpg

Share this post


Link to post
Share on other sites

@goldenpis what rom exactly? And how exactly does it loose the access - you have too give access again or something else?

Anyway, issues like this are usually associated with Files system app which contains permission folder dialog and file provider and keeps permissions. I guess in your case it’s unable to keep permissions or it’s cache/data deleted somehow. 

Thanks!

Share this post


Link to post
Share on other sites
41 minutes ago, maxmp said:

@goldenpis what rom exactly? And how exactly does it loose the access - you have too give access again or something else?

Anyway, issues like this are usually associated with Files system app which contains permission folder dialog and file provider and keeps permissions. I guess in your case it’s unable to keep permissions or it’s cache/data deleted somehow. 

Thanks!

It's Evolution X 3.4 on redmi S2, I don't know how losts the permission, but after restarting, widget it's frozen, and into the app, says me that the SD it's unmounted, and I need to allow to Poweramp grant permission and re scan the library, others apps with SD access, works fine.

I read others post about it in the forum, I install files by google, allow sd permission to system file app, remove Poweramp folder into Android/data after uninstalling, but the issue keeps.

Anyway I'm waiting for the upcoming rom update

Thanks

 

 

Share this post


Link to post
Share on other sites

well... I think I found my problem, there is a conflict with MiXplorer, with this option unchecked on MiXplorer, Poweramp works fine, I restarted several times and never ask me for sd permission

3dUUiIS.jpg

Edited by goldenpis

Share this post


Link to post
Share on other sites

I think I found the real problem, Poweramp load at phone start before that SD is mounted and them it's running in background.

I made a task on macrodroid, when phone starts, I kill Poweramp process, and then; when the SD is mounted; 1 minute later, I execute Poweramp and now works fine, don't ask me por SD permission.

Really is a problem with the rom, that doesn't mount the SD until I enter the screen unlock pattern.

 

 

Edited by goldenpis

Share this post


Link to post
Share on other sites

Have you tried disabling some of the options in Settings > Library > Scanner ? I don't think Settings > Audio > Audio Focus > Wait for Storage will help in this case, as it's the initial app startup that is not seeing the SD Card, not the moment of commencing audio playback. 

Andre

Share this post


Link to post
Share on other sites
2 hours ago, andrewilley said:

Have you tried disabling some of the options in Settings > Library > Scanner ? I don't think Settings > Audio > Audio Focus > Wait for Storage will help in this case, as it's the initial app startup that is not seeing the SD Card, not the moment of commencing audio playback. 

Andre

yes, I try with several combinations of this settings, none enabled, full enabled, something enabled and disabled, but same result.

I didn't know the option in focus section, I tried with it in case I was a lucky men today, but didn't works obviously

so far only works kill Poweramp at start, and then load the app few moments later

I'm not sure that I need the both acctions "stop app" and "kill background process", I will keep testing.

Thanks.

 

 

photo_2020-01-19_15-41-28.jpg

Share this post


Link to post
Share on other sites

I'm glad it's not just me as I've moved to a new phone myself Realme x50 pro from an Huawei mate 20 pro with no problems before!

This is all I'm getting when I try to look for my music..

Screenshot_2020-07-06-00-03-05-21_345bb2134bfb84a7decceb0b36861421.jpg

Share this post


Link to post
Share on other sites
8 hours ago, Colin c said:

I'm glad it's not just me as I've moved to a new phone myself Realme x50 pro from an Huawei mate 20 pro with no problems before!

The problem is that Google keep moving the storage goalposts with each new Android release, and individual manufacturers bolt their own incompatibilities on top. Gone are the days where it was your phone and your storage card and you could expect your choice of apps could always access all of your own files without having to jump through security hoops. 

Have you tried to 'Enable' the internal storage? Have you tried using the '+' button to Allow Access to a different storage location?

Andre

Share this post


Link to post
Share on other sites
1 hour ago, andrewilley said:

The problem is that Google keep moving the storage goalposts with each new Android release

Androids 5-9 were stable in this regard, in Android 10 the paths changed due to (enforced by Google) the "new" Storage Access Frameworks (SAF) API requirement to access files.

For SAF you first hit that Enable button, find the desired storage and optionally a root folder and hit "ALLOW..." button. Depending on ROM, additional menu / Show Internal Storage selection is required + side menu should be used to select the target storage.

Poweramp then either uses default Music/Downloads/Playlists folders on storage by default or selects the user defined folder. As previously, subfolders in the allowed storage/folder can be further checked/unchecked without extra permissions step.

Google initially wanted to force this (quite slow and weird) API for any file access in Android 10, but later backpedaled to allow direct file access in Android 10 with Android 11 being the first version enforcing SAF. Poweramp is already optimized for SAF nevertheless.

You can enable old way of accessing files in Poweramp via Settings / Misc / File Access Legacy Mode.
I also recommend this in case device is "missing" core Android system file picker or external storage component.

PS Many quotes here:
- "new" SAF - SAF exists from Androids 4.x but was enforced only for USB-sticks previously
- "missing" file picker - usually disabled via apps like Package Disabler or "optimized" out by ROM authors
- "optimized" - I don't think removing critical core part and breaking updated apps is an optimization. Granted, non-updated apps built for previous Android SDKs will continue to work, but updated apps will be broken

Share this post


Link to post
Share on other sites
23 hours ago, andrewilley said:

The problem is that Google keep moving the storage goalposts with each new Android release, and individual manufacturers bolt their own incompatibilities on top. Gone are the days where it was your phone and your storage card and you could expect your choice of apps could always access all of your own files without having to jump through security hoops. 

Have you tried to 'Enable' the internal storage? Have you tried using the '+' button to Allow Access to a different storage location?

Andre

That makes sense and have tried the + sign but not the other one yet.

Will give it a go as I'm missing using Poweramp as the one that's on the phone is crap.

Share this post


Link to post
Share on other sites

I've got it working....

Only folder it was seeing was the download folder, so moved all my music into there and it's working fine now.

Share this post


Link to post
Share on other sites
30 minutes ago, Colin c said:

Only folder it was seeing was the download folder, so moved all my music into there and it's working fine now.

Well that would work of course, but it hasn't solved the underlying problem and you shouldn't be forced to put all your music in a Download folder. Were you not able to 'Enable' access to the main storage using the provided function?

Andre

Share this post


Link to post
Share on other sites
4 hours ago, andrewilley said:

Well that would work of course, but it hasn't solved the underlying problem and you shouldn't be forced to put all your music in a Download folder. Were you not able to 'Enable' access to the main storage using the provided function?

Andre

Yes your right but until it's worked out, at least we have a work around...

 

Colin

Share this post


Link to post
Share on other sites

Why don't you ask a developer of some other music app how to do this right?

Every other music app work as it should, whether they be expensive, cheap, or even free, they all work...... but not your own???

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...