Jump to content
Poweramp
stevewilson

No longer able to see or choose music folders for library

Recommended Posts

version 830 in Google Store -> a problem occurrence

version 829 in this site -> Normal

version 830 in this site -> Normal

This is what happened to me.

Share this post


Link to post
Share on other sites

@NerdRocker if you have time/wish to experiment, what happens if you update to 830 again? (The issue may be related to rare database corruption which is restored by (clean) re-installing to previous build, so it may continue to work OK in 830).

Share this post


Link to post
Share on other sites

I can confirm this problem as well.

Having trying out the iOS-platform for a while I went back to the Android platform. So I logged into my google account on a new S10 plus, it restored my apps. Poweramp included.

I copied over my folder with music and noticed quite quickly the same problems that some other person mentioned. The songs skips and I get something like "could not be played" a lot, can not remember the exakt phrase.

The same thing others describe is also hitting me, the thing where I can not select folders but only choose internal storage.

I am not comfortable installing apps from any site, this site included, and would prefer to get a fixed version from the google play store.

 

This must be a permissions thing or something with how the folder is mounted for reading. I also noticed that sometimes even though it says that it can not play a file, if you continue to press the play button, it actually will play it. That could mean that there is an intermittent reading problem. It might very well also be an Android bug as well. As a developer you sometimes pull your hair trying to solve an issue when eventually it turns out it was an OS bug. Neither Apple nor Google are perfect in this.

Thanks for still developing this app, the sound settings are just leaps and bounds over other music-apps 👍🏿

 

Screenshot_20190614-101305_Poweramp.jpg

Share this post


Link to post
Share on other sites

@maxmp, I installed the 830 apk from your site and it worked too. It sounds like you're onto something with the Play Store restores.

I'm like most other people having the problem. I got a new S10+, restored all my apps from Google Backup and encountered this problem.

Let me know if you'd like me to test anything else.

 

Share this post


Link to post
Share on other sites
8 hours ago, skitapa said:

I can confirm this problem as well.

Please try installing build 830 as a direct download from the website here - https://forum.powerampapp.com/files/category/2-poweramp-v3-latest-releases/ - which will overwrite the Google Play installed version (you'll still get updates through the Play store later, it won't unlink the app from the store).There shouldn't be a difference between the two builds, but this does seem to be helping for other people.

Andre 

Share this post


Link to post
Share on other sites

FYI, I´ve just experienced this exact issue but now with Android 10 on my Huawei P30 Pro.

Reinstalling 852 from here solved the problem.

Thought you´d like to know.

 

Hugo

 

Share this post


Link to post
Share on other sites

If you can reproduce the issue constantly - it well be helpful if log can be captured and shared with me. Unfortunately, all my Android 10 devices have no such issue, but Poweramp uses the new Storage Access Framework (SAF) API and only few apps on Play use that, so I guess this API is not well tested by OEMs and bugs are possible.

Another known app which uses SAF on 10 is Solid Explorer.

SAF is generally not a new API, but in Q Google added new functionality and made it mandatory for first betas, then they allowed “legacy” mode, this is why most apps not updated to use it and keeping legacy mode.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...