Jump to content
Poweramp
Sign in to follow this  
dmw_4814

EXTREME Lag in Poweramp

Recommended Posts

I am getting EXTREME lag in Poweramp; in practically everything it does - almost to the point of it being unusable! The main problem is when changing tracks - both in the main player screen, and in the Poweramp notification (although, the lag doesn't seem to be as bad when using the Poweramp notification to change tracks). When in the main player screen, when I tap on the current track, to bring up a list of all the tracks on that particular album, and then I tap on another track (or, even if I change to a track from a completely different artist/album), there is a delay, sometimes as long as TEN seconds or so, before the track change actually occurs. If I happen to tap on it several times, because I'm thinking I didn't tap in the right spot, the track will actually restart for each time I tapped it, when it actually starts playing. V3 wasn't like this at first; this started happening several updates ago (I don't remember exactly when, as it's been going on for a while). I'm using V3-build-830-Play (Full version), along with Poweramp Full Version Unlocker 3-build-301, on a Razer Phone 2, running Android 9. No other app or anything else I do on this phone exhibits the same kind of sluggishness; in fact, this phone is pretty lightning-fast in almost everything it does.

 

Any ideas what's happening/how I can fix this?

 

Thanks,

 

Dennis

Share this post


Link to post
Share on other sites

It might be worth checking buffer sizes and crossfade in case either of those are excessive. Also could be related to SD Card reading (I assume you music is on SD Card?).

Try going into Settings > Audio > Output and Restore Defaults. Also try turning off any crossfade settings. Put some music on internal memory and see if you have the same problem there. Finally, try doing a Full Rescan or uninstalling / reinstalling the app (remember to export your settings and any internal playlists first though).

Andre

Share this post


Link to post
Share on other sites

This kind of lags can’t originate from the player itself - I guess it’s system wide or hardware issue, for example, caused by faulty sd card/storage (just check it for errors on computer, if you can). Try to open exactly the same track on other player or try to copy it with some file manager - do you see lags in this case?

I don’t have exactly Razer phone 2 on hands for testing, but Poweramp is tested on similar hardware/software and of course it’s blazing fast on snapdragon 845 SOCs.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

×
×
  • Create New...