Jump to content
Poweramp
Sign in to follow this  
Stallion777

Getting 'Failed to play - Storage Unmounted' after latest update

Recommended Posts

After the latest update (Build 828), after a while, when trying to play my music in folders, I get an error: 'Failed to play - storage unmounted'. At first I thought my SD card had gone bad, until I went to play my music using another app I have, and my music played just fine. I've done a re-scan, shut my device off (Motorola Moto G5+), even removed and re-installed the SD card, all to no avail. Then I realized I was having the same problem on another device, but only in Poweramp with the same update. Does anyone know what's going on with this?

 

Share this post


Link to post
Share on other sites

And if a Full Rescan does not work, try a clean reformat of your SD Card and then copy all the contents back again  (using a computer). Then try another Full Rescan, as Android will have invented a new name for the SD Card.

Andre

Share this post


Link to post
Share on other sites

This message means Poweramp tries to play song from missing storage. Poweramp doesn't remove tracks automatically from internal database when sdcard/storage is changed, so track entries stay there and attempt to play them will show the message.

If you changed sdcard permanently and don't want missing tracks to hang in Library use Settings / Library / Full Rescan (use once after such storage change).

Note that Poweramp builds prior 824 completely removed missing entries from custom Playlists for Full Rescan.
Poweramp builds 824+ will keep your playlist entries as is, optionally resolving them to the new storage locations (if files match by directory/name).
 

Share this post


Link to post
Share on other sites

The thing is that I'm only getting this problem in Poweramp. As I mentioned in my post, other music players are having no problem reading the music on my SD card, only Poweramp after this last update. And the other reason I know it's not my SD card is that one of my music folders was not on the SD card, but on the smartphone's storage, and I received the same error message when trying to read music from it. My other music app is 'Player Pro', so right now, I'm using it because I'm not having this issue with Player Pro. I really like Poweramp, but right now, with the problems caused by recent updates, I have to say that I'm not too happy with it.  

Share this post


Link to post
Share on other sites

You could uninstall and reinstall Poweramp, perhaps that helps. ( settings and playlists will get lost, so export and save before uninstall )

Share this post


Link to post
Share on other sites
6 hours ago, Stallion777 said:

 I really like Poweramp, but right now, with the problems caused by recent updates, I have to say that I'm not too happy with it.  

Check that it is actually the PA update and roll back one version (all previous versions are available from the Downloads tab at the top of the page).

Andre

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×