Jump to content
Poweramp
smiller

Tasker problem with Android 9, same config works fine on Android 7 (Poweramp v3, build 828)

Recommended Posts

Hi,


I am using a known-working Poweramp Tasker task (Poweramp v3-828 and Android 7 on a Moto X Pure) on an Android 9 device (Pixel 3 XL) and am seeing it fail with the following Poweramp log entry:

21:27:57.318 PlayerService OPEN_TO_PLAY content://com.maxmpz.audioplayer.data/playlists/16/files?shf=2 IGNORED

On the Android 7 device I see the same log entry, but without the 'IGNORED' on the end, and the command works properly (loads a playlist and starts playback.)


Other than the OS everything is the same (same Tasker config, same Poweramp version, both restored from their respective backups) so the only meaningful difference on the device seeing the failure seems to be the different OS (although I don't see how that could be the problem since Poweramp seems to be receiving the intent message in both cases.) Any ideas why Poweramp is apparently ignoring the command on Android 9 and not on Android 7?

Thanks for any help in sorting this out...

 

 

Share this post


Link to post
Share on other sites

As a followup, I tried another Android 9 phone and everything worked OK so I then uninstalled and reinstalled Poweramp v3-828 on the problem phone and it then worked as well, so apparently a complete reinstall of Poweramp cured the problem.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×