Jump to content
Poweramp
maxmp

Poweramp Build 826

Recommended Posts

Thank you for the updates. Still not working with 3rd party build-in chromecast, such as LG Sky10 soundbar or LG TV, while other app (Playpro) does. Thank you again.

Share this post


Link to post
Share on other sites

Looks like the volume jump to zero issue was solved! 

Thank you 

Share this post


Link to post
Share on other sites
4 hours ago, VanGolfer said:

Thank you for the updates. Still not working with 3rd party build-in chromecast, such as LG Sky10 soundbar or LG TV, while other app (Playpro) does. Thank you again.

If it connects at all, could you check the version numbers of your Chromecast devices? Either in their own setup menus, or in PA by connecting and then long-pressing on the metadata info line at bottom of player screen and scroll down to bottom of the info screen.

Andre

Share this post


Link to post
Share on other sites

@VanGolfer Poweramp requires pretty fresh CC firmware/Chrome version - mostly related with the possibility of testing, as some old CC devices with old un-updated firmwares are hard to get.

Share this post


Link to post
Share on other sites
6 hours ago, maxmp said:

@VanGolfer Poweramp requires pretty fresh CC firmware/Chrome version - mostly related with the possibility of testing, as some old CC devices with old un-updated firmwares are hard to get.

It does appear that even some fairly new third-party device with built-in Chomecast are using version 62 though, certainly a lot of people are reporting that Chrome version across a wide range of manufacturers' devices.

Andre

Share this post


Link to post
Share on other sites

Facing a weird issue with my wired earphones with this version. I have DVC turned on. When I connect the earphones, the volume will be slightly higher but then the music will pause and resume but with a lower volume. If I turn off and turn on DVC again the volume will again increase till the next time I plug in the earphones. I recently changed my earphones to without a mic ones, earlier used one with mic. Didn't face this issue on that, but the update came after I changed the earphones so cannot confirm whether the issue is with earphones or Poweramp. 

Asus Zenfone 5z 

Android version: 9.0

Earphones: mee audio m6 pro 1st gen

Share this post


Link to post
Share on other sites
On 4/25/2019 at 3:25 AM, maxmp said:

Play now has new icon requirements, and (not yet updated) Play app will show ugly rectangle icon. But this doesn't affect actuallapp icon (in launcher).

Ah got it any how I'm using omoro icon pack so it's no problem :)

Share this post


Link to post
Share on other sites

@kunaltyagii what output do you use in Poweramp (Hi-Res/ Open SL/ Audiotrack?). What exactly pauses Poweramp when this volume change happens (notification/call/other sound/anything else)?

Share this post


Link to post
Share on other sites
On 4/24/2019 at 11:37 PM, hypomaniac-eric said:

don't know if it's fixed or not in the 826 build but has anyone noticed the last few builds that at the beginning of some songs there's a glitch in the mp3 file?  I"m on shuffle when i notice it.   makes me think my mp3's are corrupted but when going back and listening to the same songs again it's fine.  And fine on the computer.   

Also I noticed it today on my tablet as well.   

Share this post


Link to post
Share on other sites
10 hours ago, maxmp said:

@kunaltyagii what output do you use in Poweramp (Hi-Res/ Open SL/ Audiotrack?). What exactly pauses Poweramp when this volume change happens (notification/call/other sound/anything else)?

I use hi-res, this doesn't depend on the audio track. And there is no notification or any other visible change that I can see when this pause happens. But I've noticed something which might point to a problem with my phone. The icon for the connected earphones is first shown as a headset but changes to an earphone later. This might indicate that my phone wrongly reads my earphones as with mic and then corrects it. I'll also try and raise the issue in my phones official forum. But this is happening only when DVC is turned on. If I turn off DVC then the phone correctly identifies it as an earphone without mic in the first go itself.

Share this post


Link to post
Share on other sites
On 4/26/2019 at 1:46 PM, kunaltyagii said:

Facing a weird issue with my wired earphones with this version. I have DVC turned on. When I connect the earphones, the volume will be slightly higher but then the music will pause and resume but with a lower volume. If I turn off and turn on DVC again the volume will again increase till the next time I plug in the earphones. I recently changed my earphones to without a mic ones, earlier used one with mic. Didn't face this issue on that, but the update came after I changed the earphones so cannot confirm whether the issue is with earphones or Poweramp. 

Asus Zenfone 5z 

Android version: 9.0

Earphones: mee audio m6 pro 1st gen

I can use 384khz for the sampling rate, but when i do that if i change from Poweramp to another app, for example, Google Chrome, the volume decrease. If I use 192khz sampling rate Poweramp works well. I tried to changed the settings Focus, Buffer, but the problem continues with 384/352khz.

Xperia Xz2  compact 

Android 9

Poweramp build 826

Earphones : 1More Triple Driver 

Share this post


Link to post
Share on other sites

I'm on build 826 (Moto X Pure running Android 7.0) but I do not see the 'change track by long volume key press' option on the Misc menu or anywhere else (well, there is a selection in the Headset/Bluetooth menu for that function that in turn redirects me to the Misc menu, but again the option is not there.)

I tried using the 'adb shell pm grant com.maxmpz.audioplayer android.permission SET_VOLUME_KEY_LONG_PRESS_LISTENER' command listed earlier in the thread but SET_VOLUME_KEY_LONG_PRESS_LISTENER does not appear to be a valid command as the attempt fails with: Bad argument: java.lang.IllegalArgumentException: Unknown permission: android.permission.SET_VOLUME_KEY_LONG_PRESS_LISTENER

What am I missing?

Thanks

Edit: It seems that SET_VOLUME_KEY_LONG_PRESS_LISTENER was added in Oreo, so does that mean the 'change track by long volume key press' option is unsupported on earlier OS versions?

 

 

Share this post


Link to post
Share on other sites
2 hours ago, smiller said:

I'm on build 826 (Moto X Pure running Android 7.0) but I do not see the 'change track by long volume key press' option on the Misc menu or anywhere else (well, there is a selection in the Headset/Bluetooth menu for that function that in turn redirects me to the Misc menu, but again the option is not there.)

I tried using the 'adb shell pm grant com.maxmpz.audioplayer android.permission SET_VOLUME_KEY_LONG_PRESS_LISTENER' command listed earlier in the thread but SET_VOLUME_KEY_LONG_PRESS_LISTENER does not appear to be a valid command as the attempt fails with: Bad argument: java.lang.IllegalArgumentException: Unknown permission: android.permission.SET_VOLUME_KEY_LONG_PRESS_LISTENER

What am I missing?

Thanks

Edit: It seems that SET_VOLUME_KEY_LONG_PRESS_LISTENER was added in Oreo, so does that mean the 'change track by long volume key press' option is unsupported on earlier OS versions?

 

 

How do you enter the command to make it work on a non rooted phone? Does it require plugging the phone to the computer or can you a terminal on the phone? I tried a terminal and it was throwing errors from not recognizing the commands

Share this post


Link to post
Share on other sites

My phone is not rooted and I don't believe that root is required for this permission (although unfortunately it looks as though Android 8.0 or above is :(  ). To run the command you need to install the adb application on your PC and enable USB debugging on your phone. The process is a bit long to include in a post but there are many online tutorials available that describe the procedure.

I'm not 100% certain that it is even required but there doesn't seem to be any documentation available on this new Poweramp feature so ...

 

Share this post


Link to post
Share on other sites
1 hour ago, smiller said:

My phone is not rooted and I don't believe that root is required for this permission (although unfortunately it looks as though Android 8.0 or above is :(  ). To run the command you need to install the adb application on your PC and enable USB debugging on your phone. The process is a bit long to include in a post but there are many online tutorials available that describe the procedure.

I'm not 100% certain that it is even required but there doesn't seem to be any documentation available on this new Poweramp feature so ...

 

Correct. Android 8 (Oreo) is a minimum requirement for the long press to skip function. It tells you this right in the description for the option but could probably be worded better to communicate that requirement. I believe it's been tested up to Android Q. Your phone does NOT have to be rooted to use this. You need access to a Windows, Mac or Linux computer to run ADB which allows your phone to activate the permission required to use the feature. If you are rooted then all you need to do is download a Terminal app and copy the code without the adb part in it and execute it. If not rooted then you will.need to download ADB and connect your phone to allow adb to work it's magic

Share this post


Link to post
Share on other sites
14 minutes ago, KUSOsan said:

Correct. Android 8 (Oreo) is a minimum requirement for the long press to skip function.

In that case there is a minor bug in build 826. The long-press-to-skip option is absent from the 'Misc' menu (which apparently is correct since I am running Android 7.0 and thus the feature is unsupported), however the option is available under the Headset/Bluetooth menu, which sends you to the Misc menu, where it is missing. If the option is absent from the Misc menu on pre-8.0 phones (because it is not supported) then it should also be absent from the Headset/Bluetooth menu.

Share this post


Link to post
Share on other sites
2 hours ago, smiller said:

 If the option is absent from the Misc menu on pre-8.0 phones (because it is not supported) then it should also be absent from the Headset/Bluetooth menu.

Probably true, but the note in the Headset/Bluetooth menu is just a pointer in case people happen to look there, I don't think it does any version checking. You are right that in an ideal world it should though, to avoid this confusion.

Andre

Share this post


Link to post
Share on other sites
On 4/20/2019 at 7:33 PM, maxmp said:

Thank you very much for the new feature "Animate Long Labels" on the Now Playing screen! This completely changes how well the information can be displayed. Some skins that have reduced to one line to save space for larger album art can really benefit from this added feature.

Now for the feature request - can you add the ability for the user to choose the tag details that are displayed in both lines on the Now Playing screen? Currently the default display shows;

%title%

%artist% - %album%

In some cases the %artist% tag has been replaced with %albumartist% if that has been selected as the preference. But if you could add support to choose the tag contents of both lines, users could display any details they prefer. Common tags besides these are %composer%, %year%, %track%, %disc%, %kind%, and %genre%. There are plenty more. But if some of the basic ones could be supported, that would be great. With the animation feature added in 824, this can add a whole new level of customization to Poweramp!

Thanks @maxmp!

Share this post


Link to post
Share on other sites
26 minutes ago, MotleyG said:

Now for the feature request - can you add the ability for the user to choose the tag details that are displayed in both lines on the Now Playing screen?

I think that sort of feature (if Max wanted to add it) would need to be category dependent. For example you might want different logic if playing files from Folders than if you are playing Albums by Artist.

Andre

Share this post


Link to post
Share on other sites
4 minutes ago, andrewilley said:

I think that sort of feature (if Max wanted to add it) would need to be category dependent. For example you might want different logic if playing files from Folders than if you are playing Albums by Artist.

Andre

Great idea. This is something that could be done using file and folder tags. Very flexible for any user preference if @maxmp goes with this.

Share this post


Link to post
Share on other sites

Sadly still can't see volume bar when not using headphones and Poweramp is playing. Can see it when using headphones. LG V30 on Oreo. 

Share this post


Link to post
Share on other sites

Skipping tracks with the volume buttons works great, however it doesn't play nice with apps that enable these controls system-wide, such as this one:

https://forum.xda-developers.com/android/apps-games/app-skip-track-volume-keys-t3914337

Right now, if I enable volume button controls in Poweramp they won't work for any other apps, while if I disable Poweramp's setting and enable the app linked above, the button controls work in every app except for Poweramp. Hopefully this can be fixed!

Share this post


Link to post
Share on other sites

I suspect the other app doesn’t properly detect that music is playing (will fail for apps doing eg chromecast or playing otherwise without using Android media player).

Share this post


Link to post
Share on other sites

Poweramp does catch the next/previous commands sent by the Skip Tracks app (as confirmed by the Last Processed Commands list in Poweramp), but doesn't actually skip tracks as expected:

 

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...