Jump to content
Poweramp
tdas777

v3 build 823 - High Battery Consumption

maxmp

Before posting here, please try the following:

Settings / Look and Feel / Player UI / Chromecast Button - Disable (Poweramp will restart)
This helps with some un-updated/failing Play services libraries being loaded into Poweramp and increasing battery usage.

Settings / Library / Scanner / Auto-scan - Disable
This helps with some apps constantly/frequently sending file system change event causing Poweramp to rescan frequently and increasing battery usage.

Message added by maxmp

Recommended Posts

I've had auto scanning and chromecast disabled for a long time now, and it has NOT fixed this issue with the overheating and high battery usage.

So this is bug is not resolved by any means. 

Share this post


Link to post
Share on other sites
8 hours ago, lasse said:

I've had auto scanning and chromecast disabled for a long time now, and it has NOT fixed this issue with the overheating and high battery usage.

So this is bug is not resolved by any means. 

Yep. The first day i disabled auto-scanning, i got the high usage android notification -- i wasn't even skipping through my library and the volume was down.

And have experienced it a few more times after that. So yeah, this is not resolved. 

Share this post


Link to post
Share on other sites

The screen grabs are in probably chaotic order, but I hope they point to what surprised me after leaving PA idle. 

What are wakelocks, and do I care? 

2019_08_04_02.38.52.jpg

2019_08_04_02.38.04.jpg

2019_08_04_02.39.04.jpg

2019_08_04_02.39.13.jpg

Share this post


Link to post
Share on other sites

@RBEmerson Android version you have can’t distinguish between multiple apps loaded into single process (Poweramp itself and Unlocker).

Share this post


Link to post
Share on other sites
On 8/5/2019 at 10:47 PM, andrewevenstar said:

Yep. The first day i disabled auto-scanning, i got the high usage android notification -- i wasn't even skipping through my library and the volume was down.

And have experienced it a few more times after that. So yeah, this is not resolved. 

 

I'm back here to report that the Chromecast trick worked for that day only. The power consumption is still high, just like before. 😣

Share this post


Link to post
Share on other sites
On 8/6/2019 at 6:14 PM, maxmp said:

@RBEmerson Android version you have can’t distinguish between multiple apps loaded into single process (Poweramp itself and Unlocker).

Considering PA and the unlocker are tightly bound, what matters is why directly related PA activity is at the top of the battery consumption list. The icon question is not the primary problem. 

@krazzyvishal Did you check to see if Chromecast re-asserted itself. For some reason, it returned on my phone. It's disabled now, but I'm watching to see if it magically returns. 

Share this post


Link to post
Share on other sites

@RBEmerson from your screenshot it looks like it sorts by wakelock duration usage. Audio playing always have implicit system wakelock for the duration of the playback. Phone can’t play audio while it’s asleep. Thanks!

Share this post


Link to post
Share on other sites

🙁🙁🙁🥺 it's sad that this isn't reproducible on your end while so many users are facing it. Can a device log help you understand what is causing it for us? 

Screenshot_20190827-072459_Settings.jpg

Share this post


Link to post
Share on other sites
12 hours ago, krazzyvishal said:

🙁🙁🙁🥺 it's sad that this isn't reproducible on your end while so many users are facing it. Can a device log help you understand what is causing it for us? 

Screenshot_20190827-072459_Settings.jpg

 

In a bid to find a solution for myself, I, at last, removed the beta version of Google Play Services, thinking that's the last one that can cause problems and installed the public version and tested the battery consumption again.

Surprisingly, it shows happy results. Will test this again during commute tomorrow morning and post it. For now, here are the results. 

Screenshot_20190827-200826_Settings.jpg

Share this post


Link to post
Share on other sites

I never had the beta of Google Play Services installed and encounter the issue for any version newer than 820, including the build posted without Play Services integration.

Share this post


Link to post
Share on other sites

what was the first version this bug was reported on? anyway we could get a repack of the version right before that one? or is it just too far back. 

Share this post


Link to post
Share on other sites

Build 820 is available in the downloads section at top of this forum, and doesn't have the issue. 

Share this post


Link to post
Share on other sites

In my experience, 820 didn't fix the problem. Leaving WiFi and BT on seems to increase drain and heating. Your Mileage May Vary

Share this post


Link to post
Share on other sites

Poweramp v3 build 841

Android 9

One Plus 7 Pro

I'm experiencing high battery usage by Poweramp.

Auto Scan: Off

Chromecast : Off

Screenshot_20190905-144711.jpg

Screenshot_20190905-144704.jpg

Share this post


Link to post
Share on other sites

Chiming in with the same problem... I think it started happening around May for me

After a while, Poweramp just starts using so much CPU that it noticeably heats up the phone. In my battery history screenshot, I plugged in my phone and went to sleep with music playing... 45-ish minutes later the battery temperature went up from the increased CPU usage

The only fix I know of is force-closing Poweramp manually. My Galaxy S9+ (Exynos) will actually force-close Poweramp all by itself without asking (prompting the "Poweramp was killed!" message in the app) if it's not playing music after the bug starts happening.

If there's any more information that I can give to help troubleshoot the problem I will gladly do so. The suggestions stickied at the top of this thread did not help.

2019-09-10 21.10.06.jpg

2019-09-10 21.08.29.jpg

Share this post


Link to post
Share on other sites

Hi all. At first, sorry for my English) I had the same problem of consumption and heating - 1 hr of music in wired or bluetooth headset and my battery falls from 100 to 75% with considerably high heat. Phone Xiaomi Mi6 global, not rooted, remains screen-off all the music time. Chromecast off, autoscan off, PA lockscreen off.

But.

A week ago I've turned off two settings that uses Headset Micro Service. And - the problem is gone for all week. I don't know if this is a general solution, but it seems to solve my problem.

Just for info, thanks.

And, of course - PA is a great player, especially with Hi-Res. Much thanks!

Share this post


Link to post
Share on other sites

Samsung s10+ (exynos), android 9, latest (samsung s10) build.

Did all the steps from the sticky-icky-icky. Oooh wee! Put it in the air - I digress...
Go from 100% to 40% battery in 4 hours playback, with free pocket warmer, cpu-z gives no actual temperatures of the cpu and shows no GPU activity, temperature of the battery around 37~38 degrees C (not so strange when wearing the phone while exercising).
But the phone it self feels too warm to the touch and is noticeable (annoyingly) warmer in my pocket-> meaning higher then body temp. 
Get the device care notification.

Went from a oneplus 6 (snapdragon) to a s10 so first assumed it to be a samsung issue: and stopped using the high-res output, no visualization etc.
but reading others here this doesn't seem to be an issue specific to this model or output.

Screenshot_20190926-211052_WhatsApp.jpg

Screenshot_20190926-120207_Device care.jpg

Share this post


Link to post
Share on other sites

Update to the thread: last builds (842) contain few additional tweaks which reduce probability of the topic behavior. Fixed rare issue with some broken flac files causing scanning thread spinning forever.

Share this post


Link to post
Share on other sites
7 hours ago, maxmp said:

Update to the thread: last builds (842) contain few additional tweaks which reduce probability of the topic behavior. Fixed rare issue with some broken flac files causing scanning thread spinning forever.

I tried version 843 and still get much higher battery drain compared to 820, though I don't think it's as pronounced as some of the other versions.

Share this post


Link to post
Share on other sites

I've attached a screenshot of using version 843 followed by downgrading back to 820. You can see a steep difference in power consumption.

Screenshot_20191003-185111.jpg

Share this post


Link to post
Share on other sites

@akb825 per app battery stats don't survive app uninstalling and reinstalling. So these stats are for your last installed Poweramp version. Poweramp can play non stop 24+ hours on modern phones (Airplane mode). But of course it's possible to consume a lot of battery as well as some options/features will use more (large library rescans, visualizations, hi-res output, cover downloading).

 

Share this post


Link to post
Share on other sites

Unfortunately the issue still exists. Today I was at the gym for about two hours and I went from above 70% to about 30. The first few hours were good and I noticed the phone wasn't getting hot but later on things definitely ended up how they usually do. So this is still a persisting issue no doubt. 

I would classify myself as a power user because I'm listening to music all day at work and then after at the gym. 

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...