Jump to content
Poweramp
goldenpis

Queue never clear completely

Recommended Posts

Queue never clear completely, always there is some rest, some tines show a tracks, other times the list appears clear but the number indicator show something like 4/0, or 1/0, if you insist to clear the queue again, never more happens. Them you create a new queue, and always starts with the last song of previous queue, some times if you forward the song, start the new queue some times, other times start few song past the begin of the new queue, or continue with the songs of the old queue.

Android 7.1.2 custom rom Lineage 14.1

Poweramp 2.x worked perfectly

 

 

 

Share this post


Link to post
Share on other sites

You are right, I see this all the time. When I clear the Queue and then put my new selection of albums in the queue I've started going to the Queue listing and select the first song I put in the queue so that it starts playing on that first song. For whatever reason Poweramp V3 likes to position the start position of the Queue at some random location within the Queue and a lot of the time it's not even at the 1st of the song PA randomly picked to start on!

Moto x4 - Pie - PA v3 820

Share this post


Link to post
Share on other sites

You don't have the option for the queue to allow Shuffling turned on do you?

Andre

Share this post


Link to post
Share on other sites
3 minutes ago, andrewilley said:

You don't have the option for the queue to allow Shuffling turned on do you?

Andre

No I don't have the Queue set to shuffle. If that were true the songs would be listed in a random order, however the listing is in the proper order that the songs are on the albums that I added to the Queue. The problem is that PA just seems to pick a random location in the queue to start rather than at the beginning of the Queue.

Share this post


Link to post
Share on other sites
4 minutes ago, w3wilkes said:

No I don't have the Queue set to shuffle. If that were true the songs would be listed in a random order

No they wouldn't. Shuffle does not change the contents of the list itself, merely the order that songs are played from the list.

However you say that it plays onward in order after that first song, so that it unlikely to be the case (the control is in Settings > Library > Queue > Ignore Shuffle if you want to check, it should be turned ON if you want the queue to playback in order)

Andre

Share this post


Link to post
Share on other sites

I do not have that particular settingON, however on the main now playing screen -> long press the shuffle icon it is set to Shuffle Off. Shouldn't that do the job?

Screenshot_20190311-133512.thumb.png.3ae7b0b8edcf6ba829ddf0260c8f56b4.png

 

Share this post


Link to post
Share on other sites
36 minutes ago, w3wilkes said:

I do not have that particular settingON, however on the main now playing screen -> long press the shuffle icon it is set to Shuffle Off. Shouldn't that do the job?

Yes, turning the Shuffle icon off should stop any shuffling anyway.

Andre

Share this post


Link to post
Share on other sites

Today I see if I start to play the new queue from the queue section works fine, but from other interface zone, the queue goes crazy.

Share this post


Link to post
Share on other sites
14 hours ago, goldenpis said:

 but from other interface zone, the queue goes crazy.

What do you mean by the "other interface zone"? The queue should start playing on its own whenever you enqueue any song, and continue until all enqueued songs are done. You can use the controls in Settings > Library > Queue to determine whether the queue overrides normal playback and starts immediately, or it it waits until after the end of the currently playing track.

Andre

Share this post


Link to post
Share on other sites
50 minutes ago, andrewilley said:

What do you mean by the "other interface zone"? The queue should start playing on its own whenever you enqueue any song, and continue until all enqueued songs are done. You can use the controls in Settings > Library > Queue to determine whether the queue overrides normal playback and starts immediately, or it it waits until after the end of the currently playing track. 

Andre

I mean from the main screen or from the "miniplayer shortcut". If I forward a new queue song from the main screen, the song order is fully shuffle with all the song fron SD card, don't respect the queue songs. But if I start to play from the queue section queue order works fine.

Anyway I will check again that you said.

Thanks.

 

 

unnamed.png

hhhh.png

Share this post


Link to post
Share on other sites
29 minutes ago, goldenpis said:

I mean from the main screen or from the "miniplayer shortcut". If I forward a new queue song from the main screen, the song order is fully shuffle with all the song fron SD card, don't respect the queue songs. But if I start to play from the queue section queue order works fine.

I'm not sure I understand what you are saying. You can't enqueue a new song from the main player screen at all (i.e. the top image in your above post), as given that you could only add the track that is currently playing anyway, it would be a bit pointless. :) The same goes for the mini-player at the bottom of the library views, you can't enqueue from that either as it i also the currently playing track already.You can only add a song to the queue from one of the library list views, by long-pressing on the song title (or an album/folder/etc, which will add all of its songs).

Playback of the queue will then temporarily interrupt the normal (i.e. currently playing) track order - either immediately, or at the end of the current track, depending on your Settings choice. (If you have selected the option to commence the queue after the current track has finished, you can manually trigger it by pressing the >> (Next Track) button, which should start the queue at the first queued track, unless you have shuffling enabled).

You can see what tracks are already queued in the Library > Queue view, and from there you can select songs to play manually (which will adjust the position in the queue, so the earlier tracks won't get played).

Andre

Share this post


Link to post
Share on other sites
3 hours ago, andrewilley said:

I'm not sure I understand what you are saying. You can't enqueue a new song from the main player screen at all (i.e. the top image in your above post), as given that you could only add the track that is currently playing anyway, it would be a bit pointless. :) The same goes for the mini-player at the bottom of the library views, you can't enqueue from that either as it i also the currently playing track already.You can only add a song to the queue from one of the library list views, by long-pressing on the song title (or an album/folder/etc, which will add all of its songs).

Playback of the queue will then temporarily interrupt the normal (i.e. currently playing) track order - either immediately, or at the end of the current track, depending on your Settings choice. (If you have selected the option to commence the queue after the current track has finished, you can manually trigger it by pressing the >> (Next Track) button, which should start the queue at the first queued track, unless you have shuffling enabled).

You can see what tracks are already queued in the Library > Queue view, and from there you can select songs to play manually (which will adjust the position in the queue, so the earlier tracks won't get played).

Andre

Sorry, my english is a bit poor, i learned english watching Lost 😂, and google translator is helping me.... or dis-helping me, I'm not sure.

Summary:

-If I clear the queue and add some albums or songs or whatever, some times the new queue didn't play correctly, the order does not make sense, these are the following:

  • 1- If I start to play (I no mean add) the new queue from the main screen pushing the play button.
  • 2- If I start to play (I no mean add) the new queue from the mini-player

In both cases, Poweramp shows correctly the artwork and the info of the new queue in main screen and miniplayer, but I keep listening the last song I was listening from the old queue.

But if in the queue section, with a new queue, with the previous queue cleared, I push play to start the new queue, in this case plays correctly (the last song from the old queue stops, and begin the first song from the new queue).

 

Attach my Poweramp config.

 

 

 

Screenshot_20190313-131831.png

Share this post


Link to post
Share on other sites
12 minutes ago, goldenpis said:

 Poweramp shows correctly the artwork and the info of the new queue in main screen and miniplayer, but I keep listening the last song I was listening from the old queue.

When you press the Play button on the main player screen, PA will start playing its current track, still in the current playback mode (album, folder, etc). That could of course be the last track played in an old queued session. The queue itself will commence after the end of the current track (again, that depends on your settings, but that is the default behaviour). Remember that the queue is not a normal playback mode, it is a temporary departure from regular playback in order to listen to a few specific songs.

To start the queue playing on request, go to the Queue list in the Library view and either tap on a song or tap the Play icon at the top of the list.

Andre 

Share this post


Link to post
Share on other sites

By the way, you can tell the current playback mode (and also see what is planned next) by repeatedly tapping on the metadata info line on the player screen (just below the seekbar).

Andre

Share this post


Link to post
Share on other sites

Still having Queue position problems when stay in queue is set in build 821.

Share this post


Link to post
Share on other sites

There is a minor issue with Queue to be fixed in 822 (the first queued song "unplayed" mark is not cleared), but other than that I can't reproduce issues with Queue. Step-by-step reproduce instructions can be helpful here (e.g. starting from empty Queue, you do that and that...). Thanks!

Share this post


Link to post
Share on other sites
3 hours ago, maxmp said:

Step-by-step reproduce instructions can be helpful here 

I did manage to duplicate the issue:

  • First, enable the "On Queue End, Stay in Queue" option.
  • Add some songs to the queue and let it play a few of them so you are part-way through the queue (e.g. track 6 of 12).
  • Go into the library queue view and use Menu > Clear Queue.
  • That should (presumably) stop playback of the current queued item, clear all of the songs from the queue view, and show the queue counter as "Empty". However instead it shows the counter as something like track 6/0, which messes up the queue when you add more items to it later.

Andre

 

Share this post


Link to post
Share on other sites

Starting at this comment in another thread the Queue bug is fairly well documented;

 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×