Jump to content
Poweramp
Bunkley987

Poweramp - Failed to play file! When jack 3.5 mm plug

Recommended Posts

Hello, here is the video of the bug. (My screen recorder does not capture audio)

Before I plug jack 3.5mm the player has no problem.
When I plug it display "Failed to play file!" and skip a piece to play next sound. Same problem when I unplug jack 3.5mm

To fix that I have to close Poweramp in the notification first and in the Task Manager last. (In the order or it will not fix)
After that I relaunch Poweramp (with aux 3.5mm connected or not) and it work fine until I un/plug them.

I tried to:

  • Rescan in the Poweramp app
  • Clear the data/cache of Poweramp
  • Uninstall/install Poweramp
  • Change the location to storage/Music

Info:

  • Poweramp version: v3-build-820-play
  • Phone: Meizu M3 Max
  • SD Card: Nothing
  • Android Version: 6.0
  • Rom (Default of Meizu Phone): Flyme 6.2.0.0G

Share this post


Link to post
Share on other sites
4 hours ago, Bunkley987 said:

Hello, here is the video of the bug. (My screen recorder does not capture audio)

Before I plug jack 3.5mm the player has no problem.
When I plug it display "Failed to play file!" and skip a piece to play next sound. Same problem when I unplug jack 3.5mm

To fix that I have to close Poweramp in the notification first and in the Task Manager last. (In the order or it will not fix)
After that I relaunch Poweramp (with aux 3.5mm connected or not) and it work fine until I un/plug them.

I tried to:

  • Rescan in the Poweramp app
  • Clear the data/cache of Poweramp
  • Uninstall/install Poweramp
  • Change the location to storage/Music

Info:

  • Poweramp version: v3-build-820-play
  • Phone: Meizu M3 Max
  • SD Card: Nothing
  • Android Version: 6.0
  • Rom (Default of Meizu Phone): Flyme 6.2.0.0G

When you plug in the headphones the output plugin might change. Check in Settings > Audio > Output and make sure that it stays the same across output devices. Perhaps the screen recorder requires java audiotrack output ?

116201994212.jpg

Edited by blaubär

Share this post


Link to post
Share on other sites
16 hours ago, Bunkley987 said:

Hello thank's for the reply I'm back sorry to answer you so late.
My screen recorder does not have the functionality of capturing audio. It's include in the official Meizu ROM.

By default my Poweramp is set to AudioTrack Output here some pictures.
Even when I'm using OpenSL ES Output the error still here.

I install Poweramp in other phone (Samsung Galaxy J5) who have by default OpenSL ES Output with same bug.
Next try is to clean my library maybe there is a wrong file.

 

AudioTrack-Speaker.jpg

AudioTrack-Wired.jpg

Share this post


Link to post
Share on other sites
8 hours ago, Bunkley987 said:

 

AudioTrack-Speaker.jpg

AudioTrack-Wired.jpg

So now you use Audiotrack output.

Did you change the settings ? Does the problem persist ?

Share this post


Link to post
Share on other sites
2 hours ago, blaubär said:

So now you use Audiotrack output.

Did you change the settings ? Does the problem persist ?

By default when I install Poweramp or reset settings it is set to Audiotrack Output not OpenSL ES Output.

I try change to OpenSL ES Output. The problem persist.

I did not change the advanced settings.

OpenSL ES Wired.jpg

Share this post


Link to post
Share on other sites

(Note: The sound works but my screen recorder does not have the functionality of capturing audio.)

Earlier of this video the fix is already set up. That's why I can skip without error.
Second I show you "Failed to play file!" message when I un/plug aux 3.5mm.
0:55 Change output and the problem persist.
At 1:40 of the video it show how I fix. But the next un/plug will get the problem back.

Maybe it's a wrong/corrupt file but when the problem is fix I can play all file with no problem.

 

Share this post


Link to post
Share on other sites

Sorry for my bad english

Hello. I have the same problem ... I go into the player, turn on the music, plug in the headphones - the music is playing. Just change the music, as the error "Could not play the file." In this case, the music is played, but there is no possibility to rewind it. Changing audio outputs did not help. Turning off the Sound Enhancement also failed.

Smartphone: Xiaomi Redmi Note 4. Android 7. Miui Global Stable 10.2.3.

Immediately I found the problem on 4pda (https://4pda.ru/forum/index.php?showtopic=194117&view=findpost&p=80384472) Symptoms are one-on-one.

 

На русском:

Здравствуйте. У меня такая же проблема... Захожу в плеер, включаю музыку, подключаю наушники - музыка играет. Стоит только сменить музыку, как вылезает ошибка "Не смог воспроизвести файл". При этом музыка проигрывается, однако нет возможности перемотать её.  Смена аудио выходов не помогла. Отключение Улучшения звука наушников в системе miui также не дала результата.

Смартфон: Xiaomi Redmi Note 4. Android 7. Miui Global Stable 10.2.3.

Схожую проблему нашёл на 4pda: ( https://4pda.ru/forum/index.php?showtopic=194117&view=findpost&p=80384472 ) Симптомы один в один.

Share this post


Link to post
Share on other sites
1 hour ago, andrewilley said:

Are the files that are being skipped regular MP3 files?

Andre

Yes, these are ordinary mp3 files. All files are normally played in regular and third-party players. With normal tags and encoding. I think the problem is not in the files ...

Share this post


Link to post
Share on other sites
Just now, Tomahawk said:

Yes, these are ordinary mp3 files. All files are normally played in regular and third-party players. With normal tags and encoding. I think the problem is not in the files ...

Didn't think so (it would always happen with same files otherwise) but I thought I'd check.

Andre

Share this post


Link to post
Share on other sites
1 hour ago, andrewilley said:

Didn't think so (it would always happen with same files otherwise) but I thought I'd check.

Andre

The situation is strange. Symptoms and causes can not understand to the end. When changing the audio output, there are two possible outcomes: 1 - this error appears when connecting headphones and switching music. 2 - when the headphones are connected, the music plays normally, the switching works, but if you disconnect the headphones, an error appears when switching music

Share this post


Link to post
Share on other sites

A little understood the essence of the error:

Headphones are connected, I launch the player, the music plays and switches without problems. It is necessary to turn off the headphones, switch the track and there is an error. Similarly, if the speaker originally worked. With headphones, an error pops up when switching.

Share this post


Link to post
Share on other sites
On 2/16/2019 at 7:25 AM, Bunkley987 said:

Hello, here is the video of the bug. (My screen recorder does not capture audio)

Before I plug jack 3.5mm the player has no problem.
When I plug it display "Failed to play file!" and skip a piece to play next sound. Same problem when I unplug jack 3.5mm

To fix that I have to close Poweramp in the notification first and in the Task Manager last. (In the order or it will not fix)
After that I relaunch Poweramp (with aux 3.5mm connected or not) and it work fine until I un/plug them.

I tried to:

  • Rescan in the Poweramp app
  • Clear the data/cache of Poweramp
  • Uninstall/install Poweramp
  • Change the location to storage/Music

Info:

  • Poweramp version: v3-build-820-play
  • Phone: Meizu M3 Max
  • SD Card: Nothing
  • Android Version: 6.0
  • Rom (Default of Meizu Phone): Flyme 6.2.0.0G

In my case, the problem was solved by installing a trial version of Google Play. I bought the full version, everything is ok.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...