Jump to content
Poweramp
SHADOW-XIII

Scrobbling still broken!

Recommended Posts

Despite numerous reports during early v3 the scrobbling is still NOT working.

Using Simple Last.fm scrobbler 1.5.7 on BOTH V2 and V3 only V3 has the issue.

Interesting fact is that SLS shows sending scrobble but Last.fm does reject it (ignore), that points PA V3 is sending wrong/incorrect data.

 

The issue seems to happen only when playing song in "repeat 1" track mode.

The first time it plays the song (ie. after app start or after starting new song manually) it is scrobbled correctly. The second time song finishes, and any next one (from auto playing same track) it fails to scrobble correctly.

If I had to guess, V3 does not report metadata correctly, likely song times,ie. it reports track ended with wrong times?

Can this be looked at as priority?

 

 

Share this post


Link to post
Share on other sites

@andrewilley 

seems to have same or similar problems

 

bythe looks it scrobbled but stops when it gets unloaded from the memory by Android system and those scrobbles are lost sometimes after few tracks, sometimes misses few tracks and stars again, since the Last.fm app is fairly dated I guess it's not designed to work with latest Android. 

Such issue doesn't happen with SLS such keeps tracks internally, though scrobbling seems to be lost after sending it to the last.fm servers (SLS troubleshooting is suggesting data/metadata/timestamps etc that is being sent might be wrong)

Share this post


Link to post
Share on other sites

I hate to be "that guy", but I don't have this issue with v3. I did have scrobbling issues with the pre-release versions I tested, however, which is one reason I always reverted from the pre-release versions back to v2 until v3 came out. With v3, scrobbling has worked perfectly for me since it came out.

Details:

  • I have a Galaxy Note9 with Android 8.1.0. 
  • SLS v1.5.7
  • I have all battery conservation settings disabled for SLS.
  • Poweramp v3-build-820-play (Full Version) - It just updated to the new Play version. Scrobbling in the previous v3 release version worked just fine for me too.
  • "Scrobble via Simple Last.fm" is enabled

If you want to compare against any of my other settings, let me know.

Share this post


Link to post
Share on other sites

@danhash

are you listening tracks in Repeat Song mode? (ie. one track 20+ times)

For me it scrobbles first time in completes, but as it continues playing same song again, it's not scrobbled. 

It is sent by SLS every time (either then or when pushed manually), just second and consequituve plays do not appear on the Last.fm page, indicating it was rejected (ie. bad metadata/timestamps)

When using Repeat List mode, it seems fine

Share this post


Link to post
Share on other sites

I can see that song is being sent by SLS and on the page it appears "X minutes ago" where X is when the song started.

Therefore I am assuming that Poweramp is sending wrong timestamp of "when the song started" when playing Repeat Song mode,

Nearly sure, it sends the timestamp of the very first play with each consequituve plays, and that's why it's rejected/ignored by Last.fm

Would be nice if Max can take a look at code based on my above assumption

Share this post


Link to post
Share on other sites

When I listen to a song on repeat, it's scrobbled correctly each time it's played.

I have had a LOT of trouble with this in the past, with other scrobbling apps and with alpha/beta versions of Poweramp. But with the final version of v2 and the production versions of v3 I have not had this issue.

Share this post


Link to post
Share on other sites

I confirm that consecutively repeated tracks are not being scrobbled correctly.

I have some playlists that contain consecutive repetitions of the same track. In this scenario, only the first occurrence of a repeated track gets into the scrobble cache of my scrobbling app (Simple Last.fm Scrobbler). All subsequent consecutive occurrences of that track are ignored. This happens regardless of the setting in the "Notify now playing" option of the scrobbling app.

The problem seems to show up only when consecutive repetitions of a track appear in a playlist. If the repetitions are manually played, of if they are caused by Poweramp's "Repeat Song" option, then they are correctly scrobbled. 

In my setting, the problem started very recently -- about three or four days ago.

Details:
Poweramp v3-build-823-play (Full Version)
Simple Last.fm Scrobbler v1.5.7
Galaxy S8+ with Android 9
 

Share this post


Link to post
Share on other sites

managed to somewhat fix it by setting scrobbling by both official app (not installed) and simple last.fm 

and setting in Simple Last.fm all the apps it found, seems to be working now

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...