Jump to content
Poweramp
shmykelsa

Collection of bugs happening with Android Auto

Recommended Posts

  1. When the app is in Android Auto mode, even though my music library comprehend artist pretty much from A-Z it only loads a part of them (precisely: A to J). Shuffling all the tracks actually makes Poweramp play pretty much all the artists.                                  image.png.19f189962620b874db78f7cf5a3f38a9.png
  2. When the app is in Android Auto mode it follows the "Media channel audio stream" (I don't know if it is the precise name, but basically it is the volume you set when you adjust media sound in Android). This does not happen in all other players in Android Auto. I suppose Poweramp is designed to do so to have the ability of using EQ/Effects and stuff
  3. When adding a track to the queue, no title appears.image.thumb.png.59f022c4d92a1ee9d09b2f569fdd2e5d.pngimage.png.ebb2312e5b08faf0a2ed4ab007606e4e.png
  4. Music does not stop when disconnected from Android Auto

 

Poweramp build: v3-build-820-play

Phone model: LG V10 H960A

Android Version: 7.0

Android Auto version: 3.9.585064-release

Google Play Services: 14.7.99

Share this post


Link to post
Share on other sites

I'm having an issue where no audio is playing through my car stereo with Poweramp at all. It still works with all my other audio platforms (Apple Music, Google Play Music, Shuttle), but not Poweramp. The track will show that it's playing, but no audio comes out at all. I got it to work the first time I tried getting it to play, but ever since it's been silent. 

 

I feel like maybe I'm just missing something. Anyone have a fix?

Share this post


Link to post
Share on other sites
7 hours ago, mglassmoyer said:

I'm having an issue where no audio is playing through my car stereo with Poweramp at all. It still works with all my other audio platforms (Apple Music, Google Play Music, Shuttle), but not Poweramp. The track will show that it's playing, but no audio comes out at all. I got it to work the first time I tried getting it to play, but ever since it's been silent. 

 

I feel like maybe I'm just missing something. Anyone have a fix?

What are your Settings > Audio > Output ? Could you try to use another plugin ? Tried to disable DVC ?

Share this post


Link to post
Share on other sites

In addition to the above issues, I've also noticed that my equaliser and tone settings turn off when connected to Android Auto.

Share this post


Link to post
Share on other sites

I'm having the same issue. Android Auto is not seeing all of my music! At least half is missing. It was working fine, then I tried a voice search and half my albums disappeared!. They show in normal Poweramp but not in Android Auto.

Gutted

Share this post


Link to post
Share on other sites

I've also discovered that Album Art won't replicate on car's screen unless the screen is unlocked. Otherwise, a black baground will appear.

Share this post


Link to post
Share on other sites

Galaxy S9 with Android 8.0 and a Honda Civic 2017.

Using Android Auto, the volume for Poweramp is considerably lower than all my other AA players. Additionally, it enables the annoying, loud system sound that plays when switching tracks, and is the only AA app to do so.

Share this post


Link to post
Share on other sites
2 hours ago, Ceeneon said:

Galaxy S9 with Android 8.0 and a Honda Civic 2017.

Using Android Auto, the volume for Poweramp is considerably lower than all my other AA players. Additionally, it enables the annoying, loud system sound that plays when switching tracks, and is the only AA app to do so.

 

You should try to raise the volume via the volume rocker on the phone. Poweramp (as for now) relies on phone volume (as I mentioned on original post) even when connecting to Android Auto (and I think it should not).

As for the beep, it can be deactivated in Poweramp settings.

Share this post


Link to post
Share on other sites

Galaxy S9
Android 8.0
Android Auto v3.9.585064-release
PA v-3-build-820-play (full)

I'm getting inconstant playback when connected to AA.

Example 1: Plug phone in to AA, PA fires right up, I hit play and everything works as expected (except I have to turn the volume on the phone up). 

Example 2: Plug phone in to AA, when I hit the play button, the play button turns to the paused icon (indicating that it's playing), nothing happens for a few seconds and then the icon changes back to the play icon.  Nothing will play at all.

Example 3: Plug phone in to AA, it will fire up and play fine for a short time (like ~5 minutes) and then no sound.  The pause button is still there (indicating that it's playing?).  If I wait for a minute or so, it'll come back only to drop out again.  If I hit the pause button, the play button appears.  Hitting the play button again, I get the pause button and no sound until it feels like coming back.

I have tried this with several different mp3 files with the same inconsistent results.

Any help is much appreciated.

Share this post


Link to post
Share on other sites

@shmykelsa there is hard limit (==200 songs in Android Auto App, =20 items in headunit, but this may vary) per list, so if your list is larger, it's hard-limited and you won't get first symbols for whole list, obviously. Android Auto pushes Assistant / Voice search over touching your device, it seems.

Share this post


Link to post
Share on other sites

Hi @maxmp and thanks for the reply.

I'll start by saying that right now I have installed build 822, and sadly I have to report that most of the bugs that I've described in this thread are still affecting Poweramp.

On 3/19/2019 at 10:42 PM, maxmp said:

@shmykelsa there is hard limit (==200 songs in Android Auto App, =20 items in headunit, but this may vary) per list, so if your list is larger, it's hard-limited and you won't get first symbols for whole list

I'm aware of these limits about lists, but I reckon they are not what I'm talking about. These limits act when you actually press a letter on the list. 

By comparison, here's what happen when I use another player compatible with Android Auto and try to browse the artists by letter:

image.thumb.png.d13b6e3794fa645709aff2847d72b71a.png

Then if I press a letter, that limit will actually restrain the list.

Issues number 2 and 3 are still happening. Issue number 4 is fixed.

And this bug right here:

On 2/10/2019 at 4:14 PM, shmykelsa said:

I've also discovered that Album Art won't replicate on car's screen unless the screen is unlocked. Otherwise, a black baground will appear.

is still present.

On 3/19/2019 at 10:42 PM, maxmp said:

 Android Auto pushes Assistant / Voice search over touching your device, it seems.

I honestly don't know what you're talking about in here

 

Share this post


Link to post
Share on other sites

@shmykelsa thanks for details. The next build 823 includes following improvements regarding Auto:

- category lists limit is now 800 (sending more hits Android hard limits, so, for example, if you have > 800 artists, it won't fully load it anyway).
Note that Poweramp (or any other players) don't provide those A-Z symbols at all - this is extracted by Android Auto app from the whole list of items and I can see it can skip some characters sometimes, but this is out of Poweramp scope .
- cover is sent properly to Auto when screen is off

Let me know if you want to test this build earlier. Thanks!

Share this post


Link to post
Share on other sites
10 hours ago, maxmp said:

@shmykelsa thanks for details. The next build 823 includes following improvements regarding Auto:

- category lists limit is now 800 (sending more hits Android hard limits, so, for example, if you have > 800 artists, it won't fully load it anyway).
Note that Poweramp (or any other players) don't provide those A-Z symbols at all - this is extracted by Android Auto app from the whole list of items and I can see it can skip some characters sometimes, but this is out of Poweramp scope .
- cover is sent properly to Auto when screen is off

Let me know if you want to test this build earlier. Thanks!

Hey @maxmp thanks for addressing this issues. I would be more than happy to test the build and see the improvements in my car.

Share this post


Link to post
Share on other sites

Downloaded version 823

I can report that all the letters of artists now appear to me, and cover art too! 

The bug of adding a song to the queue remains @maxmp:

image.png.4a7362c99568d0f2fb18b3a5252efc23.png

 

and the issue of the media channel audio remains (but I might do a tasker out of it)

Share this post


Link to post
Share on other sites

Thanks for the detailed reports, these will be sorted out in the next builds.

Share this post


Link to post
Share on other sites

I'm not sure if this is a bug or not. I downloaded the latest version of the Poweramp app that's in beta. When using Android Auto in my 2017 Chevrolet Sonic (my phone is a Note8) the music plays through the phone instead of the car system. Unless I'm missing something I don't think this issue has been addressed.....

Share this post


Link to post
Share on other sites
4 hours ago, SuperAndroid17 said:

I'm not sure if this is a bug or not. I downloaded the latest version of the Poweramp app that's in beta. 

There are no public beta versions of PA at the moment. The latest public release version is 823, is that the one which are are referring to?

Andre

Share this post


Link to post
Share on other sites
5 hours ago, andrewilley said:

There are no public beta versions of PA at the moment. The latest public release version is 823, is that the one which are are referring to?

Andre

Sorry it was the public release version 823

Share this post


Link to post
Share on other sites
On 3/21/2019 at 10:29 PM, maxmp said:

@shmykelsa

- category lists limit is now 800 (sending more hits Android hard limits, so, for example, if you have > 800 artists, it won't fully load it anyway).
Note that Poweramp (or any other players) don't provide those A-Z symbols at all - this is extracted by Android Auto app from the whole list of items and I can see it can skip some characters sometimes, but this is out of Poweramp scope .

Hello, Can you still increase this limit to 1000 or more, please ? I'm interested in Poweramp's A to Z function, but I can not see all my albums: some letters are still not displayed with the 823 verson.

"OK Google" voice recognition is working poorly in my native language. It is very difficult / impossible to find an album by this way. Thank you.

My library :
Total Tracks: 12,600
Total Albums: 853
Total Artists: 474

Thank you

Share this post


Link to post
Share on other sites
5 minutes ago, Denony said:

Hello, Can you still increase this limit please 1500?

Max did say that 800 was a hard limit from Android, meaning anything more than that wouldn't load anyway.

Andre

Share this post


Link to post
Share on other sites
13 minutes ago, andrewilley said:

Max did say that 800 was a hard limit from Android, meaning anything more than that wouldn't load anyway.

Andre

Thank you for your reply.

Is there a way around this limit? For example, to make several categories of albums:

  • Albums A to F
  • Albums G to K
  • Albums P to R
  • ....

Regards

 

 

Share this post


Link to post
Share on other sites

The missing artist issue is still there. All albums are now showing but at least half of artists and even more tracks are still missing.

My artist count is much less than 800

Screenshot_20190324-202010.png

Share this post


Link to post
Share on other sites

Hi. Just joined the forum. I finding bugs on the full and latest version of the app (build 823). With the suggestion previously posted, I have sound when connected to my car. I have a Note 9, Pie 9 and the music installed on an SD card 512 GB. The car is a Ford F-150 2019. 

The bug I'm getting, not described before (that I can found), is that when I press play I can't go back and change my selection. I can do it in the phone. I'm attaching some photos. Thanks. 

 

PSX_20190329_135554.jpg

Share this post


Link to post
Share on other sites

I'm not sure I understand this 800 limit.

I'm having the issue of not seeing all the artists in my library. It's definitely way less than 800.  I'm using version 823.

What's the workaround?

Share this post


Link to post
Share on other sites

 

9 hours ago, thrak76 said:

I'm not sure I understand this 800 limit.

I'm having the issue of not seeing all the artists in my library. It's definitely way less than 800.  I'm using version 823.

What's the workaround?

I don't either. I have used several other players in the past and have had no issues with artists not showing

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...