Jump to content
SaGuppy

Poweramp keeps getting "killed"..?

Recommended Posts

I have the recent v3, build 816 version of PA installed on my Samsung Galaxy Note 9. And every time I use it, with the screen on standby, after a few minutes of play, it stops. This doesn't happen if the player itself is displaying. I get a pop up saying it was killed by a task killer/battery optimiser. I have no such task killer installed, and as you can see, I have the app itself removed from any battery saving function on my phone. I have wakelock enabled. Never had any problems on my S5 and S7 before, and been a long time fan. I'm at a loss now on how to prevent this from happening, and am seriously considering Neutron and it's god awful interface just for uninterrupted music. Any help would be much appreciated 

Share this post


Link to post
Share on other sites
35 minutes ago, SaGuppy said:

I have the recent v3, build 816 version of PA installed on my Samsung Galaxy Note 9. And every time I use it, with the screen on standby, after a few minutes of play, it stops. This doesn't happen if the player itself is displaying. I get a pop up saying it was killed by a task killer/battery optimiser. I have no such task killer installed, and as you can see, I have the app itself removed from any battery saving function on my phone. I have wakelock enabled. Never had any problems on my S5 and S7 before, and been a long time fan. I'm at a loss now on how to prevent this from happening, and am seriously considering Neutron and it's god awful interface just for uninterrupted music. Any help would be much appreciated 

On my S7 with Oreo I can choose  Apps which then won't be stopped , optimized etc by the operating system.

On Android open settings > device maintenance > battery > apps not optimized and add Poweramp.

The actual wording may differ, as I've set German language.

0172019151549.jpg

017201915212.jpg

Share this post


Link to post
Share on other sites

Having the same problem on my note 8 and I've also done all the battery stuff and it still does it. Sucks because I've been using this app sense i had a smart phone like 6 years. 

Share this post


Link to post
Share on other sites
12 minutes ago, OdTx75 said:

Having the same problem on my note 8 and I've also done all the battery stuff and it still does it. Sucks because I've been using this app sense i had a smart phone like 6 years. 

I know, it's a real ball ache!! Especially as its not clear whether this is a PA V3 bug, or an Android OS one! Bizarrely, I've just drove to Oxford and back today (2 hours each way, using PA via BT) and it's been fine. It also works fine with headphones/earphones while I'm using the phone, ie: with the screen on, but something is randomly killing the wired connection when the screen is in standby! Really frustrating. Tried emailing PA, but got zero help!! 😡😡😡 Very frustrating

Share this post


Link to post
Share on other sites

No kidding? I didn’t realize u were taking about a wired connection mine only does it on bt. I say never but I rarely if ever use it wired so it may also do it. I was starting think the problem was my equipment which is all Sony (can’t live without ldac) but I see on here it’s a common prob

Share this post


Link to post
Share on other sites
On 1/17/2019 at 2:46 PM, SaGuppy said:

This doesn't happen if the player itself is displaying. I get a pop up saying it was killed by a task killer/battery optimiser.

"Is displaying" means screen is off but the UI still on top ?

Could you provide a screenshot of the pop up ?

Share this post


Link to post
Share on other sites
9 hours ago, blaubär said:

"Is displaying" means screen is off but the UI still on top ?

Could you provide a screenshot of the pop up ?

I'll try to if and when it happens again. And yes I mean when the screen is off and just running the always on display, but Poweramp is still playing. 

Share this post


Link to post
Share on other sites
14 hours ago, OdTx75 said:

No kidding? I didn’t realize u were taking about a wired connection mine only does it on bt. I say never but I rarely if ever use it wired so it may also do it. I was starting think the problem was my equipment which is all Sony (can’t live without ldac) but I see on here it’s a common prob

Funnily enough, I've not had it happen during a BT connection, be it my Sony srs xb41, or connected to my car. Like I said yesterday, it went 2 hours to Oxford, and 2 hours back, with the phone screen off, without a single problem. For me, it's only stopped (been "killed") when listening through a wired connection, with the screen as below 

20190121_135705.jpg

Share this post


Link to post
Share on other sites
4 hours ago, andrewilley said:

Does this happen in any particular circumstances - running on battery vs on power, or lat ow battery levels, for example?

Andre

No. I'm not one for running my phone that low (rarely if ever below 50%). And it's always happened when mobile, so not with the phone plugged in, charging up

Share this post


Link to post
Share on other sites
On 1/21/2019 at 4:13 AM, blaubär said:

"Is displaying" means screen is off but the UI still on top ?

Could you provide a screenshot of the pop up ?

This is what pops up... 

Screenshot_20190126-162151_Poweramp.jpg

Share this post


Link to post
Share on other sites

my old Galaxy S Tab 8.4 has this problem . I'll have music playing while in bed and when i wake up it's not playing music anymore most the time.   I turned off all the battery optimizations.  This is using the aux cable. 

Share this post


Link to post
Share on other sites
On 1/18/2020 at 9:53 AM, Anirudh12 said:

Guys so what is the solution for the Poweramp getting killed?? What to do??

Have you ensured that all Android battery-saving and optimising features have been turned off with respect to Poweramp? Is there any pattern to when this happens - after a certain amount of time, playing certain files, etc? You could check the optimising issue by leaving it plugged in to power and turning the screen-sleep feature off (best to have the screen dimmed if it's amoled) and leaving PA playing with the screen on. 

Andre

Share this post


Link to post
Share on other sites

I have the same issue, it seems even with whitelisting PA in battery manager, the latter one kills it anyway. I've checked Wakelock in PA settings but it doesn't help. It kills while I'm doing something. When the PA only is active the battery manager doesn't kill it.

Files are in Flac or mp3

PA v3 860 Android10. Samsung Galaxy Note 9

Edited by NickIst

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...